Kodi Community Forum
[Project] Dual Audio Output support (Krypton/Jarvis/Isengard/Helix/Gotham/Frodo) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
--- Thread: [Project] Dual Audio Output support (Krypton/Jarvis/Isengard/Helix/Gotham/Frodo) (/showthread.php?tid=192480)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - extremeaudio - 2015-01-07

Thanks. Is there a link to disk image of rpi Helix build? I want to install using windows, so I can't use the tar file. Or does anyone know how to maybe create the iso from the tar files? Thanks in advance.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - mrdally204 - 2015-01-07

(2015-01-07, 11:42)extremeaudio Wrote: Thanks. Is there a link to disk image of rpi Helix build? I want to install using windows, so I can't use the tar file. Or does anyone know how to maybe create the iso from the tar files? Thanks in advance.

The Tar file is just compressed files, similar to zip. You can use a program such as 7zip on windows to extract the tar file and you will have what you need to build your RPI Helix. Good luck!


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ReMi - 2015-01-07

Rofl SUCCESS ! Rofl

Installed fresh KodiBuntu and done the steps as below and now Kodi-DA builds with success Nod

Code:
apt-get build-dep xbmc (on XBMCBuntu)
apt-get build-dep kodi (on KodiBuntu)
sudo apt-get install automake autopoint bison build-essential ccache cmake curl cvs default-jre fp-compiler gawk gdc gettext git-core gperf libasound2-dev libass-dev libavcodec-dev libavfilter-dev libavformat-dev libavutil-dev libbluetooth-dev libbluray-dev libbluray1 libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcec-dev libcec1 libcrystalhd-dev libcrystalhd3 libcurl3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libdbus-1-dev libenca-dev libflac-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev libltdl-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmp3lame-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpostproc-dev libpulse-dev libsamplerate-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libshairport-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libswscale-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libva-dev libva-egl1 libva-tpi1 libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite swig unzip yasm zip zlib1g-dev -y

cd /tmp
wget http://taglib.github.io/releases/taglib-1.9.1.tar.gz
tar xvzf taglib-1.9.1.tar.gz
cd taglib-1.9.1
cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_RELEASE_TYPE=Release .
./configure
make
make install

cd /tmp
git clone https://github.com/sahlberg/libnfs
cd libnfs
./bootstrap
./configure
make
make install

cd /tmp
git clone git://github.com/Pulse-Eight/libcec.git
cd libcec
./bootstrap
./configure
make
make install

cd /tmp
git clone https://github.com/xhbl/Kodi_dualaudio
cd Kodi_dualaudio/
git branch -v -a  [not required, but will show you what options (branches) are available]
git branch -t remotes/origin/Helix-DA
./bootstrap
./configure --prefix=/usr --enable-external-libraries
make
make install



RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - CrazyCanuck - 2015-01-07

Hi,

I do see there are existing builds for RPi by DarkAngel; however, I wanted to compile the newer Helix version myself but encountered issues. I am cross-compiling on a virtual Ubuntu 14.04 environment. I have successfully compiled Kodi without dual audio, but when trying to make the dual audio release I get a make error (using PROJECT=RPi ARCH=arm make release). Going through build output I noticed that I got a compilation error on DVDPlayerAudio.cpp. When examining that file I noticed that there is a patch applied for dual audio, but there is also a backport patch applied for RPi. The backport patch file was generated with no knowledge of dual audio changes I assume, so it appears that those patches are not being properly applied and subsequently causes compilation error (e.g. code change applied to wrong function). I made the change manually and ran make to start from where it crashed and it completed successfully, but I'm left to wonder if there are other issues there and they weren't detected by compiler. Also, I'm wondering if the dual audio patches should be applied in a different manner to ensure that it builds properly for all projects.

Thanks


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - reddevil - 2015-01-08

(2015-01-02, 08:35)xhbl Wrote: Development for Helix 14.0 and OpenELEC 5.0.0 was done, enjoy!

Thank You.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - DarkAngel2401 - 2015-01-08

(2015-01-07, 21:50)CrazyCanuck Wrote: ... but I'm left to wonder if there are other issues there and they weren't detected by compiler.
No compiling issues, but backport patch adds a new setting called "centerboost", which isn't available for 2nd audio engine/output. Rest of backport patches concern GUI, so this should the only missing setting which has to be integrated into backport patch file.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - CrazyCanuck - 2015-01-08

(2015-01-08, 19:13)DarkAngel2401 Wrote:
(2015-01-07, 21:50)CrazyCanuck Wrote: ... but I'm left to wonder if there are other issues there and they weren't detected by compiler.
No compiling issues, but backport patch adds a new setting called "centerboost", which isn't available for 2nd audio engine/output. Rest of backport patches concern GUI, so this should the only missing setting which has to be integrated into backport patch file.

Are you saying you are not having any compilation issues for RPi with the latest release of dual audio? If so, I'm at a loss to explain why I am. When I examined the CPP file that had an issue it appeared the backport patch was applied after dual audio patch and in so doing appeared to cause some mix-up and one of the backport changes was actually placed in the wrong section of the file which ultimately led to compilation to fail.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - algia71 - 2015-01-08

Hi All.

Thank you for your work on the "dual audio output" feature!

I installed OE 5 official on my new Cubox i4pro and then I discovered that I was not able to stream audio on both the HDMI output (linked to the TV set) and the S/PDIF output (linked to the DAC).

After some googling, I landed to this useful thread... Then I proceeded this way:
1) I downloaded the OpenELEC-imx6.arm.DA-5.0.0.tar image from openelec-dualaudio.subcarrier.de/OpenELEC-DualAudio/imx6.arm/
2) I put the image on the /Update/ SMB share of my cubox
3) I reboot the cubox via SSH command

After the reboot, the new image was found and automatically installed. After a second reboot, Kodi started, but... S/PDIF and HDMI still cannot stream audio in parallel :-(

Am I missing some additional conf step?

Thanks a lot for your support!

Alessandro


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - DarkAngel2401 - 2015-01-08

(2015-01-08, 20:00)CrazyCanuck Wrote: Are you saying you are not having any compilation issues for RPi with the latest release of dual audio?
No, I had the same compile error in DVDPlayerAudio.cpp, an "else if" was applied to the wrong method. A manual correction was a quick and dirty solution to solve that problem - just like you did.

After analyzing that backport patch file the second problem with missing "centerboost" handling for audiooutput2 came out - to be precise: there is no other compile error, but same handling for 2nd audio output like for main audio output isn't possible due to missing configuration parameter and code for that. In my opinion it's just a minor problem for now, so I just uploaded the binary for RPi.
For earlier OE 4.1.x and 4.2.x RPi builds the dual audio patch file had to be adjusted, too - so that special handling for RPi builds isn't very new to me.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - monobaco - 2015-01-08

(2015-01-07, 20:42)ReMi Wrote: Rofl SUCCESS ! Rofl

Installed fresh KodiBuntu and done the steps as below and now Kodi-DA builds with success Nod

Code:
apt-get build-dep xbmc (on XBMCBuntu)
apt-get build-dep kodi (on KodiBuntu)
sudo apt-get install automake autopoint bison build-essential ccache cmake curl cvs default-jre fp-compiler gawk gdc gettext git-core gperf libasound2-dev libass-dev libavcodec-dev libavfilter-dev libavformat-dev libavutil-dev libbluetooth-dev libbluray-dev libbluray1 libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcec-dev libcec1 libcrystalhd-dev libcrystalhd3 libcurl3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libdbus-1-dev libenca-dev libflac-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev libltdl-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmp3lame-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpostproc-dev libpulse-dev libsamplerate-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libshairport-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libswscale-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libva-dev libva-egl1 libva-tpi1 libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite swig unzip yasm zip zlib1g-dev -y

cd /tmp
wget http://taglib.github.io/releases/taglib-1.9.1.tar.gz
tar xvzf taglib-1.9.1.tar.gz
cd taglib-1.9.1
cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_RELEASE_TYPE=Release .
./configure
make
make install

cd /tmp
git clone https://github.com/sahlberg/libnfs
./bootstrap
./configure
make
make install

cd /tmp
git clone git://github.com/Pulse-Eight/libcec.git
./bootstrap
./configure
make
make install

cd /tmp
git clone https://github.com/xhbl/Kodi_dualaudio
cd Kodi_dualaudio/
git branch -v -a  [not required, but will show you what options (branches) are available]
git branch -t remotes/origin/Helix-DA
./bootstrap
./configure --prefix=/usr --enable-external-libraries
make
make install

Congrats!!

Sorry for my late response...


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - CrazyCanuck - 2015-01-08

(2015-01-08, 20:30)DarkAngel2401 Wrote: For earlier OE 4.1.x and 4.2.x RPi builds the dual audio patch file had to be adjusted, too - so that special handling for RPi builds isn't very new to me.

Ah ok. This is still new to me, and I thought I was doing something wrong as I didn't see anyone else mentioning any issues specific to RPi.


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - 2tonesp - 2015-01-09

I just wanted to thank you for your continued support of this much appreciated plugin. Updating to KODI now!


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - Peterhoeg - 2015-01-09

Hi, is there any chance that this will make it upstream and become part of Kodi?


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - Mettbrot - 2015-01-09

(2015-01-09, 08:51)Peterhoeg Wrote: Hi, is there any chance that this will make it upstream and become part of Kodi?

http://forum.kodi.tv/showthread.php?tid=192480&pid=1735951#pid1735951


RE: [Project] Return of the Dual Audio Output support (Helix/Gotham/Frodo) - ubuntu-xbmc - 2015-01-17

(2015-01-07, 03:54)DianeDrews Wrote: I just tried to build this a couple of different ways on Ubuntu 14.04 but i keep getting this error:

Copying kodi binary to /usr/local/lib/kodi/
install: cannot stat ‘kodi-xrandr’: No such file or directory
make: *** [install-binaries] Error 1

That's not enough info for someone help. The error you quote is likely resulting from an error in an earlier step. You should recreate the earlier error by compiling again, then share that error here. Clean out the current results with:

Code:
cd ~/Kodi_dualaudio/
make clean
git clean -xfd

the start from my step (6)

Code:
(6) ./bootstrap
(7) ./configure [I use ' ./configure --enable-external-libraries ' for Ubuntu]
(8) make
(9) sudo make install

Then carefully watch the results from each step. There will likely be some sort of error or failure that looks something like this:

Code:
PeripheralCecAdapter.cpp:1291:35: error: ‘CEC_CLIENT_VERSION_2_2_0’ was not declared in this scope
   m_configuration.clientVersion = CEC_CLIENT_VERSION_2_2_0;
                                   ^
In file included from /root/Kodi_dualaudio/xbmc/guilib/GUIControl.h:30:0,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIControlGroup.h:28,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIWindow.h:31,
                 from /root/Kodi_dualaudio/xbmc/guilib/GUIDialog.h:28,
                 from /root/Kodi_dualaudio/xbmc/dialogs/GUIDialogKaiToast.h:23,
                 from PeripheralCecAdapter.cpp:29:
/root/Kodi_dualaudio/xbmc/guilib/GraphicContext.h: At global scope:
/root/Kodi_dualaudio/xbmc/guilib/GraphicContext.h:288:150: warning: ‘g_graphicsContext’ defined but not used [-Wunused-variable]
XBMC_GLOBAL(CGraphicContext,g_graphicsContext);
                                                                                                                                                      ^
make[1]: *** [PeripheralCecAdapter.o] Error 1
make: *** [xbmc/peripherals/devices/peripheral-devices.a] Error 2

This example is from ReMi, but it appears to be a common error for people compiling Helix for the first time. It shows that CEC was missing from his machine. If you post an error like this, someone will probably have an idea how to fix it.


This forum uses Lukasz Tkacz MyBB addons.