Kodi Community Forum
Release [SteamOS] Kodi repository - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Tips, tricks, and step by step guides (https://forum.kodi.tv/forumdisplay.php?fid=110)
--- Thread: Release [SteamOS] Kodi repository (/showthread.php?tid=197422)

Pages: 1 2 3 4 5 6 7 8 9 10


RE: [SteamOS] Xbmc repository beta testing - teeedubb - 2014-10-15

Ah OK, its probably a XBMC mapping issue - check the log when you press some buttons.

BTW, how is the controller? I joined the hardware beta but its US only Sad


RE: [SteamOS] Xbmc repository beta testing - Nerdy3.14159265 - 2014-10-15

(2014-10-15, 00:08)teeedubb Wrote: Ah OK, its probably a XBMC mapping issue - check the log when you press some buttons.

BTW, how is the controller? I joined the hardware beta but its US only Sad

I'll check the log when I get the chance but it doesn't seem like it's having errors just that it's recognizing the keys weirdly.
I can navigate around with the left trackpad (which is arrow keys) and the right trackpad (which is mouse movement) but most of the actual button presses come up as numbers and other random things.

Also:
It's okay. We only received the first version of the controller so I haven't tried the newer models yet.

The right trackpad works fine for mouse movement, the only issue I really have with the controller is the left trackpad.
For movement you need something that tells you where your heading a little easier, so I'm happy they are adding a joystick on that side.


RE: [SteamOS] Xbmc repository - duhmojo - 2014-10-19

Hey guys.

Anyone get a MCE remote working with XBMC in SteamOS? I have a NUC D34010 (the i3 model with the IR sensor included) and my MCE remote will work with both SteamOS big picture and XBMC only for navigation. (up/down/left/right) Everything else doesn't work. No OK/Enter, Back, etc...

I have no clue where to start. I looked into /usr/share/sbmc/system/Lircmap.xml and remote.xml. Doesn't matter what I change, naturally, because only the navigation buttons seem to be making their way through. irw and lirc don't seem to be available in the standard SteamOS and XBMC repos. Any tools included with XBMC I can use to test what inputs are being received?

Thanks!


RE: [SteamOS] Xbmc repository - duhmojo - 2014-10-19

Ok I turned on debug in the XBMC UI, exited and started again. I've got a ~/.xbmc/temp/xbmc.log that notes the input keys. I can clearly see OnKey and Keyboard scan codes for buttons I pushed. e.g. "play_pause", "return", etc... with actions like "select", etc...

How are these guys not hooked up?

Looking at the xbmc.log there's a "Failed to connect to LIRC." but at the "Loading special://xbmc/system/Lircmap.xml" I can clearly see that all the devices in Lircmap.xml are being loaded. e.g. "mceusb", etc...

Any ideas? Thanks.

Quick note, Back, Info and the Green button show up as "OnKey: 0 (0xf200)".

The "return" key has an action of "select" but nothing happens in XBMC. Sigh...


RE: [SteamOS] Xbmc repository - pdffs - 2014-10-31

(2014-10-19, 06:11)duhmojo Wrote: Sigh...

Did you try reading the wiki at all? There are definitely pages that explain exactly how to enable your remote correctly.


RE: [SteamOS] Xbmc repository - Diazz - 2014-11-05

I'm sorry for this extremely nubish question but i have NO understand of linux distro's etc.

"create /etc/apt/preferences"

This does not work for me, i only get "command not found" And if i skip it, since it says "optional" i get

"E: Unable to correct problems, you have held broken packages."

Thank you


RE: [SteamOS] Xbmc repository - fritsch - 2014-11-05

You have to create that file(!)

You really typed "create /etc/apt/preferences" into the shell?


RE: [SteamOS] Xbmc repository - Diazz - 2014-11-05

Yes i did, and i'm guessing "create" isn't a valid command?

Edit: I found the solution eventually, if this is correct?

sudo nano /etc/apt/preferences


RE: [SteamOS] Xbmc repository - wsnipex - 2014-11-05

yes, that will work


RE: [SteamOS] Xbmc repository - stupot333 - 2014-11-18

Has anyone managed or even tried to install tvheadend service (backend)? If so, please post a how to. This would be the ideal solution for a all-in-one HTPC/Gaming(console)/Quad tuner satellite receiver. It would be a real game changer for sure. Big Grin


RE: [SteamOS] Xbmc repository - orstig - 2014-12-30

I run steamOS with xbmc from http://mirrors.xbmc.org/apt/steamos.
I have one problem DTS passthrough doesn't work (Dolby Digital does), in log: FactoryCodec - Audio: passthrough - Failed
is this a kodi/xbmc bug or is it my hardware (nvidia gtx770)?


RE: [SteamOS] Xbmc repository - tendonut - 2015-01-15

Is this repository getting updated anymore? I haven't seen any changes since maybe August.


RE: [SteamOS] Xbmc repository - wsnipex - 2015-01-15

it will be once 14.1 is ready


RE: [SteamOS] Xbmc repository - tendonut - 2015-01-16

OK, I was concerned when 14.0 was released and I never received the updates on my SteamOS box. I take it you're just going straight to 14.1?


RE: [SteamOS] Xbmc repository - wsnipex - 2015-01-31

14.1 is now available in the repository.
upgrade steps:
Code:
sudo apt-get update
sudo apt-get dist-upgrade



This forum uses Lukasz Tkacz MyBB addons.