Kodi Community Forum
Release [SteamOS] Kodi repository - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Tips, tricks, and step by step guides (https://forum.kodi.tv/forumdisplay.php?fid=110)
--- Thread: Release [SteamOS] Kodi repository (/showthread.php?tid=197422)

Pages: 1 2 3 4 5 6 7 8 9 10


RE: [SteamOS] Kodi repository - wsnipex - 2015-08-09

yes, we've already established that changes in alchemist and definitely brewmaster broke it.
Since I still don't have a replacement for my steamOS hardware, there is nothing I can do.


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-08-13

If there is any way I can test things for you, I will do whatever you need.

Hardware: https://pcpartpicker.com/b/bMHNnQ


RE: [SteamOS] Kodi repository - DanCooper - 2015-08-22

(2015-08-09, 10:02)wsnipex Wrote: yes, we've already established that changes in alchemist and definitely brewmaster broke it.
Since I still don't have a replacement for my steamOS hardware, there is nothing I can do.
What do you need to repair your Steam Maschine? Is it an original Steam Maschine or a custom PC with SteamOS?


RE: [SteamOS] Kodi repository - arndt - 2015-09-04

(2015-08-09, 10:02)wsnipex Wrote: yes, we've already established that changes in alchemist and definitely brewmaster broke it.
Since I still don't have a replacement for my steamOS hardware, there is nothing I can do.

Anything new on this? Maybe someone could help?


RE: [SteamOS] Kodi repository - LupinSansei - 2015-09-16

Anyone have any luck getting Kodi to install on Brewmaster yet?

*Edit* I'm using Stephenson's Rocket 26 in 1 plus Kodi which works great but it's Kodi 14.1 :/

Also anyone had any luck getting an RC-6 MCE remote working in Steamos?


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-19

I've been repacking this for package.libregeek.org. Most apt-get source --build packages are looking ok, but when I try to perform a build of kodi, I get

Code:
[email protected]:~/SteamOS-Tools/utilities/build-scripts$ apt-get source --build kodi
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Picking 'kodi-dmo' as source package instead of 'kodi'
E: Unable to find a source package for kodi-dmo

What source package name should I be specifying? I have the hardware to test this on, and a repository.


RE: [SteamOS] Kodi repository - Juppstein - 2015-09-21

Since we are slowy setting sail to Jarvis' Island and the version of Kodi that actually runs fine on SteamOS is starting to get some age spots, is there something we can do to fix the current lack of fixes? Can we donate a small box to serve as a SteamOS machine (i.e. something like an Intel NUC) ? Or is there something else we can do? I'd hate to lose Kodi on SteamOS once either Valve or Kodi mandate an update in the future.


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-21

I have a working script to build from source right now. I am working on getting deb(s) built from that with either the default debian build script the XBMC/Kodi team has in the 2nd link below, or using pbuilder. Until I get that sorted out (help is always welcome), you can build from source. Please do head the warnings in the disclaimer and do a proper backup. Make sure you choose to add the Debian sources when running the main script for the first time.

Code:
sudo apt-get install git
git clone https://github.com/ProfessorKaos64/SteamOS-Tools
cd SteamOS-Tools/
./desktop-software.sh install kodi-src



RE: [SteamOS] Kodi repository - wsnipex - 2015-09-23

Sorry guys, still no change on the hardware front.
As for building from source: did you try the debian packaging script we provide already: https://github.com/xbmc/xbmc/tree/master/tools/Linux/packaging


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-23

Wsnipex, I am doing a build right now.

However, it seems that even though I have 'libbluray-dev' and 'libbluray1' on SteamOS brewmaster (sourcing from deb multimedia), it seems the "Checking for LIBBLURAY...no" package error occurs. This does not occur when building from source. I did submit a PR to xbmc-packaging, since libgnutls28-dev serves the purpose of the only package allowed in the control file, libgnutls-dev. After Wheezy, the package name seems to have changed. To work around this, I have a "hot-swap" in to change to my fork of xbmc-packaging, since entire fork of xbmc/xbmc is not necessary and actually fails on build of the source code (maybe hardcoded paths to the kodi team repo).

Can you confirm the package versions of libbluray-dev and libbluray1? Currently, apt-cache policy shows '2:0.7.0-dmo1' for all packages. If you have a PPA you can direct me to, or a source build in git/xbmc et. all, I can try to package this and put it in my packages.libregeek.repo to satisfy the LIBBLURAY...no configure failure on building the package. I am very willing to go the extra mile here with getting this packaged. I have a Debian repository ready to host this already. When I get home, I can attach a build log.

I think my hint is within this forum post I am still reviewing: http://forum.kodi.tv/showthread.php?tid=80754

Build script:
https://github.com/ProfessorKaos64/SteamOS-Tools/blob/brewmaster/utilities/build-scripts/build-kodi-src.sh

PR:
https://github.com/xbmc/xbmc-packaging/pull/23

Software list:
https://github.com/ProfessorKaos64/SteamOS-Tools/blob/brewmaster/cfgs/software-lists/kodi-src.txt

Jessie package search on libbluray:
https://packages.debian.org/search?suite=all&section=all&arch=any&searchon=names&keywords=libbluray


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-23

I found out what was going on. Will update this post config soon.

I was able to configure successfully by copying /usr/lib/x86_64-linux-gnu/pkgconfig to /usr/lib, and running:
Code:
export PKG_CONFIG_PATH=/usr/lib/pkgconfig
./configure  --enable-libbluray

I am currently rebuilding Kodi again to see if a clean build will work with ...

/usr/lib/x86_64-linux-gnu/pkgconfig **vs** /usr/lib (The tile fight of the century?)


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-24

Restored my machine to do a clean run...ugh

Code:
[email protected]:~/kodi$ sudo find / -name libbluray.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/libbluray.pc

export PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig
./configure --enable-libbluray

.......

checking for LIBBLURAY... no



RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-24

I did get bluray support to work. Apparently deb-multimedia was just a bit too old. I rebuilt the ubuntu vivid package and installed the libbluray-dev package. worked like a charm, no PKG_CONFIG_PATH needed. './configure --enable-libbluray' worked like a charm. Building an trying a deb creation set now.


RE: [SteamOS] Kodi repository - wsnipex - 2015-09-24

do yourself a favor and stay away from deb-multimedia. All needed depends are in our ubuntu nightly ppa see my sig.


RE: [SteamOS] Kodi repository - ProfessorKaos64 - 2015-09-24

I will remove deb-multimedia out of my repo soon. The Ubuntu packages superseded them in apt preferences I have set. I do however get a ton of Lintian messages after a big compile. I skipped (as you saw on git) Apple Airport being enabled. I may need a bit of help just adjusting my build script to make that work. Once that is done, it is Lintian cleanup I think. Closer to my goal, so thank you very much Wsnipex. I'll post the lintian errors later today.


This forum uses Lukasz Tkacz MyBB addons.