Kodi Community Forum
Release Experimental Google Music Addon - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Release Experimental Google Music Addon (/showthread.php?tid=200640)



RE: Experimental Google Music Addon - jarredduq - 2016-11-08

I'm getting errors when launching the addon. I'm running Kodi v17 Beta 5. Errors from log below:

16:23:25 T:6152 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.googlemusic.exp/
16:23:25 T:6152 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.googlemusic.exp/) failed
16:24:27 T:9668 WARNING: CSkinInfo: failed to load skin settings
16:25:50 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] ARGV: ['plugin://plugin.audio.googlemusic.exp/', '2', '']
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Initing addon data
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Loading library
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Loading auth from cache
16:25:54 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Chunk Size: 1000
16:26:00 T:3364 NOTICE: Previous line repeats 4 times.
16:26:00 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Chunk Size: 922
16:26:01 T:3364 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'gmusicapi.exceptions.CallFailure'>
Error Contents: ListPlaylists: 500 Server Error: Internal Server Error for url: https://mclients.googleapis.com/sj/v2.5/playlistfeed?tier=fr&hl=en_US&include-tracks=true&dv=0&alt=json&updated-min=0


RE: Experimental Google Music Addon - foreverguest - 2016-11-08

(2016-11-08, 02:32)jarredduq Wrote: I'm getting errors when launching the addon. I'm running Kodi v17 Beta 5. Errors from log below:

16:23:25 T:6152 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.googlemusic.exp/
16:23:25 T:6152 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.googlemusic.exp/) failed
16:24:27 T:9668 WARNING: CSkinInfo: failed to load skin settings
16:25:50 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] ARGV: ['plugin://plugin.audio.googlemusic.exp/', '2', '']
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Initing addon data
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Loading library
16:25:53 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Loading auth from cache
16:25:54 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Chunk Size: 1000
16:26:00 T:3364 NOTICE: Previous line repeats 4 times.
16:26:00 T:3364 NOTICE: [GoogleMusicEXP-1.10.6] Chunk Size: 922
16:26:01 T:3364 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'gmusicapi.exceptions.CallFailure'>
Error Contents: ListPlaylists: 500 Server Error: Internal Server Error for url: https://mclients.googleapis.com/sj/v2.5/playlistfeed?tier=fr&hl=en_US&include-tracks=true&dv=0&alt=json&updated-min=0

Please provide full log, your cut doesn't provide enough info.


RE: Experimental Google Music Addon - m23439 - 2016-11-14

Would appreciate some help. The addon loads my library fine. However for every track that I try to play, I get an error. The error that i see in my log says"NEWADDON Unknown Music Info Key "mediatype". Log attached below:

http://pastebin.com/Li6U89xP

Thanks


RE: Experimental Google Music Addon - foreverguest - 2016-11-15

Actually your error is: "LookupError: no codec search functions registered: can't find encoding"

This is related to OpenElec/LibreElec version, please try another version. See coment http://forum.kodi.tv/showthread.php?tid=200640&pid=2412892#pid2412892


RE: Experimental Google Music Addon - anhstar - 2016-11-18

Hello, thanks for the nice addon.
I discover the addon recently and can see it's great potential.
I installed the addon and use an App password login from google.
I do have many songs that I uploaded to Google Play Music, but I cannot see those in the addon.
When I open the addon, I can only see 2 options: Listen Now, Browse Stations.
I have the free google play music account. Did not pay anything.
Is that why?

Thanks in advance


RE: Experimental Google Music Addon - Gregoire - 2016-11-20

I love the Youtube function. It's pretty good! If you'd extend on that it will probably be the only youtube addon I'd use.


RE: Experimental Google Music Addon - nb2a - 2016-11-29

I would like to thank the OP for this great add on. I can at least view and play my own songs. When I try to do anything else no good. I also would love to see the You Tube feature but do not see how to find it. I will try to see how I can load this on a LibreElec machine next.


RE: Experimental Google Music Addon - nb2a - 2016-11-30

Does anyone know how I can add this to LibreElec please?


RE: Experimental Google Music Addon - foreverguest - 2016-12-05

(2016-11-18, 17:00)anhstar Wrote: Hello, thanks for the nice addon.
I discover the addon recently and can see it's great potential.
I installed the addon and use an App password login from google.
I do have many songs that I uploaded to Google Play Music, but I cannot see those in the addon.
When I open the addon, I can only see 2 options: Listen Now, Browse Stations.
I have the free google play music account. Did not pay anything.
Is that why?

Thanks in advance

This happens because the addon couldn't find your online library, please check kodi.log for errors and double check if your user/password is correct.


RE: Experimental Google Music Addon - foreverguest - 2016-12-05

(2016-11-29, 05:00)nb2a Wrote: I would like to thank the OP for this great add on. I can at least view and play my own songs. When I try to do anything else no good. I also would love to see the You Tube feature but do not see how to find it. I will try to see how I can load this on a LibreElec machine next.

Could you explain whats is failing for you? Have you checked file kodi.log for errors?

Youtube actions are triggered by song/playlist/etc context menu options.

To install in LibreElec download/copy the addon zip (link in first post) in your LibreElec device and follow instructions from wiki http://kodi.wiki/view/HOW-TO:Install_add-ons_from_zip_files.


RE: Experimental Google Music Addon - tomjr78 - 2016-12-09

I am a long time Google Music subscriber and the job you did on this addon is is stellar! Thanks!


RE: Experimental Google Music Addon - PROF FAART - 2016-12-15

First: I cannot believe how well this addon works. I'm using two-factor and had no problems setting up and logging on.

But: There is just one thing preventing it from being perfect and I think it's just because I don't know where the button is.

Is there any way to manually refresh a certain list? Say "My Library" or even sub-lists like "Artists" or "Playlists"? I see in settings that you can have it refresh every hour. But for me, the ideal way to use this would be to look up something on my phone or laptop in Google Music, add it to My Library or a playlist and then grab the remote and play it in Kodi.

But I added a couple albums to My Library about 15 minutes ago and the addon is still only showing the Albums and Artists that I had when I first started the addon. I've tried the context menu, the view options menu, the addon settings, and I cannot see a way to manually refresh. This is on Jarvis using the Eminence 2.0 skin.

Thanks again for the addon.

Edit: I finally tried "Clear Cache," which I had assumed was just the downloaded music stream cache, and it seems to have forced a refresh. Is this the official way to refresh?

Edit2: I kept on poking around in the thread by searching for "cache" and found your post about context menu on My Library > Update Library. So never mind, now it's perfect.

FYI: Chorus2 web interface seems to work perfectly with this, even gets thumbnails, so now I can run the whole thing "headless."


RE: Experimental Google Music Addon - sudaltsov - 2016-12-18

I have many albums in Google, and basically half (or more) of them ... not working with 'Play All' menu item. And that it consistent: if album A works, it always works, if album B does not - it never does. Just nothing happens - just menu closes. No errors in kodi.log files, just silence. Some example from the log:
Code:
11:14:50 T:139863433103104  NOTICE: [GoogleMusicEXP-1.10.6]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '-1', '?action=play_all&filter_type=genre&filter_criteria=%27%5Cxd0%5Cx9f%5Cxd0%5Cxb5%5Cxd1%5Cx81%5Cxd0%5Cxbd%5Cxd0%5Cxb8+%5Cxd0%5Cx91%5Cxd1%5Cx83%5Cxd0%5Cxbb%5Cxd0%5Cxb0%5Cxd1%5Cx82%5Cxd0%5Cxb0+%5Cxd0%5Cx9e%5Cxd0%5Cxba%5Cxd1%5Cx83%5Cxd0%5Cxb4%5Cxd0%5Cxb6%5Cxd0%5Cxb0%5Cxd0%5Cxb2%5Cxd1%5Cx8b%27&artist=%27%5Cxd0%5Cx90%5Cxd0%5Cxbd%5Cxd0%5Cxb4%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxb9+%5Cxd0%5Cx9c%5Cxd0%5Cxb0%5Cxd0%5Cxba%5Cxd0%5Cxb0%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxb2%5Cxd0%5Cxb8%5Cxd1%5Cx87+%5Cxd0%5Cxb8+%5Cxd0%5Cx9e%5Cxd1%5Cx80%5Cxd0%5Cxba%5Cxd0%5Cxb5%5Cxd1%5Cx81%5Cxd1%5Cx82%5Cxd1%5Cx80+%5Cxd0%5Cx9a%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxbe%5Cxd0%5Cxbb%5Cxd1%5Cx8c%5Cxd1%5Cx81%5Cxd0%5Cxba%5Cxd0%5Cxbe%5Cxd0%5Cxb3%5Cxd0%5Cxbe+%5Cxd0%5Cxa2%5Cxd0%5Cxb0%5Cxd0%5Cxbd%5Cxd0%5Cxb3%5Cxd0%5Cxbe%27']
11:14:50 T:139863433103104  NOTICE: [GoogleMusicEXP-1.10.6] ### storage getfiltersongs: 'genre' "'\\xd0\\x9f\\xd0\\xb5\\xd1\\x81\\xd0\\xbd\\xd0\\xb8 \\xd0\\x91\\xd1\\x83\\xd0\\xbb\\xd0\\xb0\\xd1\\x82\\xd0\\xb0 \\xd0\\x9e\\xd0\\xba\\xd1\\x83\\xd0\\xb4\\xd0\\xb6\\xd0\\xb0\\xd0\\xb2\\xd1\\x8b'" "'\\xd0\\x90\\xd0\\xbd\\xd0\\xb4\\xd1\\x80\\xd0\\xb5\\xd0\\xb9 \\xd0\\x9c\\xd0\\xb0\\xd0\\xba\\xd0\\xb0\\xd1\\x80\\xd0\\xb5\\xd0\\xb2\\xd0\\xb8\\xd1\\x87 \\xd0\\xb8 \\xd0\\x9e\\xd1\\x80\\xd0\\xba\\xd0\\xb5\\xd1\\x81\\xd1\\x82\\xd1\\x80 \\xd0\\x9a\\xd1\\x80\\xd0\\xb5\\xd0\\xbe\\xd0\\xbb\\xd1\\x8c\\xd1\\x81\\xd0\\xba\\xd0\\xbe\\xd0\\xb3\\xd0\\xbe \\xd0\\xa2\\xd0\\xb0\\xd0\\xbd\\xd0\\xb3\\xd0\\xbe'"
Any advice?
Additional question: why doesn't "I'm feeling lucky mix" have "Play All" menu item at all? How can I start it?
Thank you for the great work! Keep it up!


RE: Experimental Google Music Addon - foreverguest - 2016-12-19

(2016-12-18, 13:23)sudaltsov Wrote: I have many albums in Google, and basically half (or more) of them ... not working with 'Play All' menu item. And that it consistent: if album A works, it always works, if album B does not - it never does. Just nothing happens - just menu closes. No errors in kodi.log files, just silence. Some example from the log:
Code:
11:14:50 T:139863433103104  NOTICE: [GoogleMusicEXP-1.10.6]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '-1', '?action=play_all&filter_type=genre&filter_criteria=%27%5Cxd0%5Cx9f%5Cxd0%5Cxb5%5Cxd1%5Cx81%5Cxd0%5Cxbd%5Cxd0%5Cxb8+%5Cxd0%5Cx91%5Cxd1%5Cx83%5Cxd0%5Cxbb%5Cxd0%5Cxb0%5Cxd1%5Cx82%5Cxd0%5Cxb0+%5Cxd0%5Cx9e%5Cxd0%5Cxba%5Cxd1%5Cx83%5Cxd0%5Cxb4%5Cxd0%5Cxb6%5Cxd0%5Cxb0%5Cxd0%5Cxb2%5Cxd1%5Cx8b%27&artist=%27%5Cxd0%5Cx90%5Cxd0%5Cxbd%5Cxd0%5Cxb4%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxb9+%5Cxd0%5Cx9c%5Cxd0%5Cxb0%5Cxd0%5Cxba%5Cxd0%5Cxb0%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxb2%5Cxd0%5Cxb8%5Cxd1%5Cx87+%5Cxd0%5Cxb8+%5Cxd0%5Cx9e%5Cxd1%5Cx80%5Cxd0%5Cxba%5Cxd0%5Cxb5%5Cxd1%5Cx81%5Cxd1%5Cx82%5Cxd1%5Cx80+%5Cxd0%5Cx9a%5Cxd1%5Cx80%5Cxd0%5Cxb5%5Cxd0%5Cxbe%5Cxd0%5Cxbb%5Cxd1%5Cx8c%5Cxd1%5Cx81%5Cxd0%5Cxba%5Cxd0%5Cxbe%5Cxd0%5Cxb3%5Cxd0%5Cxbe+%5Cxd0%5Cxa2%5Cxd0%5Cxb0%5Cxd0%5Cxbd%5Cxd0%5Cxb3%5Cxd0%5Cxbe%27']
11:14:50 T:139863433103104  NOTICE: [GoogleMusicEXP-1.10.6] ### storage getfiltersongs: 'genre' "'\\xd0\\x9f\\xd0\\xb5\\xd1\\x81\\xd0\\xbd\\xd0\\xb8 \\xd0\\x91\\xd1\\x83\\xd0\\xbb\\xd0\\xb0\\xd1\\x82\\xd0\\xb0 \\xd0\\x9e\\xd0\\xba\\xd1\\x83\\xd0\\xb4\\xd0\\xb6\\xd0\\xb0\\xd0\\xb2\\xd1\\x8b'" "'\\xd0\\x90\\xd0\\xbd\\xd0\\xb4\\xd1\\x80\\xd0\\xb5\\xd0\\xb9 \\xd0\\x9c\\xd0\\xb0\\xd0\\xba\\xd0\\xb0\\xd1\\x80\\xd0\\xb5\\xd0\\xb2\\xd0\\xb8\\xd1\\x87 \\xd0\\xb8 \\xd0\\x9e\\xd1\\x80\\xd0\\xba\\xd0\\xb5\\xd1\\x81\\xd1\\x82\\xd1\\x80 \\xd0\\x9a\\xd1\\x80\\xd0\\xb5\\xd0\\xbe\\xd0\\xbb\\xd1\\x8c\\xd1\\x81\\xd0\\xba\\xd0\\xbe\\xd0\\xb3\\xd0\\xbe \\xd0\\xa2\\xd0\\xb0\\xd0\\xbd\\xd0\\xb3\\xd0\\xbe'"
Any advice?
Additional question: why doesn't "I'm feeling lucky mix" have "Play All" menu item at all? How can I start it?
Thank you for the great work! Keep it up!

Have you notice if the albums failing have any special character or non-latin character? It seems to be some king of character encoding error.
Just forgot to add that option to 'I'm feeling luck', you can just start playing the first song and it will play all the list.


RE: Experimental Google Music Addon - sudaltsov - 2016-12-19

(2016-12-19, 14:52)foreverguest Wrote: Have you notice if the albums failing have any special character or non-latin character? It seems to be some king of character encoding error.
Just forgot to add that option to 'I'm feeling luck', you can just start playing the first song and it will play all the list.
No, that happens to both non-latin and latin albums. I will get the sample of the latin one later.
Thanks for the hint about 'play all'


This forum uses Lukasz Tkacz MyBB addons.