Kodi Community Forum
Release [Windows] Kodi - Texture Tool (.xbt) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Skinning (https://forum.kodi.tv/forumdisplay.php?fid=12)
+---- Forum: Skin helper addons (https://forum.kodi.tv/forumdisplay.php?fid=300)
---- Thread: Release [Windows] Kodi - Texture Tool (.xbt) (/showthread.php?tid=201883)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20


RE: [Windows] Kodi - Texture Tool (.xbt) - extremeaudio - 2016-05-19

Ok, tried killing the cmd process and now we have a finite amount of time for the program. Thanks for that, but the decompression part is now creating blacnk folders.


RE: [Windows] Kodi - Texture Tool (.xbt) - extremeaudio - 2016-05-19

Uh, now its doing something altogether unexpected. If I run it, it says update available and then the exe turns into a 1kb file !


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-05-19

you have to wait until the update process is done.
or ...

just take the latest version from the first site.


RE: [Windows] Kodi - Texture Tool (.xbt) - CellarDoorTV - 2016-05-22

Hi there. I am trying to compile my media, done all the steps with no spaces but at the end of the process it says 0kb. Any idea what's going wrong? Thank you.


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-05-23

Version 2.6.5

- TexturePacker 1.1.1 (available since yesterday on file host)
- new check for decompile/compile status
- Visual C++ Redistributable for Visual Studio 2015 hint at first start


RE: [Windows] Kodi - Texture Tool (.xbt) - Raze - 2016-05-23

(2016-05-23, 14:37)supp Wrote: Version 2.6.5

- TexturePacker 1.1.1 (available since yesterday on file host)
- new check for decompile/compile status
- Visual C++ Redistributable for Visual Studio 2015 hint at first start

Thanks for your work on this.

~Raze


RE: [Windows] Kodi - Texture Tool (.xbt) - extremeaudio - 2016-05-24

Here's what I am trying to do. I have unpacked the textures.xml of an existing skin. I am able to access the files in it. I changed just one image (for checking purposes) to a different one of same file type and resolution. And then used this very tool to repack it. The minute I copy the new file to the skin location a few other things like the main menu etc appear mis aligned, as though the compiling part is corrupting some other files. Can anyone probably figure out how to check / avoid this?


RE: [Windows] Kodi - Texture Tool (.xbt) - bl4ckd14mond - 2016-05-26

Auto updated to latest version, which now does not 'recompile' ... left it running and nothing Huh?

update....sorted lol


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-05-26

is vcredist installed on your system? which issue are you facing? empty folder?


RE: [Windows] Kodi - Texture Tool (.xbt) - Durex - 2016-05-27

I can decompile. However, unable to compile. All I get is an empty folder when I try to compile a file back to .xbt


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-05-31

Version 2.7.0

- fixxed running command for texturepacker
- included log function at tool directory
- submit log function to thread

Version 2.7.1

- complete new update function including progressbar
- vcredist check in log
- extended loglevel
- Traytip string changes


RE: [Windows] Kodi - Texture Tool (.xbt) - autodiagalgerie - 2016-06-01

Hi
I'm a bit confused
The decomplition works fine
But when I try to compile I get an empty folder
no errors! !!Huh
any ideas
Please


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-06-02

(2016-06-01, 23:14)autodiagalgerie Wrote: Hi
I'm a bit confused
The decomplition works fine
But when I try to compile I get an empty folder
no errors! !!Huh
any ideas
Please
Can you upload ur log file pls?


RE: [Windows] Kodi - Texture Tool (.xbt) - z_dane - 2016-06-02

******************Program start*****************
Current Time: 2016.06.01-13:39:47
Running Version: 2.7.1
RegRead: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\10.0\VC\VCRedist\x86: 1
13:39:48: TexturePacker Version: 1.1.1.0
13:39:48: Update function started.
13:39:48: No update found!
13:39:49: Compile Mode started.
13:40:01: Directory is fine.
13:40:01: Path to directory: C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures
13:40:13: Directory is fine.
13:40:13: Path to output file: C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures.xbt
13:40:14: Running command:TexturePacker -input C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures -output C:\Users\z_dane\AppData\Roaming\Kodi\addons\skin.aeon.nox.5\media\Textures.xbt
13:40:15: TexturePacker.exe running.
13:40:15: TexturePacker.exe closed.
******************Closed by User*****************

same issue can't compile. no error but empty folder.


RE: [Windows] Kodi - Texture Tool (.xbt) - supp - 2016-06-02

Seems that TexturePacker is only running for 1 sec. That might be the Problem here. In the log there is the running Command. Go to %Temp% and open a cmd window. Texturepacker is located there. Copy the Command in there and take a Look at the output

Gesendet von meinem Nexus 5 mit Tapatalk


This forum uses Lukasz Tkacz MyBB addons.