Kodi Community Forum
Release SoundCloud - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Release SoundCloud (/showthread.php?tid=206635)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13


RE: SoundCloud - Jackojmi - 2020-01-28

(2020-01-27, 20:45)jay.kody Wrote:
(2020-01-27, 01:36)Jackojmi Wrote: Hi,
Hope I'm posting in the right place- the last few weeks send soundcloud track to kodi, from Yatse remote, Android phone, is not working. Both from app and browser (YouTube, podcasts etc still work,).

Anyone else experiencing this?

Hi! I just tested this on my Android phone from the SoundCloud website and from the SoundCloud app. Sharing works for me (Yatse and Kore).
Is there any error that pops up? Are you using the latest plugin version?
Yes, latest version of plug in and Yatse/soundcloud/browser app. I'm on Libreelec. The error is from Yatse helper and say "could not resolve shared URL"
Cheers
Log here:
http://ix.io/28yf
And http://ix.io/28yH
Sorry have not posted logs before, don't know what I'm doing


RE: SoundCloud - jay.kody - 2020-01-28

(2020-01-28, 11:31)Jackojmi Wrote: Yes, latest version of plug in and Yatse/soundcloud/browser app. I'm on Libreelec. The error is from Yatse helper and say "could not resolve shared URL"
Cheers
Log here:
http://ix.io/28yf
And http://ix.io/28yH
Sorry have not posted logs before, don't know what I'm doing 

 Please disable the Yatse helper in Kodi and try again. Maybe it's a bug in https://github.com/Tolriq/repository.yatse.kodi.


RE: SoundCloud - Jackojmi - 2020-01-28

(2020-01-28, 19:25)jay.kody Wrote:
(2020-01-28, 11:31)Jackojmi Wrote: Yes, latest version of plug in and Yatse/soundcloud/browser app. I'm on Libreelec. The error is from Yatse helper and say "could not resolve shared URL"
Cheers
Log here:
http://ix.io/28yf
And http://ix.io/28yH
Sorry have not posted logs before, don't know what I'm doing 

 Please disable the Yatse helper in Kodi and try again. Maybe it's a bug in https://github.com/Tolriq/repository.yatse.kodi.

Ah yes that has worked! (though disabling the Yatse helper stops YouTube etc working).
Sorry my bad, I didn't think of that.
thanks for the speedy support, this addon is used daily here.
I'll report the Yatse bug.


RE: SoundCloud - Jackojmi - 2020-01-31

(2020-01-28, 23:28)Jackojmi Wrote:
(2020-01-28, 19:25)jay.kody Wrote:
(2020-01-28, 11:31)Jackojmi Wrote: Yes, latest version of plug in and Yatse/soundcloud/browser app. I'm on Libreelec. The error is from Yatse helper and say "could not resolve shared URL"
Cheers
Log here:
http://ix.io/28yf
And http://ix.io/28yH
Sorry have not posted logs before, don't know what I'm doing 

 Please disable the Yatse helper in Kodi and try again. Maybe it's a bug in https://github.com/Tolriq/repository.yatse.kodi.

Ah yes that has worked! (though disabling the Yatse helper stops YouTube etc working).
Sorry my bad, I didn't think of that.
thanks for the speedy support, this addon is used daily here.
I'll report the Yatse bug.

I reported this to Yatse developer, who quickly updated the Youtubedl, which has fixed the problem for me. No longer need to disable Yatse Helper to send soundcloud to kodi.
Thanks.


SoundCloud - MB1968 - 2020-03-27

@jay.kodi I'm experiencing problems with playlistst containing more than 100-150 files. The addon displays the last 5 files from the playlist.

I've set items per page to 50. Any idea what causes this? Let me know if you need a logfile.

Thanks in advance.


RE: SoundCloud - jay.kody - 2020-03-27

(2020-03-27, 16:33)MB1968 Wrote: @jay.kodi I'm experiencing problems with playlistst containing more than 100 files. The addon displays the last 5 files from the playlist.

I've set items per page to 50. Any idea what causes this? Let me know if you need a logfile.

Thanks in advance.
Can you tell me which playlist this is (or give me an example playlist with the described issue)? I'll try to recreate and debug it.


RE: SoundCloud - MB1968 - 2020-03-27

(2020-03-27, 19:51)jay.kody Wrote:
(2020-03-27, 16:33)MB1968 Wrote: @jay.kodi I'm experiencing problems with playlistst containing more than 100 files. The addon displays the last 5 files from the playlist.

I've set items per page to 50. Any idea what causes this? Let me know if you need a logfile.

Thanks in advance.
Can you tell me which playlist this is (or give me an example playlist with the described issue)? I'll try to recreate and debug it.
I use custom playlists. For example, I follow Joris Voorn on SoundCloud. Every week I add a new episode of Joris Voorn's show Spectrum Radio to my custom playlist.
https://soundcloud.com/joris-voorn/sets/spectrum-radio-by-joris-voorn

I think you should be able to reproduce the problem by creating a custom playlist and adding 150 files randomly to the playlist.


RE: SoundCloud - jay.kody - 2020-03-30

(2020-03-27, 22:32)MB1968 Wrote: I use custom playlists. For example, I follow Joris Voorn on SoundCloud. Every week I add a new episode of Joris Voorn's show Spectrum Radio to my custom playlist.
https://soundcloud.com/joris-voorn/sets/spectrum-radio-by-joris-voorn

I think you should be able to reproduce the problem by creating a custom playlist and adding 150 files randomly to the playlist. 

This issue affects all playlists with more than 50 items. Thanks for reporting.
Fix is submitted to repository: https://github.com/xbmc/repo-plugins/pull/2796


RE: SoundCloud - MB1968 - 2020-03-31

(2020-03-30, 22:57)jay.kody Wrote:
(2020-03-27, 22:32)MB1968 Wrote: I use custom playlists. For example, I follow Joris Voorn on SoundCloud. Every week I add a new episode of Joris Voorn's show Spectrum Radio to my custom playlist.
https://soundcloud.com/joris-voorn/sets/spectrum-radio-by-joris-voorn

I think you should be able to reproduce the problem by creating a custom playlist and adding 150 files randomly to the playlist. 

This issue affects all playlists with more than 50 items. Thanks for reporting.
Fix is submitted to repository: https://github.com/xbmc/repo-plugins/pull/2796
Thanks for the quick fix.


RE: SoundCloud - vogelmann - 2020-05-02

I think I wrote this earlier in this thread already, but a big THANK YOU for releasing this add-on.
Though I cannot directly access my likes and tracks (screw you SC, what am I paying you for?!), search helps big time and I can find everything I am looking for.

What had been driving me nuts for a while: Tracks stopped/switched to the next after half an hour. Which really sucks when you listen to a lot of techno sets like I do.
Yesterday was actually the first day ever I checked this plug-in's Wiki page - and what did I see? https://kodi.wiki/view/Add-on:SoundCloud#Audio_format
Yes, I should have just set the audio format to "mp3 (progressive)" and now everything is working like a charm...

Leaving this comment here in case someone else is experiencing this problem. (:


RE: SoundCloud - understatement - 2020-05-26

(2020-05-02, 10:58)vogelmann Wrote: Leaving this comment here in case someone else is experiencing this problem. (:
Thank you! I was having this problem and didn't know how to resolve it. Glad you posted your resolution!


RE: SoundCloud - stahlwollschaf - 2020-12-23

(2019-07-20, 08:33)blackride Wrote: hi guys.
Please tell me how i can get my id_client?
Hello,

I have the same problem. Installed V3.2.0 from the repo. Google says that a wizard should appear at first start, but ist didn't (on 2 different RP3)
How can I start the wizard? Or get the client id?
I want to login with my account. BTW: is it possible?

best regards, stahlwollschaf


RE: SoundCloud - jay.kody - 2020-12-23

(2020-12-23, 02:06)stahlwollschaf Wrote: I have the same problem. Installed V3.2.0 from the repo. Google says that a wizard should appear at first start, but ist didn't (on 2 different RP3)
How can I start the wizard? Or get the client id?
I want to login with my account. BTW: is it possible?

Since v3 there is no more setup wizard. Login is not yet implemented: https://github.com/jaylinski/kodi-addon-soundcloud/issues/40


RE: SoundCloud - stahlwollschaf - 2020-12-24

(2020-12-23, 13:48)jay.kody Wrote:
(2020-12-23, 02:06)stahlwollschaf Wrote: I have the same problem. Installed V3.2.0 from the repo. Google says that a wizard should appear at first start, but ist didn't (on 2 different RP3)
How can I start the wizard? Or get the client id?
I want to login with my account. BTW: is it possible?

Since v3 there is no more setup wizard. Login is not yet implemented: https://github.com/jaylinski/kodi-addon-soundcloud/issues/40
Hi, thank you. So I don't have to do the research anymore Smile Is it correct that this feature is planned for a later version 3.3? Would be fine...

best regards, stahlwollschaf


This forum uses Lukasz Tkacz MyBB addons.