Kodi Community Forum
Release SoundCloud - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Release SoundCloud (/showthread.php?tid=206635)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13


RE: SoundCloud - bromix - 2015-08-31

Version 2.0.2 (2015-08-31)
[fix] add missing fanart


RE: SoundCloud - nielsvans - 2015-09-19

Hello,

I can't login to my SoundCloud anymore.
I am using my email adres and password but I get an error: "invalid_client"
Tried deleting the complete addon and cache.
Also deleted addon_data folder.

Nothing seems to help.

Log:
16:52:09 T:3148 NOTICE: Thread FileCache start, auto delete: false
16:52:09 T:688 ERROR: XFILE::CDirectory::GetDirectory - Error getting addons://repository.xbmc.org/
16:52:09 T:688 ERROR: CGUIMediaWindow::GetDirectory(addons://repository.xbmc.org/) failed
16:52:09 T:2428 NOTICE: Thread BackgroundLoader start, auto delete: false
16:52:09 T:3724 NOTICE: Thread FileCache start, auto delete: false
16:52:10 T:1400 NOTICE: Thread BackgroundLoader start, auto delete: false
16:52:26 T:3156 NOTICE: Previous line repeats 2 times.
16:52:26 T:3156 NOTICE: Thread FileCache start, auto delete: false
16:52:26 T:3428 NOTICE: Thread BackgroundLoader start, auto delete: false
16:52:41 T:3176 NOTICE: Previous line repeats 1 times.
16:52:41 T:3176 NOTICE: Thread LanguageInvoker start, auto delete: false
16:52:41 T:3176 NOTICE: -->Python Interpreter Initialized<--
16:52:41 T:3176 NOTICE: [plugin.audio.soundcloud] Running: SoundCloud (2.0.2) on Isengard (15.1) with Python (2.7.8)
16:52:43 T:3176 NOTICE: [plugin.audio.soundcloud] Running View Manager for skin "skin.kaosbox.helix"
16:52:43 T:3176 NOTICE: [plugin.audio.soundcloud] Skin "skin.kaosbox.helix" not support
16:53:34 T:688 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.soundcloud/
16:53:34 T:688 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.soundcloud/) failed
16:53:34 T:3832 NOTICE: Thread BackgroundLoader start, auto delete: false
16:53:36 T:2536 NOTICE: Thread JobWorker start, auto delete: true
16:53:37 T:2768 NOTICE: Thread BackgroundLoader start, auto delete: false
16:53:37 T:680 NOTICE: Previous line repeats 1 times.
16:53:37 T:680 NOTICE: Thread JobWorker start, auto delete: true
16:53:38 T:1408 NOTICE: Thread LanguageInvoker start, auto delete: false
16:53:38 T:1408 NOTICE: -->Python Interpreter Initialized<--
16:53:38 T:1408 NOTICE: [plugin.audio.soundcloud] Running: SoundCloud (2.0.2) on Isengard (15.1) with Python (2.7.8)
17:00:09 T:688 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.soundcloud/
17:00:09 T:688 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.soundcloud/) failed
17:00:09 T:3080 NOTICE: Thread BackgroundLoader start, auto delete: false
17:00:09 T:3784 NOTICE: Previous line repeats 1 times.
17:00:09 T:3784 NOTICE: Thread JobWorker start, auto delete: true
17:00:10 T:3920 NOTICE: Thread LanguageInvoker start, auto delete: false
17:00:10 T:3920 NOTICE: -->Python Interpreter Initialized<--
17:00:10 T:3920 NOTICE: [plugin.audio.soundcloud] Running: SoundCloud (2.0.2) on Isengard (15.1) with Python (2.7.8)
17:00:10 T:2656 NOTICE: Thread BackgroundLoader start, auto delete: false
17:00:38 T:3112 NOTICE: Previous line repeats 1 times.
17:00:38 T:3112 NOTICE: Thread JobWorker start, auto delete: true
17:00:41 T:2840 NOTICE: Previous line repeats 1 times.
17:00:41 T:2840 NOTICE: Thread LanguageInvoker start, auto delete: false
17:00:41 T:688 ERROR: Control 50 in window 10501 has been asked to focus, but it can't
17:00:41 T:2840 NOTICE: -->Python Interpreter Initialized<--
17:00:41 T:2840 NOTICE: [plugin.audio.soundcloud] Running: SoundCloud (2.0.2) on Isengard (15.1) with Python (2.7.8)
17:00:58 T:688 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.soundcloud/
17:00:58 T:688 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.soundcloud/) failed
17:00:58 T:1340 NOTICE: Thread BackgroundLoader start, auto delete: false
17:01:01 T:1788 NOTICE: Previous line repeats 1 times.
17:01:01 T:1788 NOTICE: Thread LanguageInvoker start, auto delete: false
17:01:01 T:1788 NOTICE: -->Python Interpreter Initialized<--
17:01:05 T:3508 NOTICE: Thread BackgroundLoader start, auto delete: false
17:01:07 T:2452 NOTICE: Thread LanguageInvoker start, auto delete: false
17:01:07 T:2452 NOTICE: -->Python Interpreter Initialized<--
17:01:07 T:2452 NOTICE: Kodi Log Uploader: started


RE: SoundCloud - bromix - 2015-09-19

Some strange characters in your password or username? If so try to change them. Please provide logs in the future via pastebin.com or similar. It's hard to read without formatting.


RE: SoundCloud - nielsvans - 2015-09-19

Hi Bromix,

There are no strange characters in my username or password.
Only "@", letters and numbers.


RE: SoundCloud - bromix - 2015-09-19

Strange, I've tested my login with special and normal characters and all works fine. I can't reproduce the issue right now Sad


RE: SoundCloud - nielsvans - 2015-09-20

Okay, I will try to find out for myself. Thank you so far.


RE: SoundCloud - bromix - 2015-09-20

(2015-09-20, 13:20)nielsvans Wrote: Okay, I will try to find out for myself. Thank you so far.

Found the problem Smile

Version 2.0.3 (2015-09-20)
[add] Hebrew (thx 2 smoky-jr)
[fix] skip incomplete items (bug of SoundCloud)
[fix] login


RE: SoundCloud - Mathes75 - 2015-09-21

Thanks bromix for very quick solving the issue. Love this AddOn!


RE: SoundCloud - nielsvans - 2015-09-21

Great! Thank you!


RE: SoundCloud - ThaProZac - 2015-11-26

Hi.

So I might have a problem that is far outside any support or code bug fix, but just installed my new Shield Android TV and can't get the Soundcloud to work. Tried first with the original plugin for android by copying the .apk from a computer with a USB drive but no such luck.

Then I figured the Soundcloud in Kodi should work no matter what, but no such luck. I have used it on everything else, PC, Pi and tablets, but not on Shield tv. The addon will install but can't run it by simply pressing the addon.
If I go into my addons trough settings and try to launch it from there I will get the main login screen up, log in, but then unable to navigate. Any possibility for a fix for this? Can be helpful with debug logs and anything else thats needed, decent with fault searching, but when it comes to the coding itself I'm kinda lost.

Tried to navigate with normal Shield remote, the gaming remote and keyboard/mouse, same problem, nothing happends when I click any buttons.

Tnx in advance for any info or tips.


RE: SoundCloud - bromix - 2015-11-26

(2015-11-26, 16:15)ThaProZac Wrote: Hi.

So I might have a problem that is far outside any support or code bug fix, but just installed my new Shield Android TV and can't get the Soundcloud to work. Tried first with the original plugin for android by copying the .apk from a computer with a USB drive but no such luck.

Then I figured the Soundcloud in Kodi should work no matter what, but no such luck. I have used it on everything else, PC, Pi and tablets, but not on Shield tv. The addon will install but can't run it by simply pressing the addon.
If I go into my addons trough settings and try to launch it from there I will get the main login screen up, log in, but then unable to navigate. Any possibility for a fix for this? Can be helpful with debug logs and anything else thats needed, decent with fault searching, but when it comes to the coding itself I'm kinda lost.

Tried to navigate with normal Shield remote, the gameing remote and keyboard/mouse, same problem, nothing happends when I click any buttons.

Tnx in advance for any info or tips.

debug_log (wiki)


RE: SoundCloud - ThaProZac - 2015-11-26

(2015-11-26, 16:20)bromix Wrote:
(2015-11-26, 16:15)ThaProZac Wrote: Hi.

So I might have a problem that is far outside any support or code bug fix, but just installed my new Shield Android TV and can't get the Soundcloud to work. Tried first with the original plugin for android by copying the .apk from a computer with a USB drive but no such luck.

Then I figured the Soundcloud in Kodi should work no matter what, but no such luck. I have used it on everything else, PC, Pi and tablets, but not on Shield tv. The addon will install but can't run it by simply pressing the addon.
If I go into my addons trough settings and try to launch it from there I will get the main login screen up, log in, but then unable to navigate. Any possibility for a fix for this? Can be helpful with debug logs and anything else thats needed, decent with fault searching, but when it comes to the coding itself I'm kinda lost.

Tried to navigate with normal Shield remote, the gameing remote and keyboard/mouse, same problem, nothing happends when I click any buttons.

Tnx in advance for any info or tips.

debug_log (wiki)

At work now, home in an hour or so, il post it then Smile


RE: SoundCloud - ThaProZac - 2015-11-26

(2015-11-26, 16:20)bromix Wrote:
(2015-11-26, 16:15)ThaProZac Wrote: Hi.

So I might have a problem that is far outside any support or code bug fix, but just installed my new Shield Android TV and can't get the Soundcloud to work. Tried first with the original plugin for android by copying the .apk from a computer with a USB drive but no such luck.

Then I figured the Soundcloud in Kodi should work no matter what, but no such luck. I have used it on everything else, PC, Pi and tablets, but not on Shield tv. The addon will install but can't run it by simply pressing the addon.
If I go into my addons trough settings and try to launch it from there I will get the main login screen up, log in, but then unable to navigate. Any possibility for a fix for this? Can be helpful with debug logs and anything else thats needed, decent with fault searching, but when it comes to the coding itself I'm kinda lost.

Tried to navigate with normal Shield remote, the gameing remote and keyboard/mouse, same problem, nothing happends when I click any buttons.

Tnx in advance for any info or tips.

debug_log (wiki)

Ok so finally got a debug log, dam overtime hehe.Tried to navigate with normal Shield remote, the gaming remote and keyboard/mouse, same problem, nothing happends when I click any buttons except I can move up and down the meny, but when I click any of the items nothing happends. It does flicker like it think's something should happend, but nothing does.
Let me know if you need anything else.
http://pastebin.com/gaZeNpa3

Got a bit long for some reason it started to do stuff I didn't tell it too, but hope you get what you need.


RE: SoundCloud - bromix - 2015-11-26

Strange...I see you being in the root menu of SoundCloud...but from there nothing more Sad Python 2.6.X is a little bit old, but shouldn't be the problem. So, as soon as you try to navigate into one of the root items, the addon or box freezes?

On all your other platforms the addon works?


RE: SoundCloud - ThaProZac - 2015-11-26

(2015-11-26, 19:49)bromix Wrote: Strange...I see you being in the root menu of SoundCloud...but from there nothing more Sad Python 2.6.X is a little bit old, but shouldn't be the problem. So, as soon as you try to navigate into one of the root items, the addon or box freezes?

On all your other platforms the addon works?

Nothing freezes, I just can't enter any of the menus in Soundcloud. I see the ..., the Search and the Explore, but when I select either i just flashes a milli sec but nothing else happends. I can move up, down, go back to menu(with the back button, not the ... button, and I can't go in to Search or Explore. Click it, and nothing happends. The log from above is just with the remote for Shield ATV, but I get the same response with any remote I try.


This forum uses Lukasz Tkacz MyBB addons.