Kodi Community Forum
[RELEASE] Amazon Prime Instant Video (US/UK/DE) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: [RELEASE] Amazon Prime Instant Video (US/UK/DE) (/showthread.php?tid=215255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - KeithLM - 2015-04-26

Will this work in the US on linux? Every video I try and open fails. Are there extra actions needed to get this to work on linux? I installed chrome and flash, but I haven't run them separately. Does this actually call out to chrome to play videos? Here's the error I get:
Quote:21:57:22 T:139714185328384 NOTICE: Thread LanguageInvoker start, auto delete: false
21:57:22 T:139714185328384 NOTICE: -->Python Interpreter Initialized<--
21:57:24 T:139714185328384 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.IndexError'>
Error Contents: list index out of range
Traceback (most recent call last):
File "/home/keith/.kodi/addons/plugin.video.prime_instant/default.py", line 1078, in <module>
playVideo(url, selectQuality=="true")
File "/home/keith/.kodi/addons/plugin.video.prime_instant/default.py", line 628, in playVideo
content = opener.open('https://'+apiMain+'.amazon.com/cdp/catalog/GetStreamingUrlSets?
version=1&format=json&firmware=WIN%2011,7,700,224%20PlugIn&marketplaceID='+urllib.quote_plus(matchMID[0])+'&
token='+urllib.quote_plus(matchToken[0])+'&deviceTypeID='+urllib.quote_plus(matchDID[0])+'&asin='+videoID+'&
customerID='+urllib.quote_plus(matchCID[0])+'&deviceID='+urllib.quote_plus(matchCID[0])+str(int(time.time()*1000))+videoID).read()
IndexError: list index out of range
-->End of Python script error report<--
21:57:24 T:139716772648896 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.prime_instant/?url=B00KMGZPRK&mode=playVideo&name=I%27ll+Follow+You+Down&thumb=http%3A%2F%2Fecx.images-amazon.com%2Fimages%2FI%2F5112mwP2RUL.jpg]
21:57:24 T:139714185328384 NOTICE: Thread BackgroundLoader start, auto delete: false
21:57:27 T:139714185328384 NOTICE: Thread LanguageInvoker start, auto delete: false
21:57:27 T:139714185328384 NOTICE: -->Python Interpreter Initialized<--
21:57:27 T:139715731953408 NOTICE: Thread BackgroundLoader start, auto delete: false



RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - awmt102 - 2015-04-26

Hi All,

I have been enjoying using this plugin for several months. I encountered the problem at beginning of April regarding Amazons website changes and fixed it with the updated default.py. However I am now experiencing a different problem (it may be similar the one others have recently experienced, although their descriptions are not very clear).

Basically I can browse all the shows as normal however when I click to play one the "Opening Stgream" box appears, then disappears; "Working" appears in the bottom corner then the video looks like it is about to start but it is just a black video displayed behind the Kodi menu. The timing counter does increase (albeit in a jumpy way) but no video ever plays.

This appears to persist for a number of videos, although I have not tried a lot of them. The strange thing is that if I reboot my Raspberry Pi2 and try again the video appears to work again on the first play, but any subsequent plays (and plays of any other video) do not work.

Does anyone know why this may be?

Thanks

Andy


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - regnodulous - 2015-04-26

Same here. It'd been happening for about three days. Anyone know what's going on. Exactly the same symptoms as Andy. Thanks nat


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - jpl8910 - 2015-04-26

Anybody running into download 0% when trying to install the addon?


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - Hitcher - 2015-04-26

Mirrors are playing up right now.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - aNILEator - 2015-04-26

Yes I experience the same I also see the play pause state switching rapidly when the stream doesn't load


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - hdmkv - 2015-04-26

Does the Bluecop version of Amazon still work? Has been a long while since I tried it.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - skywurz - 2015-04-27

I tried bluecop bit it said it was incompatible so i could not install it probably b/c its broken
i have just swapped to using playon instead i hate that i had to pay for it but my main file server is a windows server so running the service on that was not a big deal for me


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - adenno - 2015-04-27

(2015-04-26, 09:27)awmt102 Wrote: […]I have been enjoying using this plugin for several months. I encountered the problem at beginning of April regarding Amazons website changes and fixed it with the updated default.py. However I am now experiencing a different problem (it may be similar the one others have recently experienced, although their descriptions are not very clear).[…]

(2015-04-26, 18:04)regnodulous Wrote: Same here. It'd been happening for about three days. Anyone know what's going on. Exactly the same symptoms as Andy. Thanks nat

Same here. Is it an amazon or an addon issue? Tried several alternative default.py's...


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-04-27

(2015-04-27, 02:22)skywurz Wrote: I tried bluecop bit it said it was incompatible so i could not install it probably b/c its broken
i have just swapped to using playon instead i hate that i had to pay for it but my main file server is a windows server so running the service on that was not a big deal for me

I'll be honest... I've just switched to several of the less than legal addons simply because the legit services apparently do not want my business. I still pay for Amazon simply because of the Prime shipping, but I rarely use their VoD service. PlayOn is ok in a pinch, but the poor video and sound quality and the inability to skip forward and in many cases, resume, just makes it too annoying to deal with...

Edit: Please do not message me to ask "which addons?" Google is your friend.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - Nellgrove - 2015-04-28

anyone found a fix for this? I've just signed up for prime so only just found the add on Smile


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - AshG - 2015-04-28

(2015-04-14, 10:37)AshG Wrote:
(2015-04-13, 22:48)hdmkv Wrote: For RPi2 w/OpenELEC, would I just do install from zip and use the zip in post #1, then what do I do with one in post #177? And, FileZilla is necessary for which part? Thanks.

Ok, so you'll need to download the zip in post #1 somewhere so it's accessible for Kodi to install, my OpenElec can see a shared drive, so i just dropped it in there, I then did a "install from Zip" and navigated to the file. This will then install the Amazon prime addon. However, the addon as it stands is broken, so you'll need to replace a file with the file in post #177.

Next, and this presumes you have some kind other local Windows machine (there's many other ways of doing it), you'll need download the zip in post #177, unzip the file to the desktop - it should be a default.py file. then use FileZilla (or any other FTP client) - logging into openelec using : default username: root, password: openelec, and using the RPi IP address to move and replace the current default.py in /storage/.kodi/addons/plugin.video.prime_instant.

That should sort it for yer.....

Doing the above, then deleting the addon16.db worked for me, I wouldn't say it properly fixed e.g mywatch list is empty and won't populate with new videos, but I can at least watch them...


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - Nellgrove - 2015-04-28

Hi. Where is the 'addon16.db' file?


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - AshG - 2015-04-28

I can't remember the full path and can't check as I'm at work, but off the top of my head it's something like : userdata/addons/


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - AshG - 2015-04-28

(2015-04-28, 11:25)AshG Wrote: I can't remember the full path and can't check as I'm at work, but off the top of my head it's something like : userdata/addons/

By the way, I have no idea why this works or ultimately what effects this has to kodi and other addons, I'll let someone far more intelligent than me to comment whether this is a good idea or not.... But so far I havnt noticed any adverse effects...

edit: tested it tonight, and it looks likes it not working..


This forum uses Lukasz Tkacz MyBB addons.