Kodi Community Forum
[RELEASE] Amazon Prime Instant Video (US/UK/DE) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: [RELEASE] Amazon Prime Instant Video (US/UK/DE) (/showthread.php?tid=215255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-05-15

(2015-05-13, 02:03)okidokios Wrote: Hello from north america I'm using the one from the repo dosen't work on movies just tv series and all the series stream at 720p hd could you can fix it please

This is what I am seeing (in the U.S.) as well...


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-05-15

(2015-05-14, 00:14)toejam Wrote: Oh wow, I didn't realize that the newest patched versions of this add-on had abandoned rtmp and are now using the progressive http mechanism employed by alternative platforms such as kindle/fire, ios, android or others. So now, rtmp swfvfy 2 is irrelevant. I'll have to give this another try now.

Does this mean there is hope for Netflix and Hulu?


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - dsevern - 2015-05-15

I installed this add-on, but it never prompts me to enter my Amazon Prime account information.

I can search for movies/tv shows, but it doesn't show me my Watchlist.

I tried uninstalling the add-on and the repository and re-installing but I get the same result.

I'm running Kodi 14.2 for Android on a Matricom G box.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - chapterslol - 2015-05-16

same issue as previous poster, except at one point it did prompt me to login and everything worked fine, but suddenly it is no longer logged in and will not ask for login details Confused


If i attempt UK or DE it askks for login, but not US


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - ga_mueller - 2015-05-16

Looks nice, but as noted (US Win7) no place to login and not prompted to do so...

Back to crappy PlayOn, I guess.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - toejam - 2015-05-16

Same here, no prompting for credentials for a US account, and no way to set them manually.

Edit: I sorted it all out. Now it is good enough. It could use some cdn detection logic for the US.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - mikefreeman - 2015-05-16

I'm trying Lordk's new version. How do I enter my login info? There's nothing in the settings, and it doesn't ask me for it at any point -- even after clearing the cache and cookies. However, when I try to play something it tells me I'm not logged in and to "check my credentials". But how?!

Also, before I put any more effort into this, is this version able to play in the U.S. yet? If not, I'll just give up now.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - chapterslol - 2015-05-16

it played for me yesterday in the US before giving me an issue then suddenly no more login or prompt for it


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-05-16

I entered my login information manually into the settings.xml and it has saved fine. Its not the most secure option but it works.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - alexalien - 2015-05-16

Hi,

Version 1.0.2 on Isengard 15.0beta1 is not working for me :-(

DE Login works, Browsing Content works, but starting a Video fails with this ERROR (from the logs):

Code:
20:26:42 T:3688   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
    Error Type: <type 'exceptions.IndexError'>
    Error Contents: list index out of range
    Traceback (most recent call last):
        File "E:\Kodi\portable_data\addons\plugin.video.prime_instant\default.py", line 1078, in <module>
            playVideo(url, selectQuality=="true")
        File "E:\Kodi\portable_data\addons\plugin.video.prime_instant\default.py", line 628, in playVideo
            content = opener.open('https://'+apiMain+'.amazon.com/cdp/catalog/GetStreamingUrlSets?version=1&format=json&firmware=WIN%2011,7,700,224%20PlugIn&marketplaceID='+urllib.quote_plus(matchMID[0])+'&token='+urllib.quote_plus(matchToken[0])+'&deviceTypeID='+urllib.quote_plus(matchDID[0])+'&asin='+videoID+'&customerID='+urllib.quote_plus(matchCID[0])+'&deviceID='+urllib.quote_plus(matchCID[0])+str(int(time.time()*1000))+videoID).read()
        IndexError: list index out of range
        -->End of Python script error report<--
20:26:43 T:1844   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.prime_instant/?url=B00WKX8HR8&mode=playVideo]

EDIT:
Updated to lordk's patched version 1.0.23 and everything is working fine - many thanks to lordk!

Should have read some more posts before posting the issue - SORRY.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - BashDashovi - 2015-05-17

(2015-05-16, 15:16)locoguano Wrote: I entered my login information manually into the settings.xml and it has saved fine. Its not the most secure option but it works.

@locoguano would you please share how you added it to settings.xml. I don't see anywhere obvious to add my username and pass.
Thanks!


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - chapterslol - 2015-05-17

same I tried looking but could not find obvious place for info to be put Tongue


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-05-17

(2015-05-17, 02:58)BashDashovi Wrote:
(2015-05-16, 15:16)locoguano Wrote: I entered my login information manually into the settings.xml and it has saved fine. Its not the most secure option but it works.

@locoguano would you please share how you added it to settings.xml. I don't see anywhere obvious to add my username and pass.
Thanks!

<setting id="email" value="Your Login Email" />
<setting id="password" value="Your Password" />


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - zaphod24 - 2015-05-17

I've tried setting email and password manually in the settings.xml but they get blanked out when starting the plugin. Whenever I try to play a video, I get a popup that I need to specifiy credentials and restart the plugin. I'm running 1.0.23.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - AikenDrum - 2015-05-17

patch version 1.0.23 appears to be broken in openelec, previous version was working fine.

Deleted cookies, deleted cache, rebooted, re entered login and password : still get Script Failed

cant seem to roll back to a working version...


This forum uses Lukasz Tkacz MyBB addons.