Kodi Community Forum
[RELEASE] Amazon Prime Instant Video (US/UK/DE) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: [RELEASE] Amazon Prime Instant Video (US/UK/DE) (/showthread.php?tid=215255)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - hoschi80 - 2015-02-08

(2015-02-08, 18:54)KarlSchlag Wrote: I am here just to say "Thank you" for this amazing addon. Why is it not officialy listed in the standard repo ?
I always hated to use the "app" on my so called Smart TV. Your Addon is perfect.
I´m from Germany too and i can stream on highest settings.
The only problem is, that the stream stutters for 30 seconds after i pressed "Pause"

Plesse try again during prime time. I Never had a stable stream the last few evenings even with The lowest HD setting (2500k).during The day everything is fine till 6000k.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - kar82 - 2015-02-11

A few weeks ago, the stream stability was much better with this addon. Maybe, Amazon has change anything and this addon needs an update?

In my experience the stream stability with this addon is (at the moment) much worse than with the officially Amazon-Addon in my Smart-TV. Because of that, at the moment I prefer the officially Amazon-Addon in my Smart-TV.

Can anybody confirm my experience?


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - tavoc - 2015-02-12

what do you mean with stability?
For me the addon is stable, no exceptions are thrown etc.

Main problem is that amazon cant deliver the content fast enough in the evening. This cause constant buffering.
Your Smart-TV changes image quality on the fly, therefore you dont notice this problem.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - Piers - 2015-02-12

(2015-02-12, 11:14)tavoc Wrote: what do you mean with stability?
For me the addon is stable, no exceptions are thrown etc.

Main problem is that amazon cant deliver the content fast enough in the evening. This cause constant buffering.
Your Smart-TV changes image quality on the fly, therefore you dont notice this problem.

It's more likely that the ISP can't handle the content during prime hours, I highly doubt Amazon has an issue with bandwidth.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - hoschi80 - 2015-02-12

Nope, never had bandwidth issues with my ISP during the evening. Tried several speed tests. So I still see that as an Amazon issue.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - Piers - 2015-02-13

(2015-02-12, 23:43)hoschi80 Wrote: Nope, never had bandwidth issues with my ISP during the evening. Tried several speed tests. So I still see that as an Amazon issue.

Speed tests don't take into account routing and multiple other factors. I can do a speed test now showing 200/200 but that doesn't mean I can obtain that speed for all locations.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - hoschi80 - 2015-02-13

I was not referring to those artificial speed tests some websites are offering. I use several video streaming offers inside Kodi including HD content and they all run fine. But with amazon even the lowest HD quality (4000K) is giving the mentioned buffering issues (at prime time). And there are several forums e.g. kodinerds.net where people reporting that issue frequently and I don't think that they all have ISP issues.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - sualfred - 2015-02-14

No issues during prime time for me. 10000k and everything is fine. (50k VDSL)


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - sphere - 2015-02-14

Well done!

And welcome back Smile


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - locoguano - 2015-02-14

My issue was and remains to be that the edgefcs streams do not work...


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - thent - 2015-02-17

Thank you very much for this great plugin! It's what I've been waiting for to make my raspbi a close to perfect media center.

To those who are still getting a script error on opening the watchlist: Use the website to remove all movies whose title contains special characters. For me it was the french grave accent in "Les Misérables".


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - im85288 - 2015-02-17

Awesome plugin, I know it's still the first version but will you be adding UHD support in the future? Thanks again


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - sarbes - 2015-02-17

(2015-02-14, 23:44)locoguano Wrote: My issue was and remains to be that the edgefcs streams do not work...

This has to be resolved from someone who has access to the US website, because the CDN is not present in Germany.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - toejam - 2015-02-18

(2015-02-17, 12:39)membrane Wrote:
(2015-02-14, 23:44)locoguano Wrote: My issue was and remains to be that the edgefcs streams do not work...

This has to be resolved from someone who has access to the US website, because the CDN is not present in Germany.
For edgefcs.net (akamai) on Amazon (U.S.), swfVfy 2 is mandatory. This is the same issue that ruined the hulu add-on last year.

But fplive.net (level3) doesn't require swfVfy 2 or even rtmpe, and uses a much less robust auth method. I don't see any way to force cdn selection to level3. I've seen smils returned from Amazon that contain both akamai and level3, but much more often only akamai is returned. I also don't see any way to force 720p for movies, only for TV shows or other content that is non-movies. Earlier in the thread, others claimed that an update to the add-on resolves this, but I haven't seen it work in the U.S.

Probably shouldn't hold your breath too long hoping for a swfVfy 2 solution. This has been an issue for some time now.


RE: [RELEASE] Amazon Prime Instant Video (US/UK/DE) - capfuturo - 2015-02-21

(2015-01-30, 00:44)fsman1967 Wrote:
(2015-01-30, 00:37)hoschi80 Wrote:
(2015-01-28, 21:24)hoschi80 Wrote: I have one problem with the add-on. I'm not able to get movies running in HD. TV shows run fine in HD. After the 1st start I realized that the add-on changed the video settings from Silverlight to Flash. So I tried some movies in the browser (chrome, FF, IE using Win 8.1) and it is pretty much the same behavior as in Kodi. No Movies in HD. When I click the connection icon I can switch on/off HD but with no effect. When I switch back to Silverlight everything is ok. With Flash only the Movie trailers and TV SHows are running in HD but the movie itself SD only.

Any help is much appreciated!
Thanks!

Short Update. It seems there is no problem with the add-on, must be an issue with amazon.de. I asked a friend to test the same and he observed the same behavior. HD is not working in movies with flash player. Will contact amazon directly. Maybe the problem is only in the DE region? So is anyone able to watch movies in HD in that region? Thanks for the feedback.

Same in the UK with a PI.
SD on movies, HD on TV shows.

Yeah, in the UK I have experienced HD content on TV shows and SD content for movies. I believe Amazon is delivering some of the movies in HD but only via Silverlight, which isn't supported in Kodi, only Adobe Flash.

@AddonScriptorDE: big thanks for this add-on from me, an Amazon user!


This forum uses Lukasz Tkacz MyBB addons.