Kodi Community Forum
WIP Windows DirectX 11 upgrade test thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
--- Thread: WIP Windows DirectX 11 upgrade test thread (/showthread.php?tid=218274)



RE: Windows DirectX 11 upgrade test thread - natethomas - 2015-06-10

(2015-06-10, 12:20)afedchin Wrote: reduce used memory as fritsch wants Smile

Thank goodness, I was worried you were going to have to go back to the drawing board for that one. Wink


RE: Windows DirectX 11 upgrade test thread - Martijn - 2015-06-10

@afedchin
looks just fine Smile
Be sure to also remove the language strings if no longer used any where else


RE: Windows DirectX 11 upgrade test thread - Woppie - 2015-06-10

Version.4226 of the Intel drivers seem to solve the problems with the directx11 test builds, so the problem didn't start with version .4180 but at least with .4176. It did take an additional reboot to get CEC with the pulse eight adapter working again, so nu bugs with intel hd gfx other than you need the latest drivers for not having graphical glitches in the menu.


RE: Windows DirectX 11 upgrade test thread - Ace - 2015-06-10

Log for the flicker: http://pastebin.com/ZduPnday
It only happens with the intel card, the nvidia quadro works as expected.


RE: Windows DirectX 11 upgrade test thread - pizzaboy - 2015-06-10

Just FYI: running your latest build on Intel Hd4600 on Win7 for a few days now - all is working as expected. The "washed out colors" i have seen when trying out your build in March are fixed.


RE: Windows DirectX 11 upgrade test thread - afedchin - 2015-06-10

@Ace
Thanks. Unfortunately it seems a driver issue. the log has nothing that might indicate an issue. I'll try to reproduce the issue with my Intel GPU.

@Woppie, @pizzaboy
Thank you guys for your feedback.


RE: Windows DirectX 11 upgrade test thread - Woppie - 2015-06-12

Well unfortunately newer intel drivers don't solve the flashing and menu glitches after standby. It looks like if the htpc has been for long times in standby the problem occurs, while for short times in standby nothing happens and everything is all find. Didn't have it with beta1 (non dx11 build) so it might very well be related to dx11 as I first thought. so I probably have to put the logging to debug mode and let it in standby for the night.


RE: Windows DirectX 11 upgrade test thread - rob77 - 2015-06-12

Is anyone running this build on a nuc 2820? It supports dx11 and i just wondered if I would see any benefit like better hevc playback.

Cheers


RE: Windows DirectX 11 upgrade test thread - afedchin - 2015-06-12

@Woppie
Please, provide a Debug Log after long standby, it would be useful.

@rob
this build will work fine on NUC. But you will not get any benefit from dx11 build except needing install directx9. hevc decoding is same as current nightly.


RE: Windows DirectX 11 upgrade test thread - Martijn - 2015-06-14

Could you rebase on current master? daedd5ff9439e574363826553664f2e479528640


RE: Windows DirectX 11 upgrade test thread - narvatu - 2015-06-14

I have the feeling of being missing something. Most answers from this thread dont report major problems and everything works properly them, but my experience is not as pleasant.
3 mini HTPC in the house:
- revo 3610 (Nvidia ion)
- Zotac AD02 (AMD E350 + Radeon Hd6310)
- Zotac BI320 (Celeron 2957 U + Intel HD graphics)
Only celeron works properly with this builds.
I install may & june builds. First on win7 and now in win10 10130. (latest drivers)

The problem is with backgrounds. Kodi works normally: menus & movies can be seen normally, but the background images in the menus (confluence & Aeon Nox) flicker &/or dissappear and, if I move the mouse, a rectangle with variable dimensions (marked by the mouse movement) shows part of the background. In the celeron + Intel this does not occur.I activate & deactivate option related to screen Vsync, mouse & joystic... but the problem persist and I back to normal builds.
What do you neeed for solve this? Kodi do not crash. Must I upload the log? What options must be activate? (I copy pdb file aside with exe file.


RE: Windows DirectX 11 upgrade test thread - zag - 2015-06-14

always post a log file


RE: Windows DirectX 11 upgrade test thread - derekjason - 2015-06-14

(2015-06-04, 23:29)afedchin Wrote: @derekjason
got it. will be fixed in next build.
Thanks for nice catch.

DVD subtitles now display correctly on my rig. Thanks!


RE: Windows DirectX 11 upgrade test thread - narvatu - 2015-06-14

http://xbmclogs.com/pdw3iyt8d

In the zotac AD02 with win10, I open Kodi and, with mouse navigate to movies and open one (menu visibility is correct, but in the movies view, movie posters ficker and go black).
The movie open correctly and then stop it with remote and navigate back to menu with remote. Same as before, the posters flicker and go black when I stay, but come visible when move to other poster (and in <1sec, go black)
Sorry but my English not allow me to explain what happens as I would like

Want a log in the other PCs? (revo do the same)


RE: Windows DirectX 11 upgrade test thread - afedchin - 2015-06-14

@narvatu
Please try to comment (or remove temporary) gui settings into your advancedsettings.xml.
1. Open your C:\Users\zotac\AppData\Roaming\Kodi\userdata\advancedsettings.xml
2. Replace its content with the following:
Code:
<advancedsettings>
    <!-- <gui>
         <algorithmdirtyregions>1</algorithmdirtyregions>
         <nofliptimeout>1000</nofliptimeout>
    </gui>-->
</advancedsettings>