Kodi Community Forum
WIP Windows DirectX 11 upgrade test thread - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Kodi Application (https://forum.kodi.tv/forumdisplay.php?fid=93)
--- Thread: WIP Windows DirectX 11 upgrade test thread (/showthread.php?tid=218274)



RE: Windows DirectX 11 upgrade test thread - MadScientist - 2015-11-24

Many thanks, Beta2 is fine


RE: Windows DirectX 11 upgrade test thread - LarrxX - 2015-11-25

Quote:Hardware: Windows 10 64bit (upgrade, not fresh install), NVIDIA GTX960, driver-version 359.00
Kodi DX11 version: November 12
Debug Log: n/a
Crashlog: n/a
Description: See below
Screenshots: n/a
How to reproduce: See below

I'm runinng Kodi in a full screen window because I sometimes task switch (to check my email and other stuff) without having to close Kodi.

When I use the Windows search (Windows Key + Q) the menu appears but there is no text, no icons at all, just the windows menu GUI.

Don't know if it's a Kodi or a Windows issue, just thought I'd post it here.

I also had a couple crashes when the windows screen saver came on, but hadn't set up the debug symbols file. I'll post again with a full log and crash dump when/if that happens again.


RE: Windows DirectX 11 upgrade test thread - LarrxX - 2015-11-25

Addition to my previous message: I've been unable to reproduce the behavior, so am unable to provide logs. It was probably a one off problem? I'll keep an eye out and provide logs if it ever happens again.

Also intermittently I've had complete loss of audio when switching out of and back into Kodi (I'm using the HDMI output on my graphics card). System and other applications still work. Have to restart Kodi to get sound back. Don't have the logs on that for now and will also keep an ear out if it happens again (can't reproduce it reliably).

I know that non reproducible bugs are the hardest to track/debug/fix (I'm a software engineer myself) so I'll do my best to provide you with as much info if/when I can.


RE: Windows DirectX 11 upgrade test thread - LarrxX - 2015-11-25

When I tabbed out to post the previous message and tabbed back in, I had a completely black screen, audio and GUI interaction was working fine though (could hear the clicks when I navigated with the keyboard and the episode would play/pause when I told it to).

And this time, I do have a log.


RE: Windows DirectX 11 upgrade test thread - LarrxX - 2015-11-25

Just got a black screen while watching a video: here are the log and the crash dump.

Kodi generated a crash dump but did not crash, the audio and GUI interactions kept running.


RE: Windows DirectX 11 upgrade test thread - bluechris - 2015-11-28

(2015-09-01, 17:02)Shine Wrote: Here's an always-on-top build based on Isengard-3d763c9 (20150831) and DX11-0a71ba7 (20150827). Untested because I'm at work right now...

Known issue: Kodi might freeze when a competing always-on-top window pops up behind Kodi. As promised, I will PR once I find the time to work around this issue.

Edit: For those who didn't find it, Always-on-top is an option under System -> Video output. Default is disabled, so you have to enable it manually.

Guys sorry for asking but do the latest build has the code of @Shine for the On top to 2nd monitor problem that many people have?

EDIT: @afedchin you are the man.... IT WORKS with latest thx m8....


RE: Windows DirectX 11 upgrade test thread - bossanova808 - 2015-11-30

Hi Folks

I have been testing Jarvis B2 fairly extensively lately and have encountered a weird issue.

For the most part, it's all running fine, however I started noticing an in issue with my tv flickering/de-syncing had appeared. It's taken me a while to track it down as I've tried new cables, new TV ports, etc. However, I finally figured out what was causing it last night.

On installing J-B2 I noticed issues with 16-235. Reading up I saw it was recommended to minimis unnecessary conversions was to use Full RGB in the AMD drivers, and limtied in XBMC - neither of which I have used before. I hadn't paid much attention but AMD was set to YUV and xbmc always to full range.

Anyway - this works in terms of it solving issues with the dynamic range, however - it is this setting that is causing the (irregular) de-syncing/flicker issues. It was actually hooking up my projector that helped me solved this - it uses an in wall 15m HDMI cable and has always been rock solid, but it suddenly started flickering as well so I knew then it was at the software end of thigs....and when it's not flickering (i.e. syncing/de-syncing), it has noticeable visual artefacts - thin colour stripes across the picture. Now, I initially thought it must be J-B2 and so decided to go back to Helix but when that ALSO didn't solve it I was a bit mystified until I remembered tweaking this setting. I set it back to YUV and everything was immediately rock solid again with all outputs.

So - long story short - and I am more than happy to produce proper logs etc, but I just wanted to know if anyone else has seen these issues with the AMD driver speicifically in RGB pixel format mode. The issues only crop up in Kodi, not on the desktop, or with browsers etc, which is completely solid. But the issue effects two video output devices and once I worked out what was causing it is 100% repeatable.

Hardare is an AMD A6 APU (HD6530 IIRC), through a Denon X2110 AVR, and I have tested it with drivers from 14.8 right up to the Crimson drivers, all of which have this issue. To sum up:
RGB 4:4:4 - sporadic desyncng and flickering.
YCbCr 4:4:4 - rock solid.

This isn't directly related to directX11 but as @afdechin is the resident expert on this stuff this seemed the best place to post. Apologies if not. You could even say it's not a Kodi issue however I can only see this flickering and visual artefacts within Kodi, not anywhere else, so I think ultimately it is Kodi/AMD related.


RE: Windows DirectX 11 upgrade test thread - bossanova808 - 2015-11-30

(Windows 7 64 bit BTW)


RE: Windows DirectX 11 upgrade test thread - bossanova808 - 2015-12-01

A follow up - with YCbCr I can't get video levels right in Kodi. Dekstop and Kodi UI are fine, but neither limited nor full range is right in video playback. So I am a bit screwed - sporadic flickering and wierd striping with the drivers in RGB mode, or wrong video level in YCbCr mode.

Sad

Is there anything else I can try?


RE: Windows DirectX 11 upgrade test thread - a11599 - 2015-12-01

I am using YCbCr 4:4:4, Kodi full range and everything is fine (desktop, video, games, etc.). This is (or at least was in Catalyst) a per-resolution/refreshrate setting so you need to adjust individually for 24p, 50p and 60p if you use auto refreshrate switch in Kodi.

You may also need to adjust black level on your TV (if it is supported - which is again also probably per refreshrate). This works for me on 3 AMD cards (6450, 6570, 7750).

(Using 15.2 DX11 version.)


RE: Windows DirectX 11 upgrade test thread - bossanova808 - 2015-12-01

@a11599 - ah super helpful thanks, I did not realise it was per refresh rate, that could well be it.

My TV - panasonic V10 plasma - is limited range.

I will give it a try and report back - thanks again!


RE: Windows DirectX 11 upgrade test thread - bossanova808 - 2015-12-01

@a11599 - hmm, so I checked all the relevant refresh rates (24, 50 and 60) - all are set to YCbCr 4:4:4. Kodi set to full range - Ui is fine, but video levels are still definitely not ok.

This is, however, with Jarvis B2.

I have no such issues with Isengard (although I have not yet tried the DX11 version of that). have you tried Jarvis B2?


RE: Windows DirectX 11 upgrade test thread - a11599 - 2015-12-01

Not yet, all of my "production" PCs are still on 15.2 DX11.


RE: Windows DirectX 11 upgrade test thread - Martijn - 2015-12-01

iirc afedchin added the same code to 15.2DX11 as to 16.0beta


RE: Windows DirectX 11 upgrade test thread - dprotti - 2015-12-05

Hardware: Intel Pentium G3220 3.0Ghz dual core, Windows 10 Pro 64bit fresh install, NVIDIA GTX950, driver-version 359.06, display Philips TV 4k 3840x2160 connected with HDMI [email protected]
Kodi DX11 version: November 12
Debug Log: http://pastebin.com/qyg2NWWC
Description: See below
How to reproduce: playing a few h264 files on 4k display

a few weeks ago I upgraded my TV from [email protected] TV to [email protected] and my video card from Integrated Intel HD to NVIDIA GeForce GTX 950
it seems that working with that configuration at UHD causes some problems
in the log you'll find that I played a first file without errors, then at some point in the second file the application crashed, I was hearing the audio going on, but the video was freezed and all I could do was to terminate Kodi
it's not a specific file problem, I tried many files and the problem happens "randomly"

the tested files from the log were 720p ones, but I tried with different ones, up to 2160p

I tried the 16 beta 2 too, same behaviour, so I went back to the 15.2 DX11

GPU acceleration with DXVA/DXVA2 is enabled and seems to be working correctly

if you have any suggestion or anything you want me to test please ask