Kodi Community Forum
Release Vimeo v4.X.X - KODI 14.X Helix - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Vimeo v4.X.X - KODI 14.X Helix (/showthread.php?tid=220437)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13


RE: Vimeo v4.X.X - KODI 14.X Helix - PantsOnFire - 2016-08-15

Im having trouble understanding why you want to use a NOT vimeo addon to pass a link to Kodi for playback.

-why not just user the Vimeo add-on to begin with?

--does anyone else understand what/why he's asking this?


RE: Vimeo v4.X.X - KODI 14.X Helix - Mirgolth - 2016-09-11

Hi,

I just installed the add-on but I fail at login in.

Logs are not very helpful:
Code:
19:56:20 3561.372803 T:1963364352   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/sign/in/
19:56:20 3561.375244 T:1963364352   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/sign/in/) failed
19:56:27 3569.152344 T:1695544224  NOTICE: [plugin.video.vimeo] Running: Vimeo (4.1.4) on Isengard (16.1) with Python 2.7.11

Is this part still working ?
I used my email as a username, is that correct ? My email + password are valid on the site and log me in perfectly but not on the add on.


RE: Vimeo v4.X.X - KODI 14.X Helix - jmh2002 - 2016-09-12

All still working fine here for me. I'm using only my username, not my full email address.


RE: Vimeo v4.X.X - KODI 14.X Helix - Mirgolth - 2016-09-12

Nevermind, I restarted the box and credentials got accepted. Thx anyways !


RE: Vimeo v4.X.X - KODI 14.X Helix - torenvalk - 2016-10-16

Just a heads up the video quality setting doesn't work properly, only 1080p (HD) and 540p (SD) are available (no 360p, 480p or 720p).

The addon uses the deprecated Vimeo Advanced API using the method vimeo.videos.getSourceFileUrls which only returns two quality streams. The new API doesn't appear to have an equivalent method for getting video streams apart from your own uploaded videos and even then it is a limited PRO feature.

Any new addon would likely need to get video streams from the web.


RE: Vimeo v4.X.X - KODI 14.X Helix - xbmosx - 2016-10-21

Is there any way to play ALL the videos in a specific channel and not only the first 50? With the youtube add-on there is a context menu entry called "play all" that adds all the videos in a youtube playlist. I'm looking for the same functionality for vimeo channels (as there are no playlists).

Thank you for your help!


RE: Vimeo v4.X.X - KODI 14.X Helix - spigot666 - 2016-10-31

I'm having a login issue aswell, on both my android galaxy s5 and a raspberry pi 3. Android is running confluence skin and rasp is running titan skin. Tried both email and user name as the login. I also tried restarting kodi after entering credentials. Doesn't do anything as far as I can tell. Still get only the 3 options of featured search and log in. Am I missing something?


RE: Vimeo v4.X.X - KODI 14.X Helix - spigot666 - 2016-10-31

...also, just like to say thanks for your hard work. YouTube app is working flawless. REQUEST for a bandcamp addon.


RE: Vimeo v4.X.X - KODI 14.X Helix - pascal92 - 2016-12-15

(2016-03-05, 00:15)pascal92 Wrote: Vimeo / Group => Insufficient permissions The user does not have permission to do that
nothing displayed

Tried on 2 computeurs and 2 vimeo users

23:05:15 T:2136 NOTICE: [plugin.video.vimeo] Running: Vimeo (4.1.4) on Isengard (16.0) with Python 2.7.8
23:07:21 T:3560 NOTICE: Previous line repeats 3 times.
23:07:21 T:3560 NOTICE: Storing total System Uptime
23:07:21 T:3560 NOTICE: Saving settings
23:07:21 T:3560 NOTICE: stop all
23:07:21 T:3560 NOTICE: stop player
23:07:21 T:3560 NOTICE: ES: Stopping event server
23:07:21 T:3560 NOTICE: stopping upnp
23:07:22 T:332 NOTICE: ES: UDP Event server stopped
23:07:22 T:3560 NOTICE: stop sap announcement listener
23:07:22 T:3560 NOTICE: clean cached files!
23:07:22 T:3560 NOTICE: unload skin
23:07:22 T:3560 NOTICE: stopped
23:07:22 T:3560 NOTICE: destroy
23:07:22 T:3560 NOTICE: closing down remote control service
23:07:22 T:3560 NOTICE: unload sections
23:07:22 T:3560 NOTICE: special://profile/ is mapped to: special://masterprofile/
23:07:22 T:3560 NOTICE: destroy
23:07:22 T:3560 WARNING: Attempted to remove window 10013 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10014 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10015 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10016 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10017 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10018 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10019 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10021 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10107 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10115 from the window manager when it didn't exist
23:07:22 T:3560 WARNING: Attempted to remove window 10104 from the window manager when it didn't exist
23:07:22 T:3560 NOTICE: closing down remote control service
23:07:22 T:3560 NOTICE: unload sections
23:07:22 T:3560 NOTICE: application stopped...
23:07:22 T:3560 ERROR: dllFreeLibrary - Invalid hModule specified

Nothing found in any forum :-(

Hi
I still have the same issue and found nothing in the forum about this.
I could not use Group and Channel that appear empty Confused



RE: Vimeo v4.X.X - KODI 14.X Helix - spigot666 - 2016-12-27

Is this add on completely retired, or is there a fork that is updated? If I add anything as a widget from this add on it dislays the same thumbnail for all videos. Is this just me?


RE: Vimeo v4.X.X - KODI 14.X Helix - disrupted - 2017-03-09

does anybody know the URl endpoints this addon uses if you wanna open a video? the link in the first post is broken and I believe the GitHub page doesn't exist anymore.


RE: Vimeo v4.X.X - KODI 14.X Helix - lindend - 2017-03-16

(2016-10-31, 16:21)spigot666 Wrote: I'm having a login issue aswell, on both my android galaxy s5 and a raspberry pi 3. Android is running confluence skin and rasp is running titan skin. Tried both email and user name as the login. I also tried restarting kodi after entering credentials. Doesn't do anything as far as I can tell. Still get only the 3 options of featured search and log in. Am I missing something?

I have two vimeo accounts. I can login on one, but not the other. I was beginning to wonder if the issue was having a '.' in the address prior to the @. However, since others have the issue, I'm not sure now.

Were you able to login?


RE: Vimeo v4.X.X - KODI 14.X Helix - DoubleT - 2017-12-30

Trying to get vimeo urls to play from another addon, using the formatting below
plugin://plugin.video.vimeo/play/?video_id=xxxxxxxx
Nothing plays, but the logs make it looks like the addon is talking to vimeo and getting the stream URL ok.
I have used the same plugin://plugin.video.vimeo/play/?video_id=xxxxxxxx previously elsewhere and its worked fine 

i suspect i have another issue as i can get the same video to play fine by using a chrome addon to trigger it.
From debug log the successful chrome addon seems to be making the same call i am - i cant see any difference?

Any ideas would be much appreciated
Full Log
Code:

13:19:40.550 T:13044   DEBUG: CInputManager::OnKey: return (0xf00d) pressed, action is Select
13:19:40.551 T:13044   DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.vimeo/play/?video_id=233666623)
13:19:40.551 T:13044   DEBUG:   ParentPath = [plugin://plugin.video.foeewni/]
13:19:40.589 T:16312   DEBUG: CAddonDatabase::SetLastUsed[plugin.video.vimeo] took 38 ms
13:19:40.589 T:14276   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin Vimeo('plugin://plugin.video.vimeo/play/','65','?video_id=233666623')
13:19:40.589 T:16088   DEBUG: Thread LanguageInvoker start, auto delete: false
13:19:40.589 T:16088    INFO: initializing python engine.
13:19:40.589 T:16088   DEBUG: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): start processing
13:19:40.602 T:16088   DEBUG: -->Python Interpreter Initialized<--
13:19:40.602 T:16088   DEBUG: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): the source file to load is "C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py"
13:19:40.602 T:16088   DEBUG: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): setting the Python path to C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo;C:\Program Files (x86)\Kodi\system\python\DLLs;C:\Program Files (x86)\Kodi\system\python\Lib;C:\Program Files (x86)\Kodi\python27.zip;C:\Program Files (x86)\Kodi\system\python\lib\plat-win;C:\Program Files (x86)\Kodi\system\python\lib\lib-tk;C:\Program Files (x86)\Kodi;C:\Program Files (x86)\Kodi\system\python;C:\Program Files (x86)\Kodi\system\python\lib\site-packages
13:19:40.602 T:16088   DEBUG: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): entering source directory C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo
13:19:40.602 T:16088   DEBUG: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): instantiating addon using automatically obtained id of "plugin.video.vimeo" dependent on version 2.14.0 of the xbmc.python api
13:19:40.653 T:16088   DEBUG: [plugin.video.vimeo] Starting Kodion framework by bromix...
13:19:40.656 T:16088  NOTICE: [plugin.video.vimeo] Running: Vimeo (4.1.4) on Isengard (17.2) with Python 2.7.11
13:19:40.656 T:16088   DEBUG: [plugin.video.vimeo] Path: "/play/
13:19:40.656 T:16088   DEBUG: [plugin.video.vimeo] Params: "{'video_id': u'233666623'}"
13:19:40.983 T:16088   DEBUG: [plugin.video.vimeo] selectable streams: 2
13:19:40.983 T:16088   DEBUG: [plugin.video.vimeo] selectable stream: {'url': 'https://player.vimeo.com/play/833004553?s=233666623_1514647182_ef61c1e23b148f1f0fae03bc5f3b964c&oauth_token_id=33782309', 'sort': [1920], 'video': {'format': 'video/mp4', 'height': 1080}, 'title': '1080p (video/mp4)'}
13:19:40.983 T:16088   DEBUG: [plugin.video.vimeo] selectable stream: {'url': 'https://player.vimeo.com/play/833004549?s=233666623_1514647182_79801bb15d2a551eed308b721ec56aa5&oauth_token_id=33782309', 'sort': [960], 'video': {'format': 'video/mp4', 'height': 540}, 'title': '960x540 (video/mp4)'}
13:19:40.983 T:16088   DEBUG: [plugin.video.vimeo] selected stream: {'url': 'https://player.vimeo.com/play/833004553?s=233666623_1514647182_ef61c1e23b148f1f0fae03bc5f3b964c&oauth_token_id=33782309', 'sort': [1920], 'video': {'format': 'video/mp4', 'height': 1080}, 'title': '1080p (video/mp4)'}
13:19:40.983 T:16088   DEBUG: [plugin.video.vimeo] Converting VideoItem
13:19:41.051 T:13044   DEBUG: ------ Window Init (DialogBusy.xml) ------
13:19:41.053 T:16088   DEBUG: [plugin.video.vimeo] Shutdown of Kodion
13:19:41.053 T:16088    INFO: CPythonInvoker(79, C:\Users\Oli\AppData\Roaming\Kodi\addons\plugin.video.vimeo\default.py): script successfully run
13:19:41.054 T:16088    INFO: Python script stopped
13:19:41.055 T:16088   DEBUG: Thread LanguageInvoker 16088 terminating
13:19:41.057 T:13044   DEBUG: ------ Window Deinit (DialogBusy.xml) ------
13:19:41.065 T:11512   DEBUG: Thread BackgroundLoader start, auto delete: false
13:19:41.067 T:13044   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
13:19:41.073 T:11512   DEBUG: Thread BackgroundLoader 11512 terminating
13:19:41.344 T:6800   DEBUG: CWebServer[8080]: request received for /jsonrpc
13:19:52.415 T:13044   DEBUG: Previous line repeats 11 times.
13:19:52.415 T:13044   DEBUG: Keyboard: scancode: 0x2d, sym: 0x0078, unicode: 0x0078, modifier: 0x0
13:19:52.415 T:13044   DEBUG: CInputManager::OnKey: x (0xf058) pressed, action is Stop
13:19:52.499 T:13044   DEBUG: Keyboard: scancode: 0x2d, sym: 0x0078, unicode: 0x0000, modifier: 0x0
13:19:53.344 T:6800   DEBUG: CWebServer[8080]: request received for /jsonrpc
13:19:53.799 T:13044   DEBUG: ------ Window Init (Pointer.xml) ------
13:19:54.343 T:6800   DEBUG: CWebServer[8080]: request received for /jsonrpc
13:19:55.465 T:13044   DEBUG: Previous line repeats 1 times.
13:19:55.465 T:13044   DEBUG: CWinEventsWin32::WndProcWindow is active
13:19:55.466 T:13044   DEBUG: CWinEventsWin32::WndProc: Focus switched to process C:\Windows\System32\notepad.exe
13:19:55.550 T:13044   DEBUG: CWinEventsWin32::WndProcWindow is active
13:19:56.343 T:6800   DEBUG: CWebServer[8080]: request received for /jsonrpc
13:19:56.898 T:13044   DEBUG: CWinEventsWin32::WndProcWindow is active
13:19:57.343 T:6800   DEBUG: CWebServer[8080]: request received for /jsonrpc




RE: Vimeo v4.X.X - KODI 14.X Helix - Zeesy - 2018-01-08

I've just installed an updated version of the Vimeo plugin for OSMC on my RasPi3, but am having some problems. I can sign in, search, browse featured videos and play them, but can't see my albums, channels, or groups. Of the features listed on the project page, I am unable to:
  • receive any user notifications
  • use video thumbnail browsing
  • Add, remove or list "likes"
  • Join or leave a group
  • Subscribe or un-subscribe to channel.
  • Authorize plugin access to user data on Vimeo from within plugin only
  • See a list of a channels videos and list all new subscription videos
  • List a contacts uploads, albums, groups, "likes" and channel subscriptions
I would like to be able to watch password protected videos, but they don't show up in searches. I have added some to my "watch later" and group folders through vimeo on my laptop's web browsers, but as mentioned above I am unable to access them through the Vimeo addon for OSMC.

I can search, but I have to search a term twice before it shows up in the list of searched terms, and then search a third time before I am able to see the search results.

Have I somehow installed the wrong plug in? Is something missing? Am I just not signed in? I installed and enabled the Vimeo plugin directly through Add-on Browser>My add-ons in OSMC's Settings.


RE: Vimeo v4.X.X - KODI 14.X Helix - b0g0m0l - 2018-12-14

Add autoplay next clips.