Kodi Community Forum
RPI1-512 Audio Dropout playing HD multichannel music - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: RPI1-512 Audio Dropout playing HD multichannel music (/showthread.php?tid=222061)

Pages: 1 2 3 4 5 6


RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-22

HI,

I am back once again as I didn't find out any answer to fix my issue I have for months, I wrote 2 other threads here and here at this time for this issue.
But now there are news:
- First in my test
- Second I have some money to spend to change my RPi-512 and need to better know the issue to choose a new hardware.

The issue: Drops when playing FLAC 24/96 multichannel. Other format, 16/44.1, DTS, DD are good.

I listen with a Denon AVR-2113. In the display there is an indicator "PCM-DIG" turned on whe playing FLAC files.
Test files are from http://www.2l.no/: At the right top, drop-list select "Test Bench HD audio files"
Choose in Surround 5.1 FLAC 24BIT/96kHz
I use mainly Pyotr Ilyich Tchaikovsky: SOUVENIR de Florence op. 70: I. Allegro con spirito TrondheimSolistene (552 MB)
but others do the same more or less.

Code:
Firmware Version
Mar 10 2015 15:33:55
Copyright (c) 2012 Broadcom
version 015c58030bfa095c209a59c0c19e02d6705a2c24 (clean) (release)
00:00:15 T:1968787456  NOTICE: Starting Kodi (14.2-RC1 Git:e7ba06f). Platform: Linux ARM 32-bit
00:00:15 T:1968787456  NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
I use Confluence skin, no visualisation, no RSS.
Passthrough for all 3 formats.
Audio files are in the SD card or USB hard drive.

Overclocking:
Code:
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6
This config is very stable as I use to set at
arm_freq=1050
core_freq=550
sdram_freq=550
over_voltage=6
without any problem with 16/44.1, DTS, DD files.

So new test:
I start to play through file mode.
Display: File mode, go down (down arrow) in the file list and hit enter to start playing.
Issue: Drops around every 2-5 minutes for half second: "PCM-DIG" turn off for the same time. Music time continue to go even during the drops.
TOP command (this screenshot depicts the average values):
Code:
Mem: 303108K used, 78300K free, 0K shrd, 25857680K buff, 25857728K cached
CPU: 87.7% usr 11.2% sys  0.3% nic  0.1% idle  0.0% io  0.0% irq  0.3% sirq
Load average: 1.41 1.19 0.73 2/98 3482
  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND
  441     1 root     R     427m114.5   0 95.4 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
   43     2 root     SW<      0  0.0   0  2.3 [VCHIQr-0]
   42     2 root     SW<      0  0.0   0  0.7 [VCHIQ-0]
  510   400 root     S     6824  1.7   0  0.3 sshd: [email protected]/0
3482   512 root     R     2624  0.6   0  0.2 top
   58     2 root     SW       0  0.0   0  0.2 [mmcqd/0]
2725     2 root     SW       0  0.0   0  0.2 [kworker/0:2]
After 3 minutes display dims: same issue

Now I change the display to full screen (Tab). I can see the time cursor at the bottom.
TOP command (this screenshot depicts the average values):
Code:
Mem: 351832K used, 29576K free, 0K shrd, 986784K buff, 986832K cached
CPU: 73.5% usr  9.4% sys  0.6% nic 16.0% idle  0.0% io  0.0% irq  0.4% sirq
Load average: 1.44 1.13 0.56 2/98 472
  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND
  395     1 root     R     373m100.0   0 80.5 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
   43     2 root     SW<      0  0.0   0  1.1 [VCHIQr-0]
   42     2 root     SW<      0  0.0   0  0.7 [VCHIQ-0]
  470   467 root     R     2624  0.6   0  0.4 top
  465   354 root     S     6824  1.7   0  0.2 sshd: [email protected]/0
   57     2 root     SW       0  0.0   0  0.2 [mmcqd/0]
  378     2 root     SW       0  0.0   0  0.2 [RTW_CMD_THREAD]
    4     2 root     SW       0  0.0   0  0.2 [kworker/0:0]
   19     2 root     SW       0  0.0   0  0.2 [kswapd0]
I can't note any issue as this screen stay only 10 seconds before dim.

Now this is the very interesting part. Screen is full, dim:
TOP command (this screenshot depicts the average values):
Code:
Mem: 356808K used, 24600K free, 0K shrd, 9952976K buff, 9953024K cached
CPU: 45.4% usr  5.2% sys  1.0% nic 48.0% idle  0.0% io  0.0% irq  0.2% sirq
Load average: 1.57 1.03 0.42 2/99 515
  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND
  441     1 root     S     418m112.1   0 50.3 /usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd
  515   512 root     R     2624  0.6   0  0.4 top
   42     2 root     SW<      0  0.0   0  0.4 [VCHIQ-0]
  510   400 root     S     6824  1.7   0  0.2 sshd: [email protected]/0
   58     2 root     SW       0  0.0   0  0.2 [mmcqd/0]
  424     2 root     SW       0  0.0   0  0.2 [RTW_CMD_THREAD]
  141     2 root     SW       0  0.0   0  0.2 [kworker/0:3]
  177     1 root     S     7328  1.9   0  0.0 /usr/lib/systemd/systemd-udevd
  410     1 root     S     6916  1.8   0  0.0 /usr/bin/nmbd --configfile=/run/samba/smb.conf
And now I have drops every half second (or even more often) for half second approximately: "PCM-DIG" turn off for the same time.

Note that CPU usage is around 50-55% and I have the maximum of drops...

I am ready to provide any other info.

Thanks


RE: RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-23

More info.

Instead of disabling visualisation, I tried with Spectrum and Waveform.
TOP shows the same levels than without (%CPU around 50) but drops are only every 2-5 minutes, not every half second.
When drops occur, visualisation animation continues to move, so music is playing even if I can't hear it.

@popcornmix
@Milhouse
any idea?


RE: RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-24

Maybe my first post was too long, so I do short:

I play music in full screen and press down arrow to keep the screen illuminated: I get a drop every 2-5 minutes, CPU usage is around 80%.
I stop pressing the key, after 10 seconds the screen dim: I get a drop every half second, CPU usage is around 50%.


I hope @popcornmix or/and @Milhouse will have a clue.


Re: RPI1-512 Audio Dropout playing HD multichannel music - Milhouse - 2015-03-24

Have you disabled all add-ons? Another forum member posted about the Weather add-on causing excessive CPU load, this add-on was installed by another skin so you may not even be aware it's been installed. Try a fresh .kodi folder to ensure you've got no unnecessary add-ons installed. Test only with Confluence.

Are you able to try a different amp? Obviously this isn't an easy request, but some sort of issue with your amp might explain the issue.

Also, see if you can reproduce the problem with a non-Pi platform, ie. x86. However if it's a CPU issue then you might not see the problem on a more powerful platform. The Pi1 should be able to play those files without a problem, providing it's not being hobbled by some other background process (add-on) using up all the available CPU cycles.


RE: RPI1-512 Audio Dropout playing HD multichannel music - doug - 2015-03-25

Thought I would help out with a confirmation of this. I don't normally play flac files, but I have the a Denon 2313 so thought I would try your file. I also get the audio dropouts. I also see a change in my receiver's display...the PCM sign disappears during a dropout. I am using an RPi2, OE 5.0.5, no addons. CPU (top) isn't stress at all (max 8%). It happens with passthrough enabled or disabled.

Log file:
http://sprunge.us/GTBR


RE: RPI1-512 Audio Dropout playing HD multichannel music - doug - 2015-03-25

One more finding...the dropouts disappear if I select 2.0 or 2.1 channels in audio settings. Unlike the 5.1/7.1 configuration I tested in the post above, the PCM indicator never comes on and the display shows Dolby Digital instead of Multi In.


RE: RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-26

@doug
Big, big thanks to confirm the issue.
I was thinking I was going mad as nobody could confirm and help. This is a big step forward for me.
Please doug stay in contact, this is very important for me as I only play music, FLAC and HD.
Moreover I was thinking to upgrade my hardware to a Pi2. So no need.

So, I did a fresh install on a formatted SD card.
No add-on, same settings, same config.txt file.
=> Same problem.

If more info needed, let me know.


RE: RPI1-512 Audio Dropout playing HD multichannel music - fritsch - 2015-03-26

Please try from local disk, not via nfs.


RE: RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-26

See my first post (too long I know)
Quote:Audio files are in the SD card or USB hard drive.
and my signature.


RE: RPI1-512 Audio Dropout playing HD multichannel music - MrNice - 2015-03-27

@popcornmix
@Milhouse
@fritsch

Do you think it is possible to go further:
- Find what cause the issue
- Find a workaround or a fix
We are 2 now with this bug.

I am ready to help.


RE: RPI1-512 Audio Dropout playing HD multichannel music - Milhouse - 2015-03-27

- is it a coincidence you both have the same amp, try a different amp
- is it the same problem on other Kodi platforms (x86, Ubuntu etc) while using this Denon amp?

Narrowing down the problem is what we need you to help with - start eliminating the variables. It could be RPi, it could be Kodi, or it could be your amp.

If the amp is the problem, is there a firmware update?


RE: RPI1-512 Audio Dropout playing HD multichannel music - fritsch - 2015-03-27

doug has a network issue with nfs, buffer runs dry.

And you Mr Nice and Double Poster Guy - post a Debug Log! a complete one.

Edit: @doug: Are You fast scrolling through the menus while playing viz and that flac file?


Re: RE: RPI1-512 Audio Dropout playing HD multichannel music - doug - 2015-03-28

(2015-03-27, 23:20)fritsch Wrote: doug has a network issue with nfs, buffer runs dry.

Edit: @doug: Are You fast scrolling through the menus while playing viz and that flac file?

No, not scrolling or any button clicking at all. Just starting the music and then stopping a short time after the drops. My other audio (vbr mp3s) and video (straight makemkv rips from my dvds and blurays) play fine. But my server has been totally freezing up (no shell, no ssh, no webmin...) on me occasionally in the last couple months. So a rebuild is planned soon.


RE: RPI1-512 Audio Dropout playing HD multichannel music - fritsch - 2015-03-28

(2015-03-28, 02:40)doug Wrote:
(2015-03-27, 23:20)fritsch Wrote: doug has a network issue with nfs, buffer runs dry.

Edit: @doug: Are You fast scrolling through the menus while playing viz and that flac file?

No, not scrolling or any button clicking at all. Just starting the music and then stopping a short time after the drops. My other audio (vbr mp3s) and video (straight makemkv rips from my dvds and blurays) play fine. But my server has been totally freezing up (no shell, no ssh, no webmin...) on me occasionally in the last couple months. So a rebuild is planned soon.

So, please. Play that file from local disk, usb stick, whatever - we don't want to search network issues for now. Then post the log and we can see if you have the very same issue as the OP.


RE: RPI1-512 Audio Dropout playing HD multichannel music - fritsch - 2015-03-28

I can easily reproduce. It's nothing AVR related. I plugged my Pi2 with latest Millhouse build into my Marantz NR1402 and see the same. Stopping viz does not have any effect. It seems it also happens with 2 channel flac and >= 96khz. Local file or network file also no difference. Symptomes are as written by MrNiceGuy.

AVR is working great with other input (cubox, Generic x86). As the logfile is not really obvious I think it's firmware related.

@popcornmix, @millhouse: It works for you? > 96 khz flac or multi channel flac?

HDMI, Optimized, 5.1 channel configuration.

Funny sidenote: Disabling CEC seems to make it work better :-)


This forum uses Lukasz Tkacz MyBB addons.