Kodi Community Forum
Win HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Tips, tricks, and step by step guides (https://forum.kodi.tv/forumdisplay.php?fid=110)
--- Thread: Win HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR (/showthread.php?tid=222576)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - jackhulk - 2020-02-08

This build is awesome and your excellent guide is much appreciated thank you, however there is one major issue that I can't resolve. Streaming content doesn't work and Kodi shuts down or video simply doesn't play. I therefore tried using your playercorefactory.xml for online streams and whilst streams are now working, trouble is HDR doesn't engage. I can 100% confirm that the content is HDR as download works perfectly, but as a stream HDR doesn't work. How can I get streams to work with HDR please?


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-02-08

Streaming HDR content won't work with DSPlayer because the HDR metadata can't be passed through. Is that what you are trying to play?

Other streaming video add-ons such as YouTube work fine for me with DSPlayer. They just need to be SDR.

This is the only method that I know of to play streaming HDR10 video via Windows 10. You need to use MPC-BE and manually save the link for MPC-BE:

https://forum.kodi.tv/showthread.php?tid=223175&pid=1987672#pid1987672


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - jackhulk - 2020-02-08

I've actually got some HDR content working via straight up streaming (no manually saving links etc) with HDR metadata being passed through, however the issue now is bog standard streams are not working. A simple AVI file will not play. The stream works fine with DSPlayer disabled (therefore using default VideoPlayer) confirming the stream is working fine but just not with DSPlayer, so appears to be a settings issue. Any idea how I can get basic file types working please?


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-02-09

By basic file types, do you mean local mkv's, mp4's and such? That playcorefactoy.xml shouldn't play those if you have DSPlayer checked as the default player.

Or do you mean other streaming video content? Those should all be played by VideoPlayer if you added the playercorefactory.xml to the userdata folder. That is the point of adding it to the configuration.


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-14

Hello everyone. I am trying to get Kodi/dsplayer working properly with the right colors and all. Going good so far.
Only when i stop watching a movie, sometimes Kodi gets smaller in size into my top left corner of windows 10. Pressing the ''\'' a couple of times makes it normal again.
Is this a common issue? and can this be fixed easy?

My other question is. I have big issues with playing 4K HDR movies. having big frame dips. No issues with 1080P movies. Now with a normal New Kodi install without all the fancy stuff i have no issues playing 4K. I do see quite heavy load on my i7-2600K. Maybe its time to upgrade my CPU for 4K HDR
Any advise would be appreciated


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-03-15

The resizing of Kodi on playback stop can sometimes be corrected by setting Kodi to use a fullscreen window rather than a true fullscreen and ensuring the resolution in Kodi matches the same resolution as set in the GPU control panel.

As for your 4K playback, you'd have to post a picture of your madVR OSD (Ctrl + J) during playback and post it here to see what is going on. Your rendering times may be time too high leading to frame drops. It would be the GPU that is overstressed, not the CPU.


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-15

Here is my madVR OSD

About my Resizing issue. It seems like its always the case with 4k movies. I don't get any issues with 1080p movies. With 4K it takes a while to get back out of the black screen after stopping the playback. Where at 1080p it is almost instant

Image


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-03-16

Have you tried frame rate matching (adding the entries 2160p23, 2160p24 to madVR's display modes)? Does that help at all? 

What do you have the GPU resolution set to in the GPU control panel?

Your OSD says the decoder queue is empty. Have you set LAV Video to hardware decode all 4K HEVC files? Does your GPU support 10-bit HEVC decoding?


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-17

Hey. Thanks for the reply. The LAV Filter Hardware Decode was indeed disabled. I putted it at Nvidia Cuvid. And it works without frame drops now!
About adding the entries 2160p23, 2160p24. I couldn't find where i should set this up
The GPU Control Panel is set at 3,840x2,160 pixels
My Graphics card is a 1060GTX. It seems it only not supports HEVC B Frame support. Not sure i will need it for the full experience

If there are any other things i should set up, i would really appreciate receiving this. Thank you!


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-03-17

Display modes are entered into the blank textbox found within display modes in the madVR control panel.

Choose either DXVA2 (copy-back) or D3D11 Automatic (Native) hardware decoding rather than CUVID. Both are better decoders for either Nvidia or AMD GPUs.


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-18

Hello. I found the display modes. I added both 2160p23, 2160p24. But i see nothing really happening. Shouldn't the ''Display'' Say 24Hz or 23Hz Instead of 60Hz like it shows now?
I had no option to putt the Hardware Decode on ''DXVA2''. Instead i used ''D3D11''. What about HDR. I guess its a no brainer to just putt it on passthrough right? I see no reason why u should let madVR deside.
I do still have issues with resizing. Can there be a different reason rather then Resolution settings?


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-03-18

If the refresh rate didn't change, your display might be a 60 Hz panel and does not support native 24p playback. Ensure you entered the display modes correctly. The blank textbox should show "valid" if entered correctly.

I'm not sure exactly what would be causing your display issue. It would have something to do with the GPU drivers and how they interact with your display.


HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-18

Maybe it's easier to just let u know how I got my HTPC hooked up. It goes through my AV receiver Marantz av7750 and from there to my LG C9 tv

Btw. Should there be any changes made in windows at all? talking about audio and video


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Warner306 - 2020-03-19

I would go through this checklist in the GPU control panel:

https://forum.kodi.tv/showthread.php?tid=223175&pid=2739438#pid2739438


RE: HOW TO - Configure Kodi DSPlayer with LAV Filters, XySubFilter & madVR - Paynemaster - 2020-03-22

Thanks for the reply with the Link. Pretty nice explanation and setting up there. I also set the display to 12 Bit. If i understand correctly, 10 bit 4K 60Hz is not gonna happen.
I was wondering. You also got a link like the one u posted but then just for Audio on the Windows side?


This forum uses Lukasz Tkacz MyBB addons.