Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- C-Quel - 2008-03-13

Yup afraid it does mate... ill loglevel(3) and pastebin as soon as i get the chance, its a case of waiting for a decent time slot when somethings about to finish or we could end up with 30mins of log which would not be pleasant Tongue


- C-Quel - 2008-03-13

http://pastebin.com/m8b399fb

Not normally something i would do it was unexpected and just ended i cut the log as i was not actually debugging at the time but hopefully enough for you to see its hit EOF and attempted another stream.


- elupus - 2008-03-13

no need for loglevel 3, standard debug is enough.


- ptipton - 2008-03-14

Not sure if this is any help but the xbmcmythtv python script has exactly the same problem with stopping at the end of each program


- franKiboY - 2008-03-14

I tried to run xbmc on my mythbackend yesterday, to see if my problems where fixed there. Looks like everything runs smoothly there.

The backend machine should have almost the exact same setup as the machine where I have experienced problems, but much more powerful. The backend machine runs on a recent c2d (dual core) CPU, 8600GT GPU and plenty of memory.

The GUI debug overlay is reporting that XBMC is utilizing about 100% of CPU (sometimes more than 100%), even in menus. I have not checked if this is correct with "top", but since the backend and several other things are working without problem it might be a false CPU % number.

You where talking about audio device eating CPU. This might be a problem on my side: I use gentoo, and for some reason I have to compile alsa-lib (1.0.14a) with debugging enabled to prevent xbmc from segfaulting. I guess this might be a problem with alsa. I will try to run with 1.0.15 later today.

Anyway, things look great on the backend machine. I love the new feature in xbmc!!


- elupus - 2008-03-14

wasn't meaning eating cpu, rather eating audio samples. but yea, please try that.

ptipton, not really. cmyth client are supposed to jump from file to file as the playback goes one. no such thing in the python client.


- Bram77 - 2008-03-14

Someone at the MediaPortal forum has started writing a XBMC Python script to add the ability to use the fantastic MediaPortal TVserver with XBMC.
Almost every thinkable TV card is supported by the TVserver and it's much easier to install, configure and maintain then MythTV is. The only downside is that a Windows machine is needed to run the TVserver.

This is getting me exited! Native support for the TVserver in XBMC would even be nicer! Smile

http://forum.team-mediaportal.com/general-talk-233/xbmc-python-script-36590/


- Gamester17 - 2008-03-14

@Bram77, good news but please respect that is very OFF-TOPIC for this specific topic-thread, you should have posted a separate new topic-thread in the python-scripts end-user forum instead for that. As for native MediaPortal-client support there is already a topic-thread in the feature suggestion forum, see: http://forum.xbmc.org/showthread.php?tid=5376


- Bram77 - 2008-03-14

I'm sorry. I should have thought of that myself.


- ptipton - 2008-03-14

elupus, have compiled the latest version and whilst the buffering on livetv is almost gone (only once after a channel change) so livetv now plays continuously but the video is in kind of slowmo and the audio stuttering. Have pasted xbmclog here http://pastebin.com/m29c878d4 Thanks


- ptipton - 2008-03-14

Just to add that if I pause livetv for a while and restart it plays ok for a while before the slowmo and stuttering starts again


- franKiboY - 2008-03-15

Found that the CPU usage is very high (100%) only when I'm in the menu. It doesn't matter if I'm in the mythtv sub meny, or frontpage. (So this is not related to mythtv at all). Still it's a bit strange. CPU usage is only high in full screen. In windowed mode, it's normal (<10%).

I doesn't matter which version of alsa-lib and alsa drivers I'm using. I have tried 1.0.14a, 1.0.15 and kernel drivers. I've also tested 1.0.14a and 1.0.15 of alsa-lib. The same also applies for all combinations: If alsa-lib is compiled without debug support, I get a "Floating point exception". When debug enabled, alsa is working correctly.

This means that so far, the best info is still the debug logs I sent you.

Frank


- topfs2 - 2008-03-15

ptipton Wrote:Just to add that if I pause livetv for a while and restart it plays ok for a while before the slowmo and stuttering starts again

This sounds as you have a slow network connection between them? Wireless maybe?

Does it work with the regular frontend on the XBMC comp?

I don't know if this is different on mythtv but try to have a bigger cache in XBMC, is in settings -> system -> cache.. But that would probably not help if you have seriously poor connection but if the stutters are once in a while it might help.


- ptipton - 2008-03-15

Topfs2, thanks. Don't think its the network as its wired and the regular mythtv frontend runs fine on the same machine. Also all other playback, video, music etc works fine in XBMC.


- ptipton - 2008-03-15

Am still struggling to get Mythtv working on my xbox.
If I define the share using the hostname it simply doesn't connect so cant see the TV channels etc. Log here http://pastebin.com/m11e2f2bd
If I use the IP address in the share then I can see the channel listing but cant view livetv. It does however seem to set the backend recording. Log here http://pastebin.com/m693785e
I understand that this is some sort of DNS issue but am wondering if this is something to do with Cmyth, something relating to my particular setup or something that will at some point be fixed?
XBMC reads all the other shares from the backend machine i.e videos,music etc and the python XBMCMYTHTV script works fine. Thanks


This forum uses Lukasz Tkacz MyBB addons.