Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- elupus - 2008-03-15

it is hard to fix actually. the server gives us the hostname we should connect to, since the file can have been recorded on another hostname than the one we are connected to. thus if your dns doesn't work , you are pretty much out of luck.

i will add some way to manually add static dns lookups in xbmc at some point, then it will work.


- joebidalli - 2008-03-17

Linux Frontend. Recordings work fine.

LiveTV, I get these errors.

22:29:51 T:2808081296 M:115888128 DEBUG: Process - MythTV event LIVETV_CHAIN UPDATE live-borrelli-laptop-2008-03-16T22:28:55
22:30:11 T:2866576272 M:115879936 ERROR: Read - error requesting block of data (-1)
22:30:12 T:2866576272 M:115879936 DEBUG: Seek - seek to pos 0, whence 16
22:30:32 T:2866576272 M:115699712 ERROR: Read - error requesting block of data (-1)
22:30:32 T:2866576272 M:115699712 ERROR: Open - error reading from input stream, myth://mythtv:[email protected]/channels/36.ts
22:30:33 T:2866576272 M:115699712 DEBUG: OpenDemuxStream - New stream available from input, retry open
22:30:33 T:2866576272 M:115699712 DEBUG: Seek - seek to pos 0, whence 16
22:31:02 T:2866576272 M:114692096 ERROR: Read - error requesting block of data (-1)
22:31:02 T:2866576272 M:114692096 ERROR: Open - error reading from input stream, myth://mythtv:[email protected]/channels/36.ts
22:31:02 T:2866576272 M:114692096 DEBUG: OpenDemuxStream - New stream available from input, retry open
22:31:02 T:2866576272 M:114692096 DEBUG: Seek - seek to pos 0, whence 16


- elupus - 2008-03-17

joebidalli:
check your mythbackend log, could give a hint.


- joebidalli - 2008-03-17

Elupus,

Seeing these error.
MythSocket(2aaab0040450:376): writeData: Error, zerocnt timeout

http://pastebin.com/m19fddfb1


- elupus - 2008-03-18

okey, that stuff normally happens if we request too much data from backend and it fills socket. thou i really though that was solved.


build 12173 fails for CMyth - uomiarz - 2008-03-18

CMythSession.cpp: In member function ‘bool XFILE::CCMythSession::UpdateItem(CFileItem&, cmyth_proginfo*)’:
CMythSession.cpp:91: error: ‘class DllLibCMyth’ has no member named ‘proginfo_subtitle’

I am not smart enough to fix that Sad


- joebidalli - 2008-03-18

elupus, don't know if this helps but I've added verbose backend logging information here.

http://pastebin.com/m961150b


- Nick8888 - 2008-03-18

uomiarz Wrote:CMythSession.cpp: In member function ‘bool XFILE::CCMythSession::UpdateItem(CFileItem&, cmyth_proginfo*)’:
CMythSession.cpp:91: error: ‘class DllLibCMyth’ has no member named ‘proginfo_subtitle’

I am not smart enough to fix that Sad


Snippets of logs aren't enough to help elupus fix errors. Paste full logs of both xbmc and mythbackend to pastebin and link to it.


- uomiarz - 2008-03-18

Nick8888 Wrote:Snippets of logs aren't enough to help elupus fix errors. Paste full logs of both xbmc and mythbackend to pastebin and link to it.
yes, you are correct
however i get this when I try to compile newest xbmc svn (topic) and it is related to CMyth


- Nick8888 - 2008-03-18

http://xbmc.svn.sourceforge.net/viewvc/xbmc?view=rev&revision=12173

Its only just been added. I'd give it some time.


- elupus - 2008-03-18

will be fixed in bit. thx for the heads up.

<edit> fixed </edit>


- uke75 - 2008-03-18

Hi all!

I tried to compile svn version with Revision 12173 of CMythSession.cpp. Got this error: class DllLibCMyth has no member named. Reverted back to 12172 -> compile ok.

dist: Debian lenny


- uomiarz - 2008-03-18

uke75 Wrote:Hi all!

I tried to compile svn version with Revision 12173 of CMythSession.cpp. Got this error: class DllLibCMyth has no member named. Reverted back to 12172 -> compile ok.

dist: Debian lenny

you should probably read at least a page or two back before you post
problem was fixed in latest svn, just read few posts up


- elupus - 2008-03-19

joebidalli:
please svn up and try again. i've replaced the read method with one that shouldn't block backend even if receive buffer is too small, which i think was your issue.

also i've added dates and such to the filelistings, so should be easier to see what show is what.


- joebidalli - 2008-03-20

Thanks elupus,

Tried it this morning before I left for work. XBMC wasn't able to connect to my backend. Didn't have time to troubleshoot though.

Will have a look tonight.


This forum uses Lukasz Tkacz MyBB addons.