Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- awaldram1 - 2008-04-07

Hi Elupus I've been away ever since the forum was moved and my login got corrupted ..username registered but no password and no e-mail address.

Anyway you've revived my interest with this excellent additional functionality.

I ran some tests on a 7/4/08 build and found that on one xbox previous recordings played on another they didnt , even though both were running the same XBMC copied from the same location (into clrean folders) .. live playback works on both.

The 1 that doesn't work will play nuv recordings but not re-encoded MPGs it it either locks up no error in log (like the other users) or if you persist you can get this (though once it did play !)

21:21:03 M: 32002048 NOTICE: DVDPlayer: Opening: myth://mythtv:[email protected]/recordings/3511_20071113223000.mpg
21:21:03 M: 32002048 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
21:21:03 M: 31477760 NOTICE: Creating InputStream
21:21:03 M: 31457280 NOTICE: Creating Demuxer
21:21:05 M: 25116672 NOTICE: Opening video stream: 0 source: 256
21:21:05 M: 25137152 NOTICE: Creating video codec with codec id: 13
21:21:05 M: 25124864 NOTICE: Creating video thread
21:21:05 M: 24600576 NOTICE: Opening audio stream: 1 source: 256
21:21:05 M: 24604672 NOTICE: running thread: video_thread
21:21:05 M: 24604672 NOTICE: Finding audio codec for: 86017
21:21:05 M: 24440832 NOTICE: Creating audio thread
21:21:05 M: 23924736 NOTICE: running thread: CDVDPlayerAudio:Tonguerocess()
21:21:05 M: 23511040 NOTICE: Creating audio device with codec id: 86017, channels: 2, sample rate: 48000, no pass-through
21:21:05 M: 21929984 ERROR: CThread:ConfusedtaticThread : Access violation at 0x00243758: Writing location 0x23232323
21:21:05 M: 21929984 NOTICE: uninitting video device
21:21:05 M: 21884928 NOTICE: thread end: video_thread

on the other xbox the same video plays as so

21:51:51 M: 36528128 NOTICE: DVDPlayer: Opening: myth://mythtv:[email protected]/recordings/3511_20071113223000.mpg
21:51:51 M: 36528128 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
21:51:51 M: 36003840 NOTICE: Creating InputStream
21:51:51 M: 34467840 NOTICE: Creating Demuxer
21:51:53 M: 23801856 NOTICE: Opening video stream: 0 source: 256
21:51:53 M: 23801856 NOTICE: Creating video codec with codec id: 13
21:51:53 M: 23789568 NOTICE: Creating video thread
21:51:53 M: 23265280 NOTICE: Opening audio stream: 1 source: 256
21:51:53 M: 23265280 NOTICE: Finding audio codec for: 86017
21:51:53 M: 23101440 NOTICE: running thread: video_thread
21:51:53 M: 23003136 NOTICE: Creating audio thread
21:51:53 M: 22474752 NOTICE: running thread: CDVDPlayerAudio:Tonguerocess()
21:51:53 M: 22474752 NOTICE: Creating audio device with codec id: 86017, channels: 2, sample rate: 48000, no pass-through
21:51:53 M: 21078016 NOTICE: fps: 25.000000, pwidth: 852, pheight: 480, dwidth: 851, dheight: 480
21:51:53 M: 21078016 NOTICE: Display resolution AUTO : PAL 16:9 (7)
21:52:02 M: 22401024 NOTICE: CDVDPlayer::CloseFile()
21:52:02 M: 22409216 NOTICE: DVDPlayer: waiting for threads to exit

I even swopped the lounge xbox (none working) with the bedroom(working one) fault stayed with the lounge xbox.

The lounge Xbox is an old modded xbox the bedrooom is a newer softmod.

Hope this helps.

Andy


- Nick8888 - 2008-04-08

Do Not Post Logs On Here.

Use Pastebin.

Read The Rules.


- lingenfr_xbmc - 2008-04-08

I just installed the latest T3CH build. I believe it includes the DNS fix. For me (with 3 tuners) it still locks up my xbox. I will try and check logs tomorrow to provide some feedback. Watching my backend, it launches the connection and for whatever reason locks up rather than displaying the video. Darn.


- ptipton - 2008-04-08

Also just installed the latest t3ch and the DNS fix solves my connection problem and now works fine on my xbox with single tuner back end. The livetv functionality is fantastic this is great piece of work.
I have a question on using different skins. If I use xTV (my favorite skin) then in list view for livetv the channels show towards the right of the screen but the current program does not show, I'm assuming because it would be off screen to the right. I'm guessing I need to edit the list view in xTV, reduce the size of the large clipboard icon that takes up most of the left of the screen and move the channels etc to the left. If thats the case can someone point me in the direction of how to do this?
Another difference when using xTV is that when you are watching livetv and hit display, this brings up the channel listing but rather than displaying the current channel in a small window at bottom left as in PM111 the current channel continues playing full screen in the background with the channel listing superimposed on top. This is actually pretty cool and could possibly be preferable to the small window in PM111.
Thanks for all the great work elupus.


- ptipton - 2008-04-08

Rand Al Thor - looking at previous posts would I be right in asuming you are ding some work on the aeon skin for use with mythtv? If so is the modded skin available? Thanks


- awaldram1 - 2008-04-08

Nick8888 Wrote:Do Not Post Logs On Here.

Use Pastebin.

Read The Rules.


Sorry unless something has changed in the 18 months I've been away Developers preferred short log snippets in the text rather than pastebin if the body of the text was directly referring to 1 line, As mine was in the bold line.

I didn't think 16 lines of log was 'posting log files'.

Checked the 10 commandments and posting log snippets is not frowned on

rule 4 is the only applicable rule to my post

4. Re-read and follow the FAQ before reporting any bugs!, provide all details/information!

Note the FAQ link is missing.


- awaldram1 - 2008-04-08

Hi Elupus,

Further to my last the Lounge box will happily play straight Mpgs from dvb source it'll also play NUV files trancoded to MP4 from mpg2

What it wont do is play mpeg2 trancoded to Divx but still has the mpg extension. (bit naughty but works for me ;-) )

Strangely the bedroom box is not effected by this and plays all recorded files without issue.


- Rand Al Thor - 2008-04-08

ptipton Wrote:Rand Al Thor - looking at previous posts would I be right in asuming you are ding some work on the aeon skin for use with mythtv? If so is the modded skin available? Thanks

I am working on myth specific views. However, the new version of the mod is not available for download at this time.


- elupus - 2008-04-08

awaldram1:
Evil todo so Smile. but i'm abit surprised one box works and one doesn't. Normally extension doesn't make a difference (it does for some files thou, flv in particular). And the exception you see seem to be unrelated to myth. Could you copy one of those files somewhere else and play using smb or local and post a full debug log (the parts you posted was not) on pastebin.

ps. It's always been seen as very bad to cut logs in any way. They should always be complete as alot of hints in configuration show up eariler.

lingenfr_xbmc:
You mention you had the dns fix, but did you enter static entries in AdvancedSettings.xml? otherwise the "fix" does nothing.


- awaldram1 - 2008-04-08

As requested, The smb version played fine

1 from (non working) playin file from share = success Big Grin
http://pastebin.com/d71f07c62
NOTE all @ replced with # to get past spam filter Wink

2 from workin myth box myth stream same file = success Big Grin
http://pastebin.com/m4329e734

3 from (non Working) playing myth stream same file = locked up Sad
http://pastebin.com/m6828404b


- elupus - 2008-04-08

awaldram:
1, File was played with mplayer instead of dvdplayer which is default for myth streams. Do a play using dvdplayer instead and post a log.
2, I have no idea how you generated that log, but it looks very messed up. Only debug log part way through, and not when you played the file. Also there was a huge amount of mp3 played in it.

3, nothing indicating a crash. but you said it just locked up, so there doesn't have to be something.


- awaldram1 - 2008-04-08

elupus:

sorry should have explained better the 2nd pastebin is from the working (bedroom) xbox , showing the file streaming from mythTV and playing.

the reason theres a lot of mp3 stuff in it is its busy cataloging my library and nothing I do will stop it (even carries on after reboot) pretty cool.

pastebins 1 and 3 are from the dodgy Xbox. I'll redo the smb stream using dvdplayer when I get home.


- awaldram1 - 2008-04-08

Elupus:

Better ones this time both dvdplayer crashes but both show in logs

first player lockup to blank screen.

http://pastebin.com/m2e82c98a

next player plays for a few secs then crashes back to desktop.

http://pastebin.com/d7666f187

would you like debug output from the working one ? (after the library has finished).
I'm wondering wether the good one would eventually crash.


- awaldram1 - 2008-04-08

this is the mencoder options used to create the files
they are then moved to the .mpg and the database filesize corrected

mencoder -ofps 25 -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=2500:vhq:vpass=1 -vf pp=ci,scale=852:480 -oac copy -ffourcc DX50 -o ${directory}/${file}.avi ${directory}/${file} -quiet -passlogfile /tmp/divx2pass.log

looks ok to me and xbmcmythtv played them fine but I guess thats mplayer


- elupus - 2008-04-08

awaldram1:
it looks to be a "corrupt" avi file. atleast in how our xbox version of libavformat interpret it. i suppose it might have been fixed in current version from mplayerhq. if you could check if the file fails on the other xbox i'd like to have a sample of it too check.


This forum uses Lukasz Tkacz MyBB addons.