Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- topfs2 - 2008-05-03

Hm, I did the code based on xmltv, but I doubt there is a difference as I think EIT just gets saved into the db of mythbackend (which is what we read).

Still are you dead sure the password is "mythtv"? IIRC you don't need the correct pass for livetv (not sure though)
<EDIT>Please provide me a log btw</EDIT>


Everything working swimmingly on Xbox pointing to Ubuntu Hardy - dteirney - 2008-05-04

Just wanted to say thanks so much. I now have everything working beautifully with the latest T3CH release (rev12746-T3CH-REPACK) and a Ubuntu Hardy backend.

There were a few issues getting the DNS bits working but everything seems fine now. LiveTV is working fine, Guide appears to work and the Recordings can be played and deleted (and sorted by Name or Date which is useful for deciding what to watch).

So, pretty much everything that we used to use the python XBMC MythTV Script has now been covered with the myth:// protocol. Great!

I'm using the AEON Skin with the aeonmod put together by Randy. With some different background images and a Live TV folder of images of my choice I think it will look bloody amazing. Skin works much better in HD - currently using 720p.

Great job!


- ptipton - 2008-05-04

Couple of feature suggestions for Live TV- would be great if
1. When watching LiveTV could hit a button to record the current program
2. When watching LiveTV you could change channels by punching in the channel number.
Guess there might be issues with the original xbox remote in terms of button allocation.
For me this would make LiveTV pretty much perfect. Thanks for all the good work.


- lingenfr_xbmc - 2008-05-04

I hate being a dope, but I have looked everywhere I can think of and I can't find the guide. I am using the T3CH 4-20 SVN build. I assume from reading other posts that it should show up under the Watch TV folder. I have looked everywhere I can think of. I have read the changelog, etc. Should it be working? If so, how does it work?

Also, I still get frequent buffering when using the default dvdplayer for livetv. Mplayer works fine. Any suggestions? I posted my logs, but it don't seem to indicate a problem. I am running mythbuntu 8.04 as my backend. As a test, I tried xbmcmythtv using dvdplayer for livetv. It worked fine with no buffering.

xbmc.log http://pastebin.com/m67b849e1
xbmc.old.log http://pastebin.com/m3d598782


- elupus - 2008-05-05

ptipton:
1: is already there. probably just no keymap for it. use guy for now.

2. shouldn't be hard to add.

lingenfr_xbmc:
guide should be the third folder under myth://hostname/ that isn't livetv or recordings.

Not sure why dvdplayer would buffer but mplayer not. Could be that mplayer uses a separate thread for reading data. Since the myth protocol is very latency bound this could easily be the reason.


- Anaerin - 2008-05-05

Now that both DVDPlayer and MPlayer have edl support, has anyone given any thought to making a "Myth Commercial list to edl" converter, or something like that, that works with the myth plugin, so the commercial skip marks that Myth makes are usable? Would they appear like chapter marks (Rather than hard removal edits), so if the marking is wrong you can still rewind back to what was skipped over?

And I'm also getting the "Buffering" problem with DVDPlayer playback, though not with MPlayer. Also, DVDPlayer won't jump forward/back until it's finished buffering, whereas MPlayer jumps instantly, buffering asynchronously in the background.

Note: this is on a hard-wired 100-T network, no wireless involved.

And something in the latest T3CH update has broken seeking in DVDPlayer - It buffers nice and fast, but it's not displaying a program length, and telling it to skip forward/back does nothing (It "jumps" to the last keyframe and re-buffers)


Trouble .. - nizzeh - 2008-05-05

Hi all

I have today bougt an "old" xbox with someting that called evox in ...

But all i want is to use this box as an front end to my mythtv system .

But after upgrading XBMC to 20080405 from the script inside .
i still cant get it to work .
I get :
2008-05-05 23:08:05.887 MainServer::HandleAnnounce Playback
2008-05-05 23:08:05.887 adding: xbox as a client (events: 0)
2008-05-05 23:08:05.889 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:05.890 MainServer::HandleAnnounce Playback
2008-05-05 23:08:05.890 adding: xbox as a client (events: 0)
2008-05-05 23:08:06.176 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:06.177 MainServer::HandleAnnounce Playback
2008-05-05 23:08:06.177 adding: xbox as a client (events: 0)
2008-05-05 23:08:07.338 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:07.339 MainServer::HandleAnnounce Playback
2008-05-05 23:08:07.339 adding: xbox as a client (events: 1)
2008-05-05 23:08:10.174 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:10.175 MainServer::HandleAnnounce Playback
2008-05-05 23:08:10.175 adding: xbox as a client (events: 0)
2008-05-05 23:08:10.177 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:10.178 MainServer::HandleAnnounce Playback
2008-05-05 23:08:10.178 adding: xbox as a client (events: 0)
2008-05-05 23:08:19.718 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:19.719 MainServer::HandleAnnounce Playback
2008-05-05 23:08:19.719 adding: xbox as a client (events: 0)
2008-05-05 23:08:19.720 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:19.721 MainServer::HandleAnnounce Playback
2008-05-05 23:08:19.721 adding: xbox as a client (events: 1)
2008-05-05 23:08:19.722 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:19.723 MainServer::HandleAnnounce Playback
2008-05-05 23:08:19.723 adding: xbox as a client (events: 0)
2008-05-05 23:08:19.725 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
2008-05-05 23:08:19.726 MainServer::HandleAnnounce Playback
2008-05-05 23:08:19.726 adding: xbox as a client (events: 0)
2008-05-05 23:08:22.079 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!


My server is ubuntu 8.04 the last version .
It works perfect with all 3 pc clients i have .

Any hints ??

// Nizze


- lingenfr_xbmc - 2008-05-06

Anaerin Wrote:And I'm also getting the "Buffering" problem with DVDPlayer playback, though not with MPlayer. Also, DVDPlayer won't jump forward/back until it's finished buffering, whereas MPlayer jumps instantly, buffering asynchronously in the background.

Can we do anything to help troubleshoot this? It seems to be something unique to this project since the DVDPlayer works fine with the xbmcmythtv script playing the exact same livetv channels.

I'm not griping and it does seem to buffer less with this current version. I let it go and eventually it locks up. The 'Play using...' crap to use mplayer is a bit much for the SO and kids.


- squishback - 2008-05-06

nizzeh Wrote:2008-05-05 23:08:22.079 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!

It sounds crazy, but I made this error go away by making sure dns was set up for xbmc. I have a dns server on my lan and point the xbmc dns setting to that. I think there may be some negotiation on the protocol that relies on the host name of the mythtv server.

Worked for me anyway! Just need to solve the buffering issues now ...


Oki - nizzeh - 2008-05-06

squishback Wrote:It sounds crazy, but I made this error go away by making sure dns was set up for xbmc. I have a dns server on my lan and point the xbmc dns setting to that. I think there may be some negotiation on the protocol that relies on the host name of the mythtv server.

Worked for me anyway! Just need to solve the buffering issues now ...

Hi .

Nope that did not help .

I search the forum and i could read that xbmc should try to change protcoll by it self but as far as i can see in my logs it continues using protocol 8 ??

So i'l test some more and see if i can find out why ..

// Nizze


- Anaerin - 2008-05-06

nizzeh Wrote:Hi .

Nope that did not help .

I search the forum and i could read that xbmc should try to change protcoll by it self but as far as i can see in my logs it continues using protocol 8 ??

So i'l test some more and see if i can find out why ..

// Nizze

It's not actually a problem. First off XBMC connects with version 8 to see what version Myth is actually running. After getting the error (Which is logged by the backend), XBMC then re-connects with the correct version (In this case, version 40), which does not get logged by the MythTV backend (As it's not an error).

So, what actually happens on XBMC when you tell it to open the Myth URL? Do you get a few folders (Live TV, Guide and Recordings)? Does XBMC report an error? How do you have the URL set up?


- nizzeh - 2008-05-06

Anaerin Wrote:It's not actually a problem. First off XBMC connects with version 8 to see what version Myth is actually running. After getting the error (Which is logged by the backend), XBMC then re-connects with the correct version (In this case, version 40), which does not get logged by the MythTV backend (As it's not an error).

So, what actually happens on XBMC when you tell it to open the Myth URL? Do you get a few folders (Live TV, Guide and Recordings)? Does XBMC report an error? How do you have the URL set up?

Hi

when i enter MY Video
i get :
Guide
Live TV
Recordings

And if i enter live tv i can see my tv channel list
if i go into recordings i can see my recordings.

But if i select one channel or recording i get
" To Many conscutive dailed items "
and if i take a look in myth backend i can see this:

2008-05-06 21:35:52.963 MainServer::HandleAnnounce Playback
2008-05-06 21:35:52.963 adding: xbox as a client (events: 0)
2008-05-06 21:35:52.966 MainServer::HandleVersion - Client speaks protocol version 8 but we speak 40!
And there are several lines that looks the same as above.

// Nizze


- elupus - 2008-05-07

I need the xbmc debug log. The myth log tells me hardly anything.


- nizzeh - 2008-05-07

elupus Wrote:I need the xbmc debug log. The myth log tells me hardly anything.

Sorry to ask ..
But where in the xbox are the logs ??
U know i'm a newbee with xbox

I search on and when i find them i'l post them

// Nizze


Sometimes - nizzeh - 2008-05-07

One can bee blind ....
sorry ..

Maybee this can help u help me ....

17:37:08 M: 40128512 NOTICE: DVDPlayer: Opening: myth://mythtv:[email protected]:6543/channels/4.ts
17:37:08 M: 40128512 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
17:37:08 M: 39604224 NOTICE: Creating InputStream
17:37:19 M: 39256064 ERROR: DNS lookup for TVSERVER failed: 10060
17:37:19 M: 39256064 ERROR: XFILE::CCMythFile::SetupLiveTV - unable to spawn live tv: Failed to setup livetv.
17:37:19 M: 39256064 ERROR: InputStream: Error opening, myth://mythtv:[email protected]:6543/channels/4.ts
17:37:19 M: 39256064 NOTICE: CDVDPlayer::OnExit()
17:37:19 M: 39256064 NOTICE: CDVDPlayer::OnExit() deleting input stream
17:37:19 M: 39780352 ERROR: Playlist Player: skipping unplayable item: 0, path [myth://mythtv:[email protected]:6543/channels/4.ts]
17:37:58 M: 40751104 NOTICE: CDVDPlayer::CloseFile()
17:37:58 M: 40751104 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
17:37:58 M: 40751104 NOTICE: DVDPlayer: waiting for threads to exit
17:37:58 M: 40751104 NOTICE: DVDPlayer: finished waiting
17:38:02 M: 40751104 ERROR: XFILE::CFile:Big Grinelete - Error deleting file Z:\xbmc.edl
17:38:02 M: 40751104 NOTICE: DVDPlayer: Opening: myth://mythtv:[email protected]:6543/channels/1.ts
17:38:02 M: 40751104 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
17:38:02 M: 40226816 NOTICE: Creating InputStream
17:38:13 M: 39948288 ERROR: DNS lookup for TVSERVER failed: 10060
17:38:13 M: 39948288 ERROR: XFILE::CCMythFile::SetupLiveTV - unable to spawn live tv: Failed to setup livetv.
17:38:13 M: 39948288 ERROR: InputStream: Error opening, myth://mythtv:[email protected]:6543/channels/1.ts
17:38:13 M: 39948288 NOTICE: CDVDPlayer::OnExit()
17:38:13 M: 39948288 ERROR: Playlist Player: skipping unplayable item: 0, path [myth://mythtv:[email protected]:6543/channels/1.ts]
17:38:13 M: 39948288 NOTICE: CDVDPlayer::OnExit() deleting input stream
17:38:15 M: 40628224 NOTICE: CDVDPlayer::CloseFile()
17:38:15 M: 40628224 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
17:38:15 M: 40628224 NOTICE: DVDPlayer: waiting for threads to exit
17:38:15 M: 40628224 NOTICE: DVDPlayer: finished waiting


// Nizze


This forum uses Lukasz Tkacz MyBB addons.