Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- elupus - 2008-05-18

dteirney:
The buffering during fastforward is fixed in svn yesterday. (has nothing todo with that dll).

lingenfr_xbmc:
Did you test the new dll i posted a few posts ago?


- lingenfr_xbmc - 2008-05-23

I loaded T3CH SVN 0518 REPACK. While I am not getting the progress bar type buffering, I am still getting constant stuttering in the audio when using dvdplayer. With mplayer it seems fine, but the whole play using... crap is a bit too complex for the family. Is there anything I can do to help get this fixed?


- elupus - 2008-05-23

lingenfr:
test the dll i posted above.


- lingenfr_xbmc - 2008-05-25

elupus,

I tried it. No joy. Frequent stuttering and video artifacts, occassional (once per minute) buffering.


- lingenfr_xbmc - 2008-05-25

lingenfr_xbmc Wrote:elupus,

I tried it. No joy. Frequent stuttering and video artifacts, occassional (once per minute) buffering.

Also, the dll made the xbmcmythtv script stutter and buffer as well. When I put the once from the latest T3CH build back in, xbmcmythtv worked fine. Don't know if that is helpful for troubleshooting, but I thought I would let you know.


Xbox locking up - wishie - 2008-05-25

I have the latest T3CH build of XBMC, and have tried both xbmcmythtv (python scripts) and the inbuilt myth:// support.

I finally got xbmcmythtv working perfectly tonight, but what i am really after, is to use the inbuilt myth support.

I can add the source, and 3 items get shown..

If i click on 'Live TV' i get a list of the channels available, so that is fine, but when i click on the channel to watch, the xbox instantly freezes, totally dead. The only way to get it working again, is to power off/on the xbox.

The xbmc logs dont show anything useful, really, as i think the xbox crashes before a log gets written..

Anyone experiencing the problem of xbmc (and the xbox itself) totally freezing when trying to watch LiveTV with the inbuilt myth support ? Any ideas how to fix ?

I have also tried the libcmyth.dll mentioned above, but it made no change at all.


- ptipton - 2008-05-27

One issue I have is that on my xbox tv displays in wide screen but on linux tv displays in 4:3. Have been through the settings many times and cant find any differences and the linux machine plays video from all other sources in wide screen. Thanks


- elupus - 2008-05-27

wishie:
log is written from first startup of xbmc. so check wiki on how to generate a debug log, and post it to pastebin.org

ptipton:
sounds abit weird. must be getting aspect wrong somewhere. I've never had such an issue.


- lingenfr_xbmc - 2008-05-29

elupus, I still get stuttering, buffering followed by perma-pause lockup. Once it is no longer responsive to the remote I can still FTP and web in. I am running T3CH 5-18 repack. I am not running the latest dll you posted as it not only didn't fix the problem, it seemed to screw up xbmcmythtv script as well. I am using the one from the T3CH build. Here is a debug log where I tried to play a channel until it locked up.

http://pastebin.com/m16c83902


- elupus - 2008-05-29

The dll can i no way mess with xbmcmythtv.


- lingenfr_xbmc - 2008-05-29

OK, sorry just trying to provide complete information. I installed the dll. Stuttering and buffering was worse. I went to use xbmcmythtv instead. It was stuttering and buffering. It has never done that before. I put the svn dll back in. Built in still stutter and buffer, xbmcmythtv no stutter and buffer. Hopefully the provided log will be useful.


myth:// protocol working fine for me - dteirney - 2008-05-29

FWIW, I have the myth:// protocol working fine for me with the latest T3CH build.

I'm using:
Latest T3CH build (T3CH 5-18 repack)
Latest 0.21 MythTV server from the Ubuntu distro
100Mb wired connection between XBox and MythTV box
Aeon Skin with aeonmod for myth:// goodness in menus.
MythTV server is a Core 2 Duo (2.3GHz)
PVR-500 so onboard hardware MPEG2 encoding.

If the server is recording a couple of shows and trying to play we sometimes don't have the skip functionality working (when you skip ahead 30s for example).


- dteirney - 2008-05-29

@wishie

Sounds like you don't have the DNS entry configured for your MythTV server. I had the exact same problem. There's instructions in this thread somewhere for how to do it (or maybe a different one that I'm getting confused with).

You need to add the hostname entry into the AdvancedSettings.xml file. There's instructions in the XBMC wiki for the format etc.

The standard DNS lookup is pretty primitive and unqualified hostname stuff normally fails miserably (which is what happens for LiveTV).


- elupus - 2008-05-29

lingenfr_xbmc:
Then your network was messing up. The script reads over smb://, has nothing at all todo with the myth:// protocol that dll provides.
The log is abit interesting, but you forgot to tell me what libcmyth.dll that was from.

dteirney:
think you can get me a log when that happens?


- lingenfr_xbmc - 2008-05-30

elupus Wrote:you forgot to tell me what libcmyth.dll that was from.

I am now running the one from the T3CH 018 REPACK.


This forum uses Lukasz Tkacz MyBB addons.