Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



Do Myth TV recordings expose the same information as scrapped TV Shows? - dteirney - 2008-06-08

@elupus

I'm trying to figure out the easiest way to have a great looking XBMC that works in great with myth://

The Aeon skin is about to get some love for the TV Shows View.

Does the information that is exposed about recorded TV shows within Myth TV look remotely similar to the information XBMC expects for downloaded and scrapped TV Shows? If so, a skin with a generic TV Shows view should be able to be plugged in directly and work a treat. If not, bugger!

See http://forum.xbmc.org/showpost.php?p=190394&postcount=1788 for my related post in the Aeon skin thread.


Scraper for Myth TV recorded shows to get fanart etc? - dteirney - 2008-06-08

@elupus

In a similar vein to my last post, any idea if there are any XBMC plans to more closely align the display/grouping of TV shows that were either downloaded from the internet or recorded directly from a broadcast via Myth TV.

Downloaded TV shows need to be named appropriately so the TV Show scraper can get the relevant information.

Recorded TV shows already have some of that information available from the EPG and exposed by myth:// (although normally the episode name rather than the episode number, and possibly not the series number).

It would be great if all the fanart etc, didn't care about whether it was recorded or downloaded. It's all just the same to me, just a TV show that I want to watch on the big screen, regardless of where it came from.

I guess if the recorded show information from myth:// could be imported into the XBMC TV Show library that would kind of work. Not sure if there are any plans to do that, or whether it's even possible.

Cheers for all your great work helping get the myth:// protocol up and running for those of us using both XBMC and Myth TV. You're a legend!


Seem to need to delete recordings twice before they disappear - dteirney - 2008-06-08

With the latest XBMC release (1-Jun-2008) we have found that we need to delete a recording twice before it doesn't show in the list.

A debug log can be found at http://pastebin.com/m4c4955c


- lingenfr_xbmc - 2008-06-08

As this thread is getting pretty difficult to navigate, the dll that elupus posted for some to try is located on page 44, post number 432 on 17 May 08. Or here;

http://forum.xbmc.org/showpost.php?p=185518&postcount=432


- lingenfr_xbmc - 2008-06-08

I tried the other dll. It buffered initially, but then played with just stuttering. I let it play for a few minutes and it didn't lock up. Then I stopped it an restarted with Play Using... Mplayer. It played perfectly. The log is here.

http://pastebin.com/d6564470e

Not sure if it is helpful, but I set xbmcmythtv to use dvdplayer for livetv and started it playing. I have attached a debug log that I thought might be helpful for comparison.

http://pastebin.com/d779bde01

I am not sure what else to do to help troubleshoot. The situation is pretty much the same as the past few months. Mplayer works fine, dvdplayer buffers/stutters/freezes. I tried xbmcmythtv with dvdplayer and mplayer. Both work fine. I do, very rarely get a stutter with dvdplayer, but not similar to myth:// stuttering.


Listing of upcoming recordings? - dteirney - 2008-06-11

Is there any information about any of the future development plans for myth://

For example, are there any plans to add any of the other summary pieces of information that the XBMC Python script used to provide into myth://

Sometimes we like to check that something is scheduled to record, or has in fact started recording.

A listing of upcoming recordings would be dandy.


- lingenfr_xbmc - 2008-06-11

lingenfr_xbmc Wrote:I tried the other dll. It buffered initially, but then played with just stuttering. I let it play for a few minutes and it didn't lock up. Then I stopped it an restarted with Play Using... Mplayer. It played perfectly. The log is here.

http://pastebin.com/d6564470e

Not sure if it is helpful, but I set xbmcmythtv to use dvdplayer for livetv and started it playing. I have attached a debug log that I thought might be helpful for comparison.

http://pastebin.com/d779bde01

I am not sure what else to do to help troubleshoot. The situation is pretty much the same as the past few months. Mplayer works fine, dvdplayer buffers/stutters/freezes. I tried xbmcmythtv with dvdplayer and mplayer. Both work fine. I do, very rarely get a stutter with dvdplayer, but not similar to myth:// stuttering.

elupus,

Any other ideas on what I can try to isolate the problem. I posted several times with some different logs.


- Gamester17 - 2008-06-11

dteirney Wrote:Is there any information about any of the future development plans for myth://
This is what is planned: http://wiki.xbmc.org/?title=GSoC_-_Unified_PVR_Frontend
For discussion about that see: http://forum.xbmc.org/showthread.php?tid=28918

...and note that it will not be limited to MythTV, however MythTV will be the reference back-end for development purposes.


- lingenfr_xbmc - 2008-06-18

From the deafening silence I assume that means we won't see any more activity of this project until the SOC. I just tried the T3CH 6-16 SVN build and I am still getting the stuttering. Here is the log http://pastebin.com/m2afe6e98

It does not skip with Play using... Mplayer.


- spiff - 2008-06-18

elupus is on vacation.


- dteirney - 2008-06-19

dteirney Wrote:With the latest XBMC release (1-Jun-2008) we have found that we need to delete a recording twice before it doesn't show in the list.

A debug log can be found at http://pastebin.com/m4c4955c

Has anyone else had this problem deleting MythTV recordings or is it just me? I'm on holiday so can't check the latest T3CH release. We never needed to have to delete twice before the show disappeared but we've consistently had to with the 1-Jun-2008 T3CH release.

Couldn't see anything in the change log for the 16-Jun-2008 T3CH release to suggest anything will be different.


It's the damnedest thing. - balthisar - 2008-06-21

Everything was working perfectly for me last night. Recordings, Program List, and of course, Live TV. Live TV alone justifies leaving xbmcmythtv behind.

This morning, though, when bragging to my wife how the "new" way things work was so much better, I couldn't get live TV to work. Like others have said, a hard lockup. Sometimes I get the busy dialogue before the hard lockup, and sometimes not.

Here's my loglevel=1 log.
http://pastebin.ca/1052479


It's even damndester now - balthisar - 2008-06-25

I keep trying a couple of times per day, because I know it was working. So, last night, I try to reproduce why it was working originally. I'd kept restarting XBMC (not the Xbox). So I start my Xbox, XBMC starts, and I immediately use the shutdown menu to restart XBMC (only, not the Xbox restart cycle). What do you know! Live TV starts and works mostly fine! If I stop and try again, though, I get the hard lockup until I repeat the startup cycle I described.

Obviously this isn't the most desired behavior, unless I can come up with a script that does that automatically (otherwise: "honey, you've got to do this and this and this first.") I'll try to capture some better logs to post and figure out what's going on. I may also try the other Xboxes -- all three of them are different versions (1.4, 1.5, 1.6), two are soft-mods, and one has a TSOP flash. I'll see if there are any differences. I also need to see if the live TV works on the DirecTV. Every time I want to try, my wife is recording something, so it's only been basic cable that works.

Also, when I change the channels in live TV and press the info button, the screen isn't updated with the current channel's information. Repeat, skip back, and skip forward also don't work.


- lingenfr_xbmc - 2008-07-04

Well, not sure anyone is still paying attention, but the latest T3CH SVN (06-30) is a bit better. I get 3-4 minor stutters and about 15 minutes of livetv before it locks up tight. Here is the log.

http://pastebin.com/d2397db64


- agaffney - 2008-07-05

I'm giving this feature (and XBMC itself) a first try today. I'm using the 6/30 SVN build from T3CH.

First, I must say that XBMC as a whole is really slick. I think this will definitely pass the "spouse test" Big Grin

I set up my myth backend (0.21pre SVN build using protocol 40) in my Video section, and it connects just fine. I can browse my channels and stuff I had previously recorded.

However, when I try to actually view anything (live or pre-recorded), it acts like it's playing but I just get a black screen. This still works fine with the actual mythfrontend and this backend.

The other problem is that when I choose "Guides", nothing happens. Is this part supposed to work yet?


This forum uses Lukasz Tkacz MyBB addons.