Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- elupus - 2008-07-10

Actually that code is already in libcmyth, (we used that method to start with). So I (or you if you feel like it) can add a fallback in the case of whitespace in the name.


- CapnBry - 2008-07-10

Yeah that's why I offered to do it ImageHow about this one-liner workaround to libcmyth?
Code:
Index: xbmc/lib/libcmyth/proginfo.c
===================================================================
--- xbmc/lib/libcmyth/proginfo.c        (revision 14003)
+++ xbmc/lib/libcmyth/proginfo.c        (working copy)
@@ -1659,7 +1659,12 @@
                return NULL;
        }

-       if(control->conn_version >= 32) {
+        /*
+         * mythbackent doesn't support spaces in basenames
+         * when doing QUERY_RECORDING.  If there are spaces, fallback
+         * to enumerating all recordings
+         */
+       if(control->conn_version >= 32 && strchr(basename, ' ') == NULL) {
                pthread_mutex_lock(&mutex);

                snprintf(msg, sizeof(msg), "QUERY_RECORDING BASENAME %s",



- CapnBry - 2008-07-10

Of course, it would help if I spellchecked my comment before posting it. Same patch with mythbackend spelled correctly
Code:
Index: xbmc/lib/libcmyth/proginfo.c
===================================================================
--- xbmc/lib/libcmyth/proginfo.c        (revision 14003)
+++ xbmc/lib/libcmyth/proginfo.c        (working copy)
@@ -1659,7 +1659,12 @@
                return NULL;
        }

-       if(control->conn_version >= 32) {
+        /*
+         * mythbackend doesn't support spaces in basenames
+         * when doing QUERY_RECORDING.  If there are spaces, fallback
+         * to enumerating all recordings
+         */
+       if(control->conn_version >= 32 && strchr(basename, ' ') == NULL) {
                pthread_mutex_lock(&mutex);

                snprintf(msg, sizeof(msg), "QUERY_RECORDING BASENAME %s",



- pshepherd - 2008-07-10

CapnBry Wrote:I'll work with mythtv to get a fix, but Paul the immediate solution to your problem is to not rename your recordings. If you want human-readable names, create another directory and use mythrename.pl to build a symbolic link tree leaving the original filenames intact.

*dumb as it is, I can whip up a patch to do that if you want elupus.

Thanks for both your help in diagnosing this. I convert to readable filenames because I watch all recordings via xbmc using smb (rather than via a myth front end). I may do the sym link but it sounds like you are close to handling spaces in filenames in the code.

Thanks again

Paul


- lingenfr_xbmc - 2008-07-11

lingenfr_xbmc Wrote:Well, not sure anyone is still paying attention, but the latest T3CH SVN (06-30) is a bit better. I get 3-4 minor stutters and about 15 minutes of livetv before it locks up tight. Here is the log.

http://pastebin.com/d2397db64

elupus, do you want us to keep posting these or not? I am still hoping to get this working with reasonable performance on the xbox. I am trying to help by testing the latest releases and posting logs.


- elupus - 2008-07-11

No point. I'll ask if I do any changes for it. I have no idea why perf is so slow for some of you guys.


List of outstanding niggles with myth:// support - dteirney - 2008-07-13

Hey elepus, looks like you are back from vacation - hope you had a great time.

I've got a couple of remaining niggles for the myth:// support (both buried in the growing thread) that would be great to get your or others feedback on.

1) A recorded show isn't removed from the list until it is deleted twice. This happens everytime now whereas it appeared to only be every now and then previously. The log I pasted at pastebin has expired, but is easy to reproduce.

2) Skipping forward and backward doesn't work for shows that are still being recorded. Pressing skip or forward just seems to jump forward or backward a few seconds. Fast forward and rewind still work correctly. I'm not sure if it's related, but the duration of the show doesn't increase either. The duration stays the same as when playback started. I vaguely recall something in the XBMC release notes that was supposed to fix the duration problem.

Unlike others I don't appear to have any issues with performance or stuttering upon playback, although I am not using Live TV yet.

If there's anything I can do to help resolve either of these let me know.


- dteirney - 2008-07-13

New debug log at http://pastebin.com/m7076f664 that shows the problem with needing to "Delete" a recording twice before it is removed from the list of recordings.


- agaffney - 2008-07-15

I found a new aspect to my "black screen while playing recordings" problem. If I try to play the .nuv files directly via SMB, it's all black as well. Isn't the mythtv .nuv format well supported by mplayer (and XBMC by extension)?


- elupus - 2008-07-15

It's not that well supported no. But did you try playing it with dvdplayer (that is what we play with when you use the myth protocol)


- agaffney - 2008-07-15

elupus Wrote:It's not that well supported no. But did you try playing it with dvdplayer (that is what we play with when you use the myth protocol)
I just told it to play. I didn't specify how I wanted to open it.


- waldo22 - 2008-07-16

well... try it in DVDPlayer and see if it works.


- agaffney - 2008-07-16

waldo22 Wrote:well... try it in DVDPlayer and see if it works.
I tried it last night, and it doesn't play in either dvdplayer or mplayer. I get the same thing...the video "plays" (pressing title shows info about the video...its framerate, type (nuv), etc.), but it's just a black screen.

These .nuv files do not play with mplayer on my x86_64 box running linux, either. I just get a green screen and messed up time display. However, I can watch the recordings just fine with mythfrontend on the same box.


- elupus - 2008-07-17

Could you get me a small sample. Not sure when i have the time to look at it, but a sample makes it easier.


- agaffney - 2008-07-17

I've got a 18K .nuv file, but I can't be sure it works at all, since it's from my previous mythtv install. The next smallest file I've got is 282MB.


This forum uses Lukasz Tkacz MyBB addons.