Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- narcan - 2008-07-20

I'm trying to get this running.

I first tried on my Xbox, now secondly on my new Mac Book Pro.

Both from latest SVN.

In both instances the same thing happens, which is just a total freeze.

Here's the log from the Mac Book Pro

http://pastebin.com/me80c590

The backend is Ubuntu Gutsy, myth 0.20+fixes.

Everything works fine either from a mythtv-frontend or the xbmc python script.


- dubstar_04 - 2008-07-20

I have dusted the xbox off and installed a new t3ch build this weekend and I have been having problems with getting the mythtv streams to play on the xbox hardware.

All the information is displayed properly and i can browse the channels and recordings.

The Problem;
When I select a video nothing happens. The video will appear in the 'now playing' list however there isn't actually any output.

I have tried the build from 15-7-08 and I had read that there were problems with playing video. I competely deleted the build from the xbox and ftp'd the build from 30-6-07 and I have the same problems.

I have 2 mythtv boxes and the xbmc linux version is working fine on them so the issue is isolated to the xbox.

Question();
Do you have a the myth:// protocol working with a recent t3ch build?

if so which one?

Is there any thing you can suggest so resolve the issue, other than compiling my own xbox build?

I can post debug logs later. The mrs is watching tv on the main pc at the moment.

many thanks,

Dubstar_04


LiveTV cannot seem to seek to fileposition, possibly why rewind or skip doesn't work - dteirney - 2008-08-03

I've recorded a debug log with some of the problems with Live TV. Not sure if it is related to Myth TV or XBMC itself so I will post in the main XBMC forum as well since this thread hasn't had much traffic of late.

http://pastebin.com/m51f0766f

Throughout the log there are lots of the following.

Code:
15:32:49 M: 26148864 WARNING: error while seeking
15:32:49 M: 26148864   DEBUG: CDVDPlayer::Process - Seeking to catch up
15:32:49 M: 26148864   DEBUG: demuxer seek to: 1943275
15:32:49 M: 26148864   DEBUG: XFILE::CCMythFile::Seek - seek to pos 0, whence 16
15:32:49 M: 26148864   DEBUG: CDVDDemuxFFmpeg::SeekTime - input stream reports it is not seekable



- lingenfr_xbmc - 2008-08-03

Based on the wiki page and other posts, I thought we might be seeing something out of the summer of code by now. I am a bit concerned about the direction this is headed as it seems that it may be focused on the linux branch and hardware more capable than the xbox. If thats the case, I expect I will roll back to the last stable version and be happy with xbmcmythtv script until I decide to replace my xboxes for HD capable hardware.


- elupus - 2008-08-03

livetv doesn't support seek at all at the moment. ff might work a little bit, but unlikely.


- dteirney - 2008-08-04

I've raised a feature request about the seeking.

http://forum.xbmc.org/showthread.php?p=205991


- dteirney - 2008-08-04

@elupus - I've gotten all confused. Does the Live TV seeking issue need to be resolved within the myth:// protocol, or does the player in XBMC need to be updated to support it?


- elupus - 2008-08-04

To clearify:
1. If you start playback from LiveTV folder it won't allow seek...
2. If you start playback from Recordings folder it should allow seek, even if it's currently recording that show. (atleast in the part that has already been recorded).

If 2. isn't true there seem to be a bug.


- dteirney - 2008-08-06

elupus Wrote:To clearify:
1. If you start playback from LiveTV folder it won't allow seek...
2. If you start playback from Recordings folder it should allow seek, even if it's currently recording that show. (atleast in the part that has already been recorded).

If 2. isn't true there seem to be a bug.

Seeking is working for shows that are currently recording when started from the Recordings folder. However we have observed problems once the playback gets past the length of the file that it was when XBMC started playing the file.

For example, if a show starts recording at 8:30 and we start watching at 8:45 XBMC thinks that the file is 15 minutes long. Once playback gets past 15 minutes the seeking seems to get a bit wonky (generally skipping forwards over commercials doesn't work).

To workaround this we stop and start playing and then XBMC thinks the show is now longer so skipping works again (luckily XBMC remembers where we were and carries on from there).

Elupus, do you have any plans to modify Live TV starting so seeking is supported or is that something that alcoheca may need to consider as part of the GSoC PVR project?

Thanks for the support thus far on the myth:// protocol within XBMC. XBMC media handling is way better than Myth TV.


- elupus - 2008-08-06

Seeking is my table. nothing alcoheca should need to look at.


- Anaerin - 2008-08-11

I've found out one way to get Myth's "Commercial Skip" list into an MPlayer-compatible EDL:

http://www.outflux.net/blog/archives/2006/08/02/mythtv-cutlist-to-mplayer-edl-file/

(A sample perl script is here: http://outflux.net/software/shorts/shell/mythwatch.txt)

It doesn't look that difficult (And that's for 0.19, so it's pretty damned old), but it does rely on being able to talk to the DB direct.

Does the cmyth library allow you to get the list of commercials in some form, or to execute ad-hoc queries? If so, can this be added in to grab the commercial list, create an in-ram EDL and point DVDPlayer/MPlayer at it? And as you're playing the file, you can grab the actual FPS value and slot it in, rather than the "Guesstimate" of 29.97 the author has used there. That should (in theory) make commercial skipping work AOK with XBMC and Myth, and satisfy a lot of users. And it would really put the icing on the cake as far as Myth support goes.


- Anaerin - 2008-08-13

Damn. Looks like I hit the "Feature Freeze" wall. Sad


- Trev - 2008-08-14

agaffney Wrote:I tried it last night, and it doesn't play in either dvdplayer or mplayer. I get the same thing...the video "plays" (pressing title shows info about the video...its framerate, type (nuv), etc.), but it's just a black screen.

These .nuv files do not play with mplayer on my x86_64 box running linux, either. I just get a green screen and messed up time display. However, I can watch the recordings just fine with mythfrontend on the same box.

Was this ever resolved? im running into the same problem. I can watch the .nuv's from mythfrontend, but my linuxbox running xbmc and my xbox running xbmc both just get a green screen with audio.


- elupus - 2008-08-14

it wasn't solved. something that ffmpeg doesn't support i suspect. upload a small sample somewhere and i'll have a look when i get time (no timeframe at all)


- EmuMannen - 2008-08-14

Hi everyone, I have been running first VDR and then MythTV successfully for years and I just started to looking into the opportunity to use XBMC as a front-end to my MythTV-back-end (I would prefer to runt the back-end headless scheduling through MythWeb and run XBMC as a general media center with the capability to replay recorded TV. I have tried to read trough this monstrous thread but I might have missed something on the way so please forgive me if I just re-posting already known information...

I just wanted to point at “MythTv Player” (I made a search for it on the forum but came up pretty short). It is open source and a good source of information for the implementation of the MythTV protocol. It might serve as one reference implementation of the protocol and I would therefor like to hint any developers about it. For more information please follow these links:

http://www.sudu.dk/mythtvplayer/index.php?page=home
http://www.sudu.dk/mythtvplayer/index.php?page=mythtv-protocol
http://www.sudu.dk/mythtvplayer/index.php?page=development


This forum uses Lukasz Tkacz MyBB addons.