Kodi Community Forum
MythTV front-end client built-into to XBMC - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Discussions (https://forum.kodi.tv/forumdisplay.php?fid=222)
+--- Forum: Feature Requests (https://forum.kodi.tv/forumdisplay.php?fid=9)
--- Thread: MythTV front-end client built-into to XBMC (/showthread.php?tid=2297)



- flammon - 2008-10-11

I set the video cache to 1024 from 4096 and the stuttering problem did not improve. I'm using the mythtv:// method.


- elupus - 2008-10-11

okey, apperently I wasn't clear enough..... dvdplayer is used for myth playback and cache settings DOES NOT effect dvdplayer at all..


- ptipton - 2008-10-13

In my case the stuttering is just the audio and I dont think this is a general beta2 issue but may be to do with the windows version or my hardware configuration.
On my linux desktop with XBMC beta 2 mythtv works fine.
I have tried XBMC Live on my Windows XP machine but for some reason I cant play any recorded or live TV with this, the backend log just says xbmclive exited with no errors.XBMC live plays other videos no problem. As previously posted beta2 for windows plays livetv and recordings but with stuttering repeating sound.
Thanks


- s7mx1 - 2008-10-14

ptipton Wrote:In my case the stuttering is just the audio and I dont think this is a general beta2 issue but may be to do with the windows version or my hardware configuration.
On my linux desktop with XBMC beta 2 mythtv works fine.
I have tried XBMC Live on my Windows XP machine but for some reason I cant play any recorded or live TV with this, the backend log just says xbmclive exited with no errors.XBMC live plays other videos no problem. As previously posted beta2 for windows plays livetv and recordings but with stuttering repeating sound.
Thanks

It seems shuttering only happens on windows port. I tested with xbox version and linux version and seemed all fine. To have smooth output you need to enable deinterlace.


- ptipton - 2008-10-14

s7mx1 Wrote:It seems shuttering only happens on windows port. I tested with xbox version and linux version and seemed all fine. To have smooth output you need to enable deinterlace.
Tried the dvdplayer fix from here: http://forum.xbmc.org/showthread.php?tid=38726 but didnt make any difference.


- Rand Al Thor - 2008-10-14

Are people running xbmc on windows using the host setting in advancedsettings.xml to get live tv? I have tried with and without but for the life of me I can only get recorded shows to play on my windows machine. I can't watch live tv or browse the epg. I can get a debug later today but if anyone has any tips I would greatly appreciate it. Once you set the host in advancedsettings.xml the line in sources should be myth://mythtv:[email protected] correct? The only thing I can think of is perhaps since I am running an older version of myth there might be incompatibility issues. Anyway, thanks in advance.


- ptipton - 2008-10-15

Rand Al Thor Wrote:Are people running xbmc on windows using the host setting in advancedsettings.xml to get live tv? I have tried with and without but for the life of me I can only get recorded shows to play on my windows machine. I can't watch live tv or browse the epg. I can get a debug later today but if anyone has any tips I would greatly appreciate it. Once you set the host in advancedsettings.xml the line in sources should be myth://mythtv:[email protected] correct? The only thing I can think of is perhaps since I am running an older version of myth there might be incompatibility issues. Anyway, thanks in advance.
I'm not using host settings in advancedsettings.xml and everything works fine other than the jerky sound.


- Rand Al Thor - 2008-10-15

Nevermind. Now that I have spent the entire afternoon bashing my head in trying to get it to work I realized that I had some conflicting hostname issues. It seems to be working now. Thanks for the help.


- s7mx1 - 2008-10-15

Rand Al Thor Wrote:Are people running xbmc on windows using the host setting in advancedsettings.xml to get live tv? I have tried with and without but for the life of me I can only get recorded shows to play on my windows machine. I can't watch live tv or browse the epg. I can get a debug later today but if anyone has any tips I would greatly appreciate it. Once you set the host in advancedsettings.xml the line in sources should be myth://mythtv:[email protected] correct? The only thing I can think of is perhaps since I am running an older version of myth there might be incompatibility issues. Anyway, thanks in advance.

Make sure the database and your mythtv-backend are running on the same machine.

Due to the limited functions of the mythtv support, to get contents of Live TV the client will connect to the mythtv-backend directly.


- jruss - 2008-10-17

I am running XBMC Atlantis Beta 2 on Windows Vista. I am having the same problem many others have reported on this thread. I can browse the recordings on my mythtv backend but I cannot play them. When I try to play, a message pops up stating: "Error Playlist playback aborted Too many consecutive failed items". When I look at the log I get errors about failing to connect on port 6543. Here is my xbmc.log with error highlighted:

http://pastebin.com/m1e118cc6

I run XBMC on my xbox and I can playback mythtv content on that machine. I had to fix the DNS problem for that machine to work. I did that by adding a rule to my dnsmasq settings in my router: address=/pvr/192.168.1.102. That didn't seem to help my windows box so I tried using the advancedstettings.xml file, but that had no effect either. Are there any other things I can try? Or is there more information I could provide to track down this problem?


- jruss - 2008-10-17

Somebody over on the mythtv-users list helped me track down the problem. I set up a VPN connection to my school a few years ago. In the process I had caused the primary DNS suffix on my windows machine to be set to my school's domain. So when XBMC tried to resolve the host name of my backend it had my school's domain appended to it. Unfortunately for me there was actually a machine at my school with the same name as my backend. I removed the DNS suffix and now everything works great.


- elupus - 2008-10-17

hehe, right was just about to say that it probably got the wrong ip Smile


- Anaerin - 2008-11-05

Some (Several) people on the Myth discussion list have asked if it's possible to have the programs returned within XBMC's myth:// listing to be grouped by date/channel/title/genre, so people with a lot of stored programs don't have to scroll through a LONG list to get to what they want. Some simple subfolders would work just fine, I think.

And is there any chance of getting the program subtitle in the listings too? I know XBMC has access to it, as it comes up in the "Info" screen while playing.


- anenigma - 2008-11-05

Anaerin Wrote:Some (Several) people on the Myth discussion list have asked if it's possible to have the programs returned within XBMC's myth:// listing to be grouped by date/channel/title/genre, so people with a lot of stored programs don't have to scroll through a LONG list to get to what they want. Some simple subfolders would work just fine, I think.

And is there any chance of getting the program subtitle in the listings too? I know XBMC has access to it, as it comes up in the "Info" screen while playing.
I was one of the ones wanting this. I've started digging through the libcmyth code, I can work out most of it but I can't for the life of me find any sort of entry point, or where the "Live TV/Recordings/TV Guide" folders are created. If anyone has any pointers, please let me know (anenigma on irc too).

Edit: Found FileSystem/CMythDirectory.cpp, doing some digging now.


- Anaerin - 2008-11-05

From the looks of things, it'd need a little poking around in
Code:
CMythDirectory::GetDirectory(const CStdString& strPath, CFileItemList &items)
To add Directory handlers, and some Sorting/Grouping code to split it into separate folders (Along with handlers for those folders to do some refining).


This forum uses Lukasz Tkacz MyBB addons.