Kodi Community Forum
Release ESPN 3 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release ESPN 3 (/showthread.php?tid=230418)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40


RE: ESPN 3 - dullestknife - 2016-11-04

I love this add-on and it's always worked great for me. Today I had to re-authorize my account for ESPN and ESPN 2 to work, so I did it, got the successful activation message on the Xfinity website, and clicked ok in the ESPN 3 add-on, but now it says these channels may not be included in my service when I try to watch them. Any ideas what could be causing this?


RE: ESPN 3 - ilovemymac - 2016-11-04

Same here but when i go go reauthorize now i get a error unable to authenticate device HTTP ERROR 404: Not Found.
Its with Directv which works with anything else i authorize no problems


RE: ESPN 3 - awaters1 - 2016-11-05

It works for me still, can you guys attach a debug log? Also, if you go to Authentication Details you can De-Authorize the device to try and re-authorize again. If that doesn't work you can try clearing cached data within Settings -> Advanced.


RE: ESPN 3 - ilovemymac - 2016-11-05

ill do that and send a log file


RE: ESPN 3 - ilovemymac - 2016-11-05

OK it did that 2 more times. i finally exited kodi and came back and it finally gave me a new code as before it was always same code. And this time if finally worked.


RE: ESPN 3 - awaters1 - 2016-11-08

Thanks for the information, I'll see if it can give a new code each time authentication is tried, I think that may fix the issue.


RE: ESPN 3 - japes - 2016-11-12

Is anyone else having issues today? It worked fine this morning but just started it back up to watch a game and nothing. Just loads forever and then fails to play. Just want to see if it's just me before I go through too much work.


RE: ESPN 3 - locomot1f - 2016-11-12

i don't think you're alone.

can you post a log so that we can compare the errors.
i'm gonna post mine here in a bit.

hoping that it's just something on ESPN's side


RE: ESPN 3 - locomot1f - 2016-11-12

here's my log - http://sprunge.us/fFUd

i'm gonna take a stab and say it's something on their end.
just like you, I was able to watch things earlier in the day, then all of a sudden -- poof!

seems like even the website is having trouble... just spinning, not getting anything there either -- on my end.


RE: ESPN 3 - japes - 2016-11-12

(2016-11-12, 23:15)locomot1f Wrote: here's my log - http://sprunge.us/fFUd

i'm gonna take a stab and say it's something on their end.
just like you, I was able to watch things earlier in the day, then all of a sudden -- poof!

seems like even the website is having trouble... just spinning, not getting anything there either -- on my end.

your log is nearly identical to mine in the error.


RE: ESPN 3 - vjfyahpaul - 2016-11-29

i'm getting ssl certificate error and if i would like to disable this feature?? can anyone help


RE: ESPN 3 - VladimirRS - 2016-11-30

App cant Start , got this Error in Log: (Win 64bit , Kodi Jarvis 16.1)

Code:
11:40:54 T:3716   DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video)
11:40:54 T:3716   DEBUG:   ParentPath = [addons://sources/video]
11:40:54 T:1112   DEBUG: Thread BackgroundLoader start, auto delete: false
11:40:54 T:1112   DEBUG: Thread BackgroundLoader 1112 terminating
11:40:56 T:3716   DEBUG: CInputManager::ProcessMouse: trying mouse action leftclick
11:40:56 T:3716   DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.espn_3/)
11:40:56 T:3716   DEBUG:   ParentPath = [addons://sources/video]
11:40:56 T:4720   DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin ESPN 3('plugin://plugin.video.espn_3/','5','')
11:40:56 T:4720   DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - waiting on the ESPN 3 (id=7) plugin...
11:40:56 T:3920   DEBUG: Thread LanguageInvoker start, auto delete: false
11:40:56 T:3920    INFO: initializing python engine.
11:40:56 T:3920   DEBUG: CPythonInvoker(7, C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py): start processing
11:40:56 T:3920   DEBUG: -->Python Interpreter Initialized<--
11:40:56 T:3920   DEBUG: CPythonInvoker(7, C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py): the source file to load is "C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py"
11:40:56 T:3920   DEBUG: CPythonInvoker(7, C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py): setting the Python path to C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.beautifulsoup4\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.dateutil\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.elementtree\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.iso8601\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.m3u8\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.simplejson\lib;C:\Users\John\AppData\Roaming\Kodi\addons\script.module.six\lib;C:\Program Files (x86)\Kodi\system\python\DLLs;C:\Program Files (x86)\Kodi\system\python\Lib;C:\Program Files (x86)\Kodi\python27.zip;C:\Program Files (x86)\Kodi\system\python\lib\plat-win;C:\Program Files (x86)\Kodi\system\python\lib\lib-tk;C:\Program Files (x86)\Kodi;C:\Program Files (x86)\Kodi\system\python;C:\Program Files (x86)\Kodi\system\python\lib\site-packages
11:40:56 T:3920   DEBUG: CPythonInvoker(7, C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py): entering source directory C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3
11:40:56 T:3920   DEBUG: CPythonInvoker(7, C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py): instantiating addon using automatically obtained id of "plugin.video.espn_3" dependent on version 2.14.0 of the xbmc.python api
11:40:56 T:3920   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'module' object has no attribute '_create_unverified_context'
                                            Traceback (most recent call last):
                                              File "C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\addon.py", line 19, in <module>
                                                from resources.lib import util
                                              File "C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\resources\lib\util.py", line 13, in <module>
                                                from globals import ADDON_PATH_PROFILE, LOG_LEVEL
                                              File "C:\Users\John\AppData\Roaming\Kodi\addons\plugin.video.espn_3\resources\lib\globals.py", line 48, in <module>
                                                ssl._create_default_https_context = ssl._create_unverified_context
                                            AttributeError: 'module' object has no attribute '_create_unverified_context'
                                            -->End of Python script error report<--
11:40:56 T:3920    INFO: Python script stopped
11:40:56 T:3920   DEBUG: Thread LanguageInvoker 3920 terminating
11:40:56 T:4720   DEBUG:  XFILE::CPluginDirectory::WaitOnScriptResult - plugin exited prematurely - terminating
11:40:56 T:3716   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.espn_3/
11:40:56 T:3716   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.espn_3/) failed
11:40:56 T:3716   DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/video)
11:40:56 T:3716   DEBUG:   ParentPath = []
11:40:56 T:5544   DEBUG: Thread BackgroundLoader start, auto delete: false
11:40:56 T:5544   DEBUG: Thread BackgroundLoader 5544 terminating



RE: ESPN 3 - gskiman - 2016-12-02

I hooked up my Kodi box 11/28/16.
From the ESPN 3 application I was able to view any of the ESPN channels for only 1 day.
Since then every time, instead of any of the ESPN channels that I select appearing, I get message, ESPN 3 Error or message, Playback failed. One or more items failed to play. Check the log for more information about this message.

From the Kodi Logfile Uploader I got this. https://paste.ubuntu.com/23565139

Can someone help me out? Thx


RE: ESPN 3 - awaters1 - 2016-12-05

@vjfyahpaul: There is an option to disable checking SSL certificates within settings.
@VladimirRS: I'll take a look into it, thank you for reportingy.
@gskiman: The error log doesn't contain anything about the ESPN 3 addon, can you try again.


RE: ESPN 3 - awaters1 - 2016-12-05

I pushed 2.9.23 to the custom repository at https://github.com/kodi-addons/repo.kodi-addons I have to test it more, but give it a go to see if it fixes the SSL issues.


This forum uses Lukasz Tkacz MyBB addons.