Kodi Community Forum
Release ESPN 3 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release ESPN 3 (/showthread.php?tid=230418)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40


RE: ESPN 3 - awaters1 - 2016-12-15

Updated to 2.9.24, adobe changed some of the authentication flow, I'll test this version for a few days before pushing to the official repository.


RE: ESPN 3 - nashtndeac06 - 2017-01-03

Anyone else having problems with the main ESPN stream? I am getting a lot of buffering the past week or so. And the funny thing is, it appears to just be the ESPN channel. Clicking on ESPN 2 or any other ESPN channel plays fine in HD with no problems. Only the main ESPN channel do i get lots of buffering that makes it unwatchable. Tried on 2 different Pi's in 2 different states with at least 50 MBs internet connections. So i know its not an internet issue. Any ideas?


RE: ESPN 3 - dbennett78 - 2017-01-03

When I try to play a video on the Raspberry Pi 3, it plays for about 5 seconds, then just stops (almost like its buffering), but doesnt recover. This happens regardless of which quality setting I choose.

I run the same plugin on my android phone, and it works seamlessly. Is there something I need to modify?


RE: ESPN 3 - nola mike - 2017-01-04

Trying to access premium content. I go to the es.pn/appletv web site, enter the code and my provider (xfinity). I then get an "authentication successful" message on an xfinity splash screen, even though I've never been asked for credentials. The plugin then displays the espn content, which then not surprisingly throws an error when I try to play it. I then can't figure out how to log out and try to reauthenticate.

http://pastebin.com/TNKZFznM


RE: ESPN 3 - awaters1 - 2017-01-05

Looks like a DNS issue
Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fe4e2f305d0>: Failed to establish a new connection: [Errno -2] Name or service not known'

If you go down to Authentication Details in the main menu it will bring up a dialog to de-authorize the device.


RE: ESPN 3 - awaters1 - 2017-01-06

2.9.25 has been released https://github.com/xbmc/repo-plugins/pull/845. Mostly contains bug fixes that I have found based on reports and random usage.


RE: ESPN 3 - dado1971 - 2017-01-14

(2017-01-03, 17:05)dbennett78 Wrote: When I try to play a video on the Raspberry Pi 3, it plays for about 5 seconds, then just stops (almost like its buffering), but doesnt recover. This happens regardless of which quality setting I choose.

I run the same plugin on my android phone, and it works seamlessly. Is there something I need to modify?

same here. this addon is unusable on rpi3 runnink kodi 16 or 17...can you fix it?


RE: ESPN 3 - awaters1 - 2017-01-18

That issue isn't fixable, video playback is up to Kodi, not the addon.


RE: ESPN 3 - locomot1f - 2017-01-18

interesting, @dado1971 & dbennett78.

i used to run this add on on my RPi3 with no problems.

couple of things to try:
have you tried Overclocking your machine? Many articles on this, good place to start -- https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=138123

the other is to try some cache buffering through advanced settings (although these type of streams don't do much advanced buffering).
http://kodi.wiki/view/HOW-TO%3AModify_the_video_cache

i'm currently using on Odroid c2. a little bit more power, but shouldn't be that much of a difference.


RE: ESPN 3 - mrdally204 - 2017-01-18

dado1971,

I have seen this happen recently on my Fire tv 2 running Kodi 17 betas and RC. It does not freeze as fast as your does, but it can be 15-20 minutes into a stream, the video stops as if it were a buffer problem but never returns. I have also noticed the time continues to move as if the stream is still playing. I thought it was a 17 rc issue. What version Kodi are you running?


RE: ESPN 3 - locomot1f - 2017-01-18

@mrdally204,

now that, I have seen. when the time keeps running.
there does seem to be a problem with the HW acceleration code on some linux (ARM) machines.
i'm not sure where the bug is, or if it's being worked on.
if you'd like, or can, you can try this version of LibreElec Kodi -- https://libreelec.tv/
i think they've fixed it over there.

or try going into Settings -> Player -> Videos
and turning off Hardware Acceleration
***** Warning ******
Your CPU's will max out, and raise your temperature. Only do this for testing purposes.


RE: ESPN 3 - Smb25 - 2017-01-21

In need of help. My fire stick keeps de-authenticating every few mins.


RE: ESPN 3 - andydufresne - 2017-01-21

Can anyone help with this error while attempting to start the ESPN3 addon:


12:53:30 T:139853740947200 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.NameError'>
Error Contents: name 'err' is not defined
Traceback (most recent call last):
File "/home/andy/.kodi/addons/plugin.video.espn_3/addon.py", line 316, in <module>
xbmc.log('err: %s' % err, xbmc.LOGDEBUG)
NameError: name 'err' is not defined
-->End of Python script error report<--
12:53:30 T:139854504417600 ERROR: GetDirectory - Error getting plugin://plugin.video.espn_3/
12:53:30 T:139854504417600 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.espn_3/) failed


RE: ESPN 3 - awaters1 - 2017-01-22

(2017-01-21, 20:45)Smb25 Wrote: In need of help. My fire stick keeps de-authenticating every few mins.
If you upload a debug log (http://kodi.wiki/view/Log_file/Easy) I can take a look.


RE: ESPN 3 - awaters1 - 2017-01-22

(2017-01-21, 22:00)andydufresne Wrote: Can anyone help with this error while attempting to start the ESPN3 addon:


12:53:30 T:139853740947200 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.NameError'>
Error Contents: name 'err' is not defined
Traceback (most recent call last):
File "/home/andy/.kodi/addons/plugin.video.espn_3/addon.py", line 316, in <module>
xbmc.log('err: %s' % err, xbmc.LOGDEBUG)
NameError: name 'err' is not defined
-->End of Python script error report<--
12:53:30 T:139854504417600 ERROR: GetDirectory - Error getting plugin://plugin.video.espn_3/
12:53:30 T:139854504417600 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.espn_3/) failed

I'll publish a fix for that, in the mean time try disabling SSL Certificate validation.


This forum uses Lukasz Tkacz MyBB addons.