Kodi Community Forum
Release ESPN 3 - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release ESPN 3 (/showthread.php?tid=230418)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40


RE: ESPN 3 - leejk - 2015-09-06

(2015-09-04, 16:07)locomot1f Wrote: @leejk

more than likely. but can't be sure without a debug file.

can you watch the US Open (tennis)?

Hello,

No, I can no longer watch any videos it seems. Here is a log of me trying to play the tennis video or any of the others.
http://goo.gl/UPkfua

thx


RE: ESPN 3 - bef5000 - 2015-09-06

Finally figured out how to launch the WatchESPN app on Windows 10 via the Advanced Launcher (it's a roundabout fix, but it works for now), but I'm really excited for a full WatchESPN app to be released!


RE: ESPN 3 - MetalChris - 2015-09-06

(2015-09-06, 02:11)leejk Wrote:
(2015-09-04, 16:07)locomot1f Wrote: @leejk

more than likely. but can't be sure without a debug file.

can you watch the US Open (tennis)?

Hello,

No, I can no longer watch any videos it seems. Here is a log of me trying to play the tennis video or any of the others.
http://goo.gl/UPkfua

thx

Relevant portion in bold:

Quote:20:14:31 T:139640149354240 NOTICE: ESPN3: get_html: https://espn-ws.bamnetworks.com/pubajaxws/bamrest/MediaService2_0/op-findUserVerifiedEvent/v-2.1?identityPointId=invalid&cdnName=PRIMARY_AKAMAI&channel=espn3&playbackScenario=FMS_CLOUD&partnerContentId=2660101&eventId=176-239960&contentId=453523583&rand=870515&playerId=domestic

Seems you and I have been through this before lol. You'll need to fix your userdata.xml again, and you'll likely only be able to view the HDS and RTMP streams. Check this post.


RE: ESPN 3 - dsb1234 - 2015-09-06

hi,

I am also having problem with watching US open live. I get script failed error. I am verizon customer and can watch espn live on my computer or ipad successfully.
But not on my raspberry pi II. Here is a extract from my log file. Appreciate if you can help.


16:36:14 T:1644950560 NOTICE: Name: [COLOR=FFf5f5f5]11:00 AM - US Open Chase Review Multicam (Third Round)[/COLOR]
16:36:14 T:1644950560 NOTICE: ESPN3: get_html: https://espn.go.com/watchespn/player/config
16:36:15 T:1644950560 NOTICE: ESPN3: get_html: https://espn-ws.bamnetworks.com/pubajaxws/bamrest/MediaService2_0/op-findUserVerifiedEvent/v-2.1?identityPointId=verizon&cdnName=PRIMARY_AKAMAI&channel=espn3&playbackScenario=FMS_CLOUD&partnerContentId=2630081&eventId=176-239098&contentId=449973683&rand=480393&playerId=domestic
16:36:15 T:1644950560 NOTICE: ESPN3: get_response: Could not open URL: https://espn-ws.bamnetworks.com/pubajaxws/bamrest/MediaService2_0/op-findUserVerifiedEvent/v-2.1?identityPointId=verizon&cdnName=PRIMARY_AKAMAI&channel=espn3&playbackScenario=FMS_CLOUD&partnerContentId=2630081&eventId=176-239098&contentId=449973683&rand=480393&playerId=domestic
16:36:15 T:1644950560 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.TypeError'>
Error Contents: object of type 'bool' has no len()
Traceback (most recent call last):
File "/home/osmc/.kodi/addons/plugin.video.espn_3/addon.py", line 454, in <module>
PLAYESPN3(url)
File "/home/osmc/.kodi/addons/plugin.video.espn_3/addon.py", line 196, in PLAYESPN3
PLAY(url,'n360')
File "/home/osmc/.kodi/addons/plugin.video.espn_3/addon.py", line 256, in PLAY
tree = BeautifulSoup(html, 'html.parser')
File "/home/osmc/.kodi/addons/script.module.beautifulsoup4/lib/bs4/__init__.py", line 162, in __init__
elif len(markup) <= 256:
TypeError: object of type 'bool' has no len()
-->End of Python script error report<--
16:36:15 T:1956319232 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
16:36:15 T:1644950560 INFO: Python script stopped


RE: ESPN 3 - locomot1f - 2015-09-06

i'm pretty sure Verizon is one of those you have to login to view.


RE: ESPN 3 - MetalChris - 2015-09-06

(2015-09-03, 19:29)Arse4life Wrote: 720p streams are great. Watching euro qualifiers right now. Tried some replays and they work well. Just the US Open tennis matches can't get any of those to play and there are lots. No biggie.

Please post a link to your Kodi log (wiki).

(2015-09-05, 20:32)jmbrew Wrote: I have valid provider credentials and can view streams via the browser, however I can not view them through the add-on. How do i import those credentials into ESPN3 addon?

The add-on only provides access to free ESPN3 content and does not require a login. Please post a link to your Kodi log (wiki).

(2015-09-06, 21:02)dsb1234 Wrote: hi,

I am also having problem with watching US open live. I get script failed error. I am verizon customer and can watch espn live on my computer or ipad successfully.
But not on my raspberry pi II. Here is a extract from my log file. Appreciate if you can help.

The xml returned from the url looks to be complete and correct. As far as I can tell, the add-on is working correctly up until BeautifulSoup tries to parse the smil file.

I did try to play the event on my Raspberry Pi, which is actually running an old build of Frodo under Wheezy, but the stream would not start. I did not see any errors in my log file regarding BeautifulSoup though. Not much help, but I'm wondering if maybe this is not an add-on or a BeautifulSoup issue, but perhaps caused by heavy 'net traffic which may have prevented access to the smil file. I do remember it frequently taking multiple attempts to get a stream to start when my Pi was my primary XBMC machine.

Then again, locomot1f knows the add-on and BeautifulSoup way better than I do, so he might be better able to track this one down.


RE: ESPN 3 - dsb1234 - 2015-09-07

hi locomot1f,

Let me know if you need to look at entire log file. Where can I upload it ?
I don't see any login screen in the ESPN3 addon setup.

Thanks


RE: ESPN 3 - locomot1f - 2015-09-07

there isn't one, ATM.

i'm trying to understand / incorporate some code.
but it will probably be a while before that happens.

unless someone else comes along that figure it out before me.


RE: ESPN 3 - DonQatWC - 2015-09-07

I'm having a similar issue that started about 3 weeks ago. I have tried different shows (Live or Replays) and always get an error message. I posted my log file at http://xbmclogs.com/pffdm4d24.

Thanks,


RE: ESPN 3 - Arse4life - 2015-09-07

(2015-09-03, 19:29)Arse4life Wrote: 720p streams are great. Watching euro qualifiers right now. Tried some replays and they work well. Just the US Open tennis matches can't get any of those to play and there are lots. No biggie.

Here is my log. I tried US Open events like I mentioned before and nothing plays. I also tried other events and those played fine. ISP-Comcast. Thanks in advance for taking a look.

http://xbmclogs.com/pzdhvieb3


RE: ESPN 3 - MetalChris - 2015-09-07

(2015-09-07, 03:04)DonQatWC Wrote: I'm having a similar issue that started about 3 weeks ago. I have tried different shows (Live or Replays) and always get an error message. I posted my log file at http://xbmclogs.com/pffdm4d24.

Thanks,

Thanks for posting the log, it looks like you're having authentication issues.

Code:
if not authstatus.find('successstatus'):
AttributeError: 'NoneType' object has no attribute 'find'

Try editing your userdata.xml file and change your affiliate name from 'cincinnatibell' to 'cincinnatibell_sso' or 'cbt_sso' and try again. I just tried this and was able to view the US Open Tennis that is currently on which is in HDS format, but not any of the HLS streams. I'm not in Cincinnati though.

Check this page to find out how to access the userdata folder in Windows. Your userdata.xml file will be in the /addon_data/plugin.video.espn_3 subfolder.

(2015-09-07, 03:43)Arse4life Wrote: Here is my log. I tried US Open events like I mentioned before and nothing plays. I also tried other events and those played fine. ISP-Comcast. Thanks in advance for taking a look.

http://xbmclogs.com/pzdhvieb3

Thanks for posting the log - I can see what is happening now.

Code:
21:36:00 T:139676547536640   ERROR: Unable to load librtmp.so.1, reason: librtmp.so.1: cannot open shared object file: No such file or directory

I had this same issue some time ago, not sure why this is occurring, but it can be fixed. You need to find the librtmp.so.0 file on your system (located here in Linux: /usr/lib/i386-linux-gnu/), make a copy of it in the same folder, then rename the copy librtmp.so.1 and you should be good to go.


RE: ESPN 3 - Arse4life - 2015-09-07


Thanks for posting the log - I can see what is happening now.

Code:
21:36:00 T:139676547536640   ERROR: Unable to load librtmp.so.1, reason: librtmp.so.1: cannot open shared object file: No such file or directory

I had this same issue some time ago, not sure why this is occurring, but it can be fixed. You need to find the librtmp.so.0 file on your system (located here in Linux: /usr/lib/i386-linux-gnu/), make a copy of it in the same folder, then rename the copy librtmp.so.1 and you should be good to go.
[/quote]

Thanks for the swift response. Unfortunately, I can't seem to find that file in the directory you provided. I've checked numerous times.

Screenshot of directory


RE: ESPN 3 - MetalChris - 2015-09-07

(2015-09-07, 03:43)Arse4life Wrote:
(2015-09-07, 04:20)MetalChris Wrote: Thanks for posting the log - I can see what is happening now.

Code:
21:36:00 T:139676547536640   ERROR: Unable to load librtmp.so.1, reason: librtmp.so.1: cannot open shared object file: No such file or directory

I had this same issue some time ago, not sure why this is occurring, but it can be fixed. You need to find the librtmp.so.0 file on your system (located here in Linux: /usr/lib/i386-linux-gnu/), make a copy of it in the same folder, then rename the copy librtmp.so.1 and you should be good to go.

Thanks for the swift response. Unfortunately, I can't seem to find that file in the directory you provided. I've checked numerous times.

Screenshot of directory

Ok, it's obviously somewhere else on your system. To find it, enter this in your terminal:

Code:
sudo find / | grep librtmp.so.0



RE: ESPN 3 - Arse4life - 2015-09-07

(2015-09-07, 06:13)MetalChris Wrote:
(2015-09-07, 03:43)Arse4life Wrote:
(2015-09-07, 04:20)MetalChris Wrote: Thanks for posting the log - I can see what is happening now.

Code:
21:36:00 T:139676547536640   ERROR: Unable to load librtmp.so.1, reason: librtmp.so.1: cannot open shared object file: No such file or directory

I had this same issue some time ago, not sure why this is occurring, but it can be fixed. You need to find the librtmp.so.0 file on your system (located here in Linux: /usr/lib/i386-linux-gnu/), make a copy of it in the same folder, then rename the copy librtmp.so.1 and you should be good to go.

Thanks for the swift response. Unfortunately, I can't seem to find that file in the directory you provided. I've checked numerous times.

Screenshot of directory

Ok, it's obviously somewhere else on your system. To find it, enter this in your terminal:

Code:
sudo find / | grep librtmp.so.0

(/usr/lib/x86_64-linux-gnu) This is where it was. Tried the only 2 US Open events on now and it's working flawlessly. I don't have this issue on my other systems running OpenELEC. I'll bookmark this for future reference. Thanks for your help!


RE: ESPN 3 - DonQatWC - 2015-09-07

(2015-09-07, 04:20)MetalChris Wrote: [quote='DonQatWC' pid='2099569' dateline='1441587891']
I'm having a similar issue that started about 3 weeks ago. I have tried different shows (Live or Replays) and always get an error message. I posted my log file at http://xbmclogs.com/pffdm4d24.

Thanks,

Thanks for posting the log, it looks like you're having authentication issues.

Code:
if not authstatus.find('successstatus'):
AttributeError: 'NoneType' object has no attribute 'find'

Try editing your userdata.xml file and change your affiliate name from 'cincinnatibell' to cincinnatibell_sso' or 'cbt_sso' and try again. I just tried this and was able to view the US Open Tennis that is currently on which is in HDS format, but not any of the HLS streams. I'm not in Cincinnati though.

Check this page to find out how to access the userdata folder in Windows. Your userdata.xml file will be in the /addon_data/plugin.video.espn_3 subfolder.

MetalChris,
Thanks for the quick response. I changed the user data file and it's working. Now, I did change providers 2 months ago, I use the faster TWC. What is the affiliate name for TWC in the user data file in case CB stops working?

Thanks!


This forum uses Lukasz Tkacz MyBB addons.