Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) (/showthread.php?tid=231092)



RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - polo_joe - 2015-11-24

@popcornmix

could you make a testbuild with tuned urb buffer?
https://tvheadend.org/issues/3063#change-16600


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Milhouse - 2015-11-24

(2015-11-24, 15:10)popcornmix Wrote: The multi-touch commit does look most likely. @Milhouse can you revert https://github.com/popcornmix/xbmc/commit/00c37ad5876463e6b6612ae3207feb29fc5409ff for tonight's build just to confirm?

Sure.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Ollo - 2015-11-24

I installed #1123 to verify whether the build highlight "Passthrough audio should be fixed in this build" have an effect on my Hifiberry issue posted in #2149 but it doesn't.

DTS passtrough is working well but AC3 provides no sound if it is detected by the receiver and stereo sound if not.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - bagofcrap24 - 2015-11-24

I'm having issues with rebooting with build #1121. havent been about for a couple of weeks so have jumped from #1106 to #1121
my Pi has a cron job to reboot @ 05:00 everyday
both times since jumping to #1121 when I have come in from work, the Pi is completely unresponsive.
Upon pulling the cable & replugging, it boots up as normal and has worked all night.
The thing I did notice was that the library is set to auto scan at 05:30 after the reboot, this started when I manually rebooted the Pi2 meaning that the system had been hung since before 5:30am when the scan should have happened.
The next day I came home, exactly the same thing.
I've tried rebooting from the on screen menu which worked fine.
Just issued a reboot from SSH and the issue has re-occured. The system goes down but doesnt actually restart.
Can anyone else confirm issueing a reboot from SSH or cron, does it complete or is it hanging?

[Edit]
Just updated to 1123 and the same here as well


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-11-24

(2015-11-23, 02:34)menakite Wrote: HDMI has duplicate stream types and Analogue is reporting passthrough ones (and duplicates):
https://p.6core.net/p/USaN1VVeCRJbToBBLhnpW0tZ

Should have a fix for this for tonight's build.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-11-24

(2015-11-24, 21:13)bagofcrap24 Wrote: Can anyone else confirm issueing a reboot from SSH or cron, does it complete or is it hanging?

I've just ssh-ed in to my OE Pi2 at home. "reboot" successfully rebooted and I can ssh back in.
I'm on "devel-20151122213818-#1122-g297af74".

So it's probably not a issue that affects everyone. If you have any peripherals (e.g. USB) attached it might be interesting if unplugging them improves things.
If you can find the first build with the issue that would help narrow down what the problem is.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - bagofcrap24 - 2015-11-24

I'll try this and then search for a working build

[EDIT]
removing external devices had no effect

Jumped back to #1106 and rebooting fine there. I'll find which build stops it


another quick question.
Is this normal behaviour when transferring the update tar to the SD card
Image
It's done this pretty much as long as I can remember.
When transferring largeish files. say the 120MB update. It will stop Usually twice while copying over to the .update folder.
When it stops, it drops to 0MB/s for about 5-10 seconds, than carries on as normal back at 11MB/s
Is this normal or is it the sign of a poorly SDcard?


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - effe.rnr - 2015-11-24

Do you already know when the ALSA-to-PulseAudio bridge will be implemented again? I am using built #1110 but I'd like to update again


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - bagofcrap24 - 2015-11-24

OK build #1119 is the first build where I start having issues rebooting


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - cudencuden - 2015-11-24

(2015-11-24, 06:51)allan87 Wrote:
(2015-11-24, 00:22)cudencuden Wrote: how can we submit request to have ability to update OpenELEC/Kodi from local file? ...like downloading a tar to an USB device...plug USB device into Rpi...then being able to reference tar file on USB device to update OpenELEC/Kodi.
Just to be sure - You are aware that you can update by coping the tar file to the update folder and rebooting? I can't figure why, if you know this, you would be interested in the feature you suggest.

yeah. lol..i have users that's either: a)don't know or care to find out how to browse to kodi update folder via network b)use KODI as a offline media player (with usb drive attached)

and by users i mean friends and relatives who voluntold me as their tech support.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-11-24

(2015-11-24, 22:30)bagofcrap24 Wrote: OK build #1119 is the first build where I start having issues rebooting

Okay - no kernel change. Looks like one of the big list of OE packages that were bumped.
Just guessing, but probably a system lib rather than a kodi lib. Maybe connman bump?


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - BubbleBobble - 2015-11-24

(2015-11-24, 16:06)popcornmix Wrote: No MPEG-2 licence means no HW decode of MPEG-2. That won't keep up at 1080p.
You can buy a licence here.

Thanks. I just edited config.txt with the key and it plays great.

I also got the VC-1.

You really helped me out.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - zaRos - 2015-11-24

can't play any file .mkv after updated to #1123

going back to #1121


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - asavah - 2015-11-25

(2015-11-24, 23:32)zaRos Wrote: can't play any file .mkv after updated to #1123

going back to #1121

Without a debug log you sure are helping a lot.
[/sarcasm]


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Milhouse - 2015-11-25

New OpenELEC Jarvis build #1124: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.3.0 #1 Tue Nov 24 21:04:36 GMT 2015 armv6l GNU/Linux

# vcgencmd version
Nov 18 2015 15:48:41
Copyright (c) 2012 Broadcom
version 0c9af7cde38e223c95c3404f468db8fc5004495c (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20151124210348-#1124-g2b2eee9 [Build #1124]

# vcdbg log msg 2>&1 | grep DTOK
001706.971: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (2b2eee9d, changelog) and tip of XBMC master (7e6c22a4, changelog) with the following modifications: Build Highlights:
  1. Temporarily revert multi-touch support, see if it fixes problem reported by @jackiass
Build Details:
  1. OpenELEC:
    • glibc: add upstream patches (0507ee3c)
    • mesa: update to mesa-11.0.6 (30d9b263)
    • libxml2: update to libxml2-2.9.3 (2b2eee9d)
  2. XBMC:
    • [guilib] Fix gif animations in case of a too large gif. (PR:8380, 1 commit, 2 files changed)
  3. newclock5:
    • New commits in this build:
      • [ios] - add implementation for RendererVTB (f40a23cc)
      • AE: squash me later (2292233c)
      • [PiSink] squash: Also clear passthrough streamTypes (2b28937c)
    • Commits no longer in build:
      • [shader] - fix compilation of glsl shaders for gles (0944f134)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: [pkg] b671fe50: LinuxInputDevice: add support for multi-touch devices (Reason: See if helps jackiass)