Kodi Community Forum
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) (/showthread.php?tid=231092)



RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

I am still facing freezes with RPi2 during watching livetv. It always crashes eventually. I have tried different power supplies, sd cards, no overclock, all the possible permutation settings (with omx, without, sync on/off, mmal on/of, without deinterlacer,.....) but it always crashes. Sometimes it freezes, sometime it restarts kodi.
The interesting thing is that on Rpi1 and with omx player only enabled livetv always works ok but on Pi2 it crashes100% after some time. I'd really like to solve this problem but i have paste already a lot of debug logs and in latest releases the debug logs are ridiculous big. The latest one i have is 120mb.

Milhouse and popcorrnmix what can i do to try to solve those problems. TNX


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - Heiko123 - 2015-08-10

Hey,

with #0809 my EPG is refreshed :-)
I'm happy.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

Milhouse: I am going to try iptv simple client with the same stream. I'd like to rule out tvheadend since Fritcsh said many time that tvheadend can make a mess with stream and iptv simple client just passes the stream to video player without touching them. Since there was some fixes related to streams in tvheadend I'd like to ask you if you can compile the latest tvheadend since you have already the enviroment setup.
TNX


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - L-S-D - 2015-08-10

(2015-08-10, 09:23)illiac4 Wrote: Milhouse: I am going to try iptv simple client with the same stream. I'd like to rule out tvheadend since Fritcsh said many time that tvheadend can make a mess with stream and iptv simple client just passes the stream to video player without touching them. Since there was some fixes related to streams in tvheadend I'd like to ask you if you can compile the latest tvheadend since you have already the enviroment setup.
TNX

are you running tvh locally on your Pi? Do you have speciffic channels causing freezes or is it a global problem for you. Is timeshift enabled in tvheadend as this is the only thing I remember people having problems with the stream.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - maxodolo - 2015-08-10

(2015-08-10, 07:01)illiac4 Wrote: I am still facing freezes with RPi2 during watching livetv. It always crashes eventually. I have tried different power supplies, sd cards, no overclock, all the possible permutation settings (with omx, without, sync on/off, mmal on/of, without deinterlacer,.....) but it always crashes. Sometimes it freezes, sometime it restarts kodi.
The interesting thing is that on Rpi1 and with omx player only enabled livetv always works ok but on Pi2 it crashes100% after some time. I'd really like to solve this problem but i have paste already a lot of debug logs and in latest releases the debug logs are ridiculous big. The latest one i have is 120mb.

Milhouse and popcorrnmix what can i do to try to solve those problems. TNX

Same thing for me. With enabled MMAL live-tv video stops, audio keeps playing, GUI freezes. Reboot necessary.
OMX: No problems.

I am using VDR-VNSI.

Max


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - L-S-D - 2015-08-10

(2015-08-10, 10:40)maxodolo Wrote:
(2015-08-10, 07:01)illiac4 Wrote: I am still facing freezes with RPi2 during watching livetv. It always crashes eventually. I have tried different power supplies, sd cards, no overclock, all the possible permutation settings (with omx, without, sync on/off, mmal on/of, without deinterlacer,.....) but it always crashes. Sometimes it freezes, sometime it restarts kodi.
The interesting thing is that on Rpi1 and with omx player only enabled livetv always works ok but on Pi2 it crashes100% after some time. I'd really like to solve this problem but i have paste already a lot of debug logs and in latest releases the debug logs are ridiculous big. The latest one i have is 120mb.

Milhouse and popcorrnmix what can i do to try to solve those problems. TNX

Same thing for me. With enabled MMAL live-tv video stops, audio keeps playing, GUI freezes. Reboot necessary.
OMX: No problems.

I am using VDR-VNSI.

Max

So it's not just tvh. As I no longer see any freezes with MMAL, advanced deinterlacer and vsync, are you running vdr on the Pi or on another device? Maybe it only stalls with the additional load of the pvr backend?


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

I really have no idea anymore what could be the cause. I have tried already possible. I will try iptvsimple addon to see if it has the same problems. I have timeshif in tvh but only on demand. On 1037U tvheadend stream works B.P.
RPi2 alwasy freezes or. restarts it is just a question of time. I think it has nothing to do with deinterlacer because the same thing happens when even no interlcer is used. The one thing it comes to my mind is tvheadend and this is because i will try iptvsimple addon.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-08-10

(2015-08-10, 07:01)illiac4 Wrote: Milhouse and popcorrnmix what can i do to try to solve those problems. TNX

If you are getting a crash and kodi restarting then post the debug log and crash log to a paste site.
If you can get the same behaviour from a TV recording, then a sample file would be useful.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

Ok but in latest builds debg logs are over 100MB. Streams are the same as i have posted a week or so but sometimes they do crash and sometimes they do not.
Milhouse will you be so kind and compile latest tvheadend if possible so i can see if maybe new tvheadend is going to solve the problem.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-08-10

(2015-08-10, 13:01)illiac4 Wrote: Ok but in latest builds debg logs are over 100MB

That's okay. Enable debug and reboot, and try to catch the failure quickly to keep the unwanted part of the log to a minimum.
But if it's 100MB, then we'll have to deal with that. Try xbmclogs.com - if it's too big for that then use dropbox or google drive.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

ok will do the catch in following days.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-08-10

(2015-08-09, 23:06)Milhouse Wrote: [*][rbp] Add ntsc version of 48Hz mode

In case you were wondering, this allows you to add a custom mode to config.txt
Code:
hdmi_cvt=1920 1080 48 3 0 0 1

which is 1080p48, and this will now show as an option for display mode in system/video.
If you choose 1920x1080 and 47.95 as the refresh rate, you will find you can play 23.97 files without the refresh rate changing.

You could always do this with 23.97, but the GUI looks stuttery at 23.97 - doubling that rate makes things smoother.

Note: this depends on whether your display supports 1080p48. I suspect simple TV's wont. My Dell monitor does. Report back if it works or not and make/model of display.


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - maxodolo - 2015-08-10

(2015-08-10, 11:17)L-S-D Wrote:
(2015-08-10, 10:40)maxodolo Wrote:
(2015-08-10, 07:01)illiac4 Wrote: I am still facing freezes with RPi2 during watching livetv. It always crashes eventually. I have tried different power supplies, sd cards, no overclock, all the possible permutation settings (with omx, without, sync on/off, mmal on/of, without deinterlacer,.....) but it always crashes. Sometimes it freezes, sometime it restarts kodi.
The interesting thing is that on Rpi1 and with omx player only enabled livetv always works ok but on Pi2 it crashes100% after some time. I'd really like to solve this problem but i have paste already a lot of debug logs and in latest releases the debug logs are ridiculous big. The latest one i have is 120mb.

Milhouse and popcorrnmix what can i do to try to solve those problems. TNX

Same thing for me. With enabled MMAL live-tv video stops, audio keeps playing, GUI freezes. Reboot necessary.
OMX: No problems.

I am using VDR-VNSI.

Max

So it's not just tvh. As I no longer see any freezes with MMAL, advanced deinterlacer and vsync, are you running vdr on the Pi or on another device? Maybe it only stalls with the additional load of the pvr backend?

vdr is running on a separate server. on the pi vdr-vnsi client only.

I don't think there is a problem with VDR whatsoever, because with OMX instead of MMAL i have no problems at all. no freezes. everything works. As soon as i try MMAL (and MMAL advanced deinterlacing which i use as default), the problem starts. sometimes within 5 mins sometimes wtihin an hour. happens almost every time on channel switching, rarely when live tv video is running in fullscreen mode. happens on random channels, nothing reproducible.

yesterday i tried the "performance" governor solution instead of force_turbo=1, and at first i thought, this solved the freezes, but after two hours or so: a freeze again. didn't try longer and switched back to OMX.


Max


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - popcornmix - 2015-08-10

(2015-08-10, 16:00)maxodolo Wrote: I don't think there is a problem with VDR whatsoever, because with OMX instead of MMAL i have no problems at all. no freezes. everything works. As soon as i try MMAL (and MMAL advanced deinterlacing which i use as default), the problem starts. sometimes within 5 mins sometimes wtihin an hour. happens almost ever on channel switching, rarely when live tv video is running in fullscreen mode. happens on random channels, nothing reproducible.

With omxplayer disabled, can you try disabling "sync playback to display"?


RE: OpenELEC Testbuilds for RaspberryPi (Kodi 16.0) - illiac4 - 2015-08-10

I am experiencing very similar cases. But even on omx it crashes after some time. The crash or freeze is even faster when not in full screen. Disabling "sync playback to display" has no effect.
Interesting is that on RPi1 if using only Omx player live tv does not crashes but on RPi2 it does.