Kodi Community Forum
OE/Pi 2 NFS mount causing instability - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Raspberry Pi (https://forum.kodi.tv/forumdisplay.php?fid=166)
---- Thread: OE/Pi 2 NFS mount causing instability (/showthread.php?tid=232701)

Pages: 1 2


OE/Pi 2 NFS mount causing instability - username145 - 2015-07-21

Hi,

I have VDR backend set up on my Pi 2 to write recordings to an NFS mount (system-level, NAS), and during any recording, the UI freezes for a moment every few seconds, and if playing a video, drops a large amount of frames. If I set the recording directory to a USB flash drive or the SD card itself, there are no problems.

The Pi is connected to the network via wifi, with plenty of bandwidth. This did not happen in OE 5.95.2 or any 5.x for that matter, but it does in .3 and Milhouse's builds. Any ideas?

Thanks!

Edit: Forgot to mention, using omxplayer allows video to run smoothly during recordings, but not the UI


RE: OE/Pi 2 NFS mount causing instability - popcornmix - 2015-07-21

If Milhouse build has the issue, and you believe it was better in the past, you should be able to identify a specific Milhouse nightly build that went from good to bad behaviour.
Identifying that would be very useful.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-21

(2015-07-21, 14:27)popcornmix Wrote: If Milhouse build has the issue, and you believe it was better in the past, you should be able to identify a specific Milhouse nightly build that went from good to bad behaviour.
Identifying that would be very useful.

Will try-- quick question, can you downgrade to a build through the update folder?


RE: OE/Pi 2 NFS mount causing instability - popcornmix - 2015-07-21

(2015-07-21, 14:29)username145 Wrote: Will try-- quick question, can you downgrade to a build through the update folder?

Yes. Either either download to /storage/.update, or copy to Update folder over SMB, or use Leopold's OE updater add-on.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-21

(2015-07-21, 14:32)popcornmix Wrote:
(2015-07-21, 14:29)username145 Wrote: Will try-- quick question, can you downgrade to a build through the update folder?

Yes. Either either download to /storage/.update, or copy to Update folder over SMB, or use Leopold's OE updater add-on.

Thanks, will find the problematic build


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-22

Found it, the problem begins in build #0626 from here: 224025 (thread)

Kodi's general UI and mmal-player performance tanks when recording to a system-level NAS (NFS set up via system.d instructions here http://wiki.openelec.tv/index.php/Mounting_network_shares ). Exact same setup on build #0625 runs perfectly smooth.


RE: OE/Pi 2 NFS mount causing instability - popcornmix - 2015-07-22

There are a few possibilities:
  1. curl: update to curl-7.43.0 (ef23bf30)
  2. fixed: Don't do GetLength() off-thread is it may be (b)locked by a pe… (PR:7334, 1 commit, 2 files changed)
  3. changed: Don't blindly enable filecache for any internet stream. If it is required for specific situations, it should be hinted there (3bcaece2)
  4. [libnfs] Add streaming cache (d21672c0) (removed)

Now I believe "Don't do GetLength() off-thread" was previously a custom patch in newclock4, and was merged into kodi this build, so shouldn't have changed behaviour.
"Don't blindly enable filecache for any internet stream" was dropped in #0629. Unless the problem was cured by that build, it doesn't sound like that.
For "[libnfs] Add streaming cache" I was under the impression that the library was updated to support a streaming cache, but we weren't enabling it, so I wouldn't expect this to have an effect, but there may be a change in behaviour. I'll need to investigate a bit more, and perhaps add this patch back in.
"update to curl-7.43.0" could certainly affect playing streams from internet, but I wouldn't expect this to affect PVR.

I'll see if I can add "[libnfs] Add streaming cache" back in for tonight's build.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-22

Thanks, please let me know when a build is available, and I'll test it ASAP

(2015-07-22, 13:33)popcornmix Wrote: Now I believe "Don't do GetLength() off-thread" was previously a custom patch in newclock4, and was merged into kodi this build, so shouldn't have changed behaviour.
"Don't blindly enable filecache for any internet stream" was dropped in #0629. Unless the problem was cured by that build, it doesn't sound like that.

I did test #0630 previously, and the problem was still there. Also exists in latest 16.0 builds.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-22

Just noticed those changes you listed are under build #0625, which is the last build that works OK. Do those guesses still apply?


RE: OE/Pi 2 NFS mount causing instability - popcornmix - 2015-07-22

The thing that doesn't make sense is the "[libnfs] Add streaming cache" wasn't present in OE 5.95.2 (or any earlier builds),
so if the streaming cache is required those builds should be bad.

Also you said "NFS mount (system-level, NAS)". I assume you mean these were mounted by OS (e.g. /etc/fstab), so wouldn't be affected by kodi's libnfs.
libnfs only affects paths that kodi uses that begin with "nfs://". Are you using any paths like that from kodi?


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-22

No, the sources, as far as Kodi/VDR are concerned, are local (mounted to /pvr/Recordings). I'm not particularly familiar with linux, so I used the wiki entry from my earlier post, which worked fine until I updated.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-23

This thread seems to kind-of describe the freezing I get, but I can't test it since I just get a "recording aborted" error when attempting to start a recording on the new build: 232630 (thread)


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-23

(2015-07-23, 01:55)username145 Wrote: This thread seems to kind-of describe the freezing I get, but I can't test it since I just get a "recording aborted" error when attempting to start a recording on the new build: 232630 (thread)

Tested it, still there unfortunately


RE: OE/Pi 2 NFS mount causing instability - popcornmix - 2015-07-23

I think the linked thread is related to your problem.
One of the fixed was in last night's Milhouse build. I've added the second fix, which should be in tonight's build.


RE: OE/Pi 2 NFS mount causing instability - username145 - 2015-07-24

You were right, #0723 looks good! No problems so far, though there was no VDR service addon available in the repo on that build, had to downgrade in order to get it.

Think this will make it into the upcoming OE release?