Kodi Community Forum
Win Kodi 15.0 issue with pass through - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Windows (https://forum.kodi.tv/forumdisplay.php?fid=59)
---- Thread: Win Kodi 15.0 issue with pass through (/showthread.php?tid=233791)

Kodi 15.0 issue with pass through - _Andy_ - 2015-07-31


I use Kodi 15.0 on Windows 7 32bit with AMD graphic card with HDMI output.

Kodi is conntected to my Denon X5200w with HDMI. This receiver is capable to decode all formats. I also have an Asus Xonar for music playback.

So i configured the audio output to use WASAPI Asus Xonar. I also enabled pass through and select WASAPI AMD HDMI out and select all supported formats.

Now i play an mkv with DTS-MA. I can't hear any sound. The AVR shows stereo. During playback i enter the audio menu and i can see pass through is off.
If i try to switch on pass through the switch enables for a second and automatically goes off.
I stop playback and go back to the audio setup and pass through is off.

Any hints what's wrong?
Kodi logfile

RE: Kodi 15.0 issue with pass through - _Andy_ - 2015-07-31

I tried Kodibuntu live on a USB stick and it works. So my hardware is not the issue. I get DTS-MA.

I also tried my new NUC i3 and the error is the same. I can't get passthrough to work.

Even AC3 is not working. Passthrough switches automatically off when i try to play a file which needs passthrough.

So whats wrong?

BTW: my graphics card is a AMD 6570 and i tried 3 different drivers. Very old and the latest driver.

RE: Kodi 15.0 issue with pass through - Jogee - 2015-07-31

Sorry, that's not a debug log. It won't help much. You might want to create a proper one as it can help a lot with diagnosing problems.

What I did notice is that you have some errors with your skin. It might be that the skin isn't setting the property correctly, but that is just a guess. It wouldn't hurt to try going back to the default skin (confluence) just to test.

You could also double check your settings against the audio quickstart guide in the wiki.

This forum uses Lukasz Tkacz MyBB addons.