Kodi Community Forum
Solved <hideallitems>true</hideallitems> not working - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
---- Thread: Solved <hideallitems>true</hideallitems> not working (/showthread.php?tid=233832)



<hideallitems>true</hideallitems> not working - david1337 - 2015-07-31

Hi guys

After updating to Isengard, the "<hideallitems>true</hideallitems>" in advancedsettings.xml doesn't work anymore.
The "All Seasons" poster is show in every TV Show. It has never done this before.

-->

<videolibrary>

<hideallitems>true</hideallitems>

</videolibrary>


Can anyone help to figure this out?

Thanks!


RE: <hideallitems>true</hideallitems> not working - Ned Scott - 2015-07-31

It's now an option in the GUI: http://kodi.wiki/view/Kodi_v15_(Isengard)_FAQ#advancedsettings.xml_changes

Settings -> Videos -> Library -> "Show 'all items' entry"


RE: <hideallitems>true</hideallitems> not working - david1337 - 2015-07-31

Ohh it was that simple.
Thanks for your quick response Ned Smile


RE: <hideallitems>true</hideallitems> not working - Lepaka - 2015-08-02

unfortunately is not available in my GUI see picture on the link, neither is working with the advancesettings.xml
and it is annoying to have that "all seasons" available


Kodi 15.0, Git:2015-07-21 - 2f34a0c.xml
Mac OS X 10.10.4

https://flic.kr/p/wN8pjC

can you help me?


thanks


RE: <hideallitems>true</hideallitems> not working - jjd-uk - 2015-08-02

Try changing the Settings Level to Advanced


RE: <hideallitems>true</hideallitems> not working - Lepaka - 2015-08-02

thanks for your quick reply, it was a basic solution Smile


RE: <hideallitems>true</hideallitems> not working - jjd-uk - 2015-08-02

You should have lots of other goodies now available as well, we do this to stop the interface being too cluttered by default and having an overwhelming number of options for the newbie. We try to keep the essential stuff as viewable at Standard Level but opinions will obviously differ on what's essential.


RE: <hideallitems>true</hideallitems> not working - Ned Scott - 2015-08-02

Yeah, I find that odd to have in advanced. Fun fact, OpenELEC defaults to "Advanced" view because they got tired of how many things are hidden. The argument was that OE users were "more advanced than normal Kodi users", but apparently not smart enough to toggle the settings level. To be fair, I think we do need to make a lot more settings "standard".


RE: <hideallitems>true</hideallitems> not working - jjd-uk - 2015-08-02

Personally I'd prefer it done via a "Show advanced options" selection within every settings window.


RE: <hideallitems>true</hideallitems> not working - Ned Scott - 2015-08-02

Kind of like a "more..." button that exposes full controls? I could see that.


RE: <hideallitems>true</hideallitems> not working - jjd-uk - 2015-08-02

Something similar to selections like "Enable passthrough" in Audio Output where a bunch of stuff is hidden by default, and enabling then shows a load more options. So in each settings window you'd have a "Show advanced options" setting with a radio button alongside to enable, thus it would no longer be a global setting, you'd just enabled the advanced options in the required windows.


This forum uses Lukasz Tkacz MyBB addons.