Kodi Community Forum
Win Missing header in Home Window - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
---- Thread: Win Missing header in Home Window (/showthread.php?tid=234124)

Pages: 1 2


Missing header in Home Window - Captor - 2015-08-03

Hi
I am missing the headers "Movies" and "TV-shows" in the Home Window of Kodi 14.2.
Also after updating to Kodi 15 they are missing (I am back to Kodi 14.2 again). In the settings of the skin Confluence they are greyed out. I mean I can not check or uncheck those two for hiding in Home Window. They are totally gone. It is saying like this in the Home Window settings about hiding Home menu buttoms:

Hide - Movies (Videos - Library)
Hide - TV-shows (Videos - Library)

I have no idea what (Videos - Library) means.

How can I get them back? For now I put all my movies in the header: "Video" but I would likte to put them in the missing header: "Movies".
I use Windows 6, 64-bit.

B.R. and Thanks in advance
Captor


RE: Missing header in Home Window - Redwingsfansfc - 2015-08-05

You don't have your video sources content set.


RE: Missing header in Home Window - Captor - 2015-08-05

Dear Redwingsfan
OK, how can I do that? I have no Movie heading to open so that I can set the content. You mean add sources, right?


RE: Missing header in Home Window - steelman1991 - 2015-08-05

See here for set-up of sources http://kodi.wiki/view/Adding_video_sources

It's amazing what you find in that wiki thingy.


RE: Missing header in Home Window - Captor - 2015-08-05

That is not my problem. Maybe I was unclear in my question?

I try again with fewer words:
I dont have "Movie" in the in the heading in the main view. You undertsand what I mean? I can not add sources because the heading is uncomplete. "Movie" and "TV-shows" are missing! "Video" I have and I use that. But I want to use Movie and TV-shows too. But they are gone.

Adding sources is not the issue here I have done that for decades :-). About my question above, I have tryed to find a solution in wiki already but I think this problem is beyond wiki.


RE: Missing header in Home Window - Ned Scott - 2015-08-05

Those only show up once the files in "Videos" have been scanned into the library.


RE: Missing header in Home Window - Captor - 2015-08-05

What do you mean by scanned? You mean the sources added to "Videos"?


RE: Missing header in Home Window - DarrenHill - 2015-08-05

Have you scraped any content (movies or TV shows) into your library? If I remember correctly the Movies and TV-Shows are only available once there is content scraped into your library for the relevant type. If the library is empty then there's nothing to see so they grey out and aren't available.

Access via the Videos heading is direct (essentially file viewing rather than library viewing with accompanying metadata) and so the media should appear there. But if your video sources aren't set up correctly (as per the link above) then the scraping won't work, they won't get added to your library and so the library views (Movies and TV Shows) aren't accessible.


RE: Missing header in Home Window - Captor - 2015-08-05

I remember I had them when I insalled the software 4 years ago. And that time there was no sources added to XBMC at all. Also I have done som installation for several friends and everytime the heading in the main view has "Movies" and "TV-Shows" already. In a pure new installation.
It is only me who donĀ“t have those two...

As I said I am using "videos" now. I have all my sources pointing to that. TV-showsm documentary, Thrillers and so on. But I would like to separate them now. I want the TV-shows in to the header "TV-show" which is abcent...
How can get that back?


RE: Missing header in Home Window - Captor - 2015-08-05

Dear Darren
I understand and I will look into it. I must say it sound reasonable the way you put it. Maybe I rememebr everything wrong.


RE: Missing header in Home Window - Ned Scott - 2015-08-05

We've already told you. You have to scan in your video sources for them to be added. I don't know how you had those tabs previously without you setting it up, and I don't really care. It has never been possible in XBMC/Kodi to automatically have those headers/tabs in Confluence without scanning something into the library. Maybe someone did it for you, or maybe you had some add-on that was triggering the scan for you, but one way or another this had to be done: set content and scan (wiki)


RE: Missing header in Home Window - DarrenHill - 2015-08-05

Your welcome Smile

It's also work looking at the wiki page for Naming_video_files (wiki) and its sub-pages to make sure that your Movies and TV show files are in the correct name format so that the scrapers can recognise them properly for inclusion into the library. It's also often worth checking the scraper database sites themselves (usually thetvdb.com for TV shows and themoviedb.org or imdb.com for movies) to confirm exactly how the files should be named.

This is especially true for TV shows to make sure you get the seasons and episode numbering correct (and the main name itself of course).

Oh and to be clear scanning and scraping are just different words for the same thing in the above posts - grabbing the additional metadata (information, fan art etc) for the shows from the online databases for display in the library views on your Kodi installation.


RE: Missing header in Home Window - Captor - 2015-08-05

Yes it works now. I have got up Movie and TV shows on the main view. Have some problem with getting up the fanarts for TV-shows on the main view. But it is working fine in the Movie heading. Thank you very much all and excuse me for my stupidity.


RE: Missing header in Home Window - Captor - 2015-08-05

Dear Darren
Thank you very much! That link will probably keep me busy for the rest of the year, haha. And I think that is a good thing for your all, hehe.
It is obviously for me now that Kodi is much more advanced then I thought in the beginning. Thanks again.


RE: Missing header in Home Window - DarrenHill - 2015-08-05

Ah yes, always the fun of first setting up the library and getting everything in the right format.

All media players which use scrapers and metadata have that issue (Plex and Emby both also do), and of course they all seem to prefer the naming to be in a slightly different format (although Kodi's scraper does seem to do a fairly reasonable job of working things out). But it is quite powerful and nice looking with the metadata and fan art that it enables over just using the plain file view method in the Video header.


This forum uses Lukasz Tkacz MyBB addons.