Kodi Community Forum
Release skin helper service - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Skinning (https://forum.kodi.tv/forumdisplay.php?fid=12)
+---- Forum: Skin helper addons (https://forum.kodi.tv/forumdisplay.php?fid=300)
---- Thread: Release skin helper service (/showthread.php?tid=235676)



RE: skin helper service - User 224999 - 2015-11-14

(2015-11-14, 06:34)Mr. V Wrote: Hi Marcel,

Having Some issues with what I would like to do. I am trying to get discart to display in a dynamic list panel container on the home screen for library data provider music widgets.

I'm actually thinking it may be a limitation of the script so it may border on a feature request or quite possibly something I have missed.

For music artwork such as Window(Home).Property(SkinHelper.Music.DiscArt).
In the home.xml I have <onload>SetProperty(SkinHelper.WidgetContainer,8001,home)</onload>

It works fine using $INFO[Window(Home).Property(SkinHelper.Music.DiscArt)] outside of container 8001.

So I have two issues
1. Within the panel container 8001 it will not show any discart.
2. I have two containers for widget 1 (8001) and widget 2 (8002). So setting the onload property will not work for each container.

You can't use $INFO properties (home properties or skin settings) inside a container, it's a Kodi limitation.
Even if that would work it wouldn't be a great idea because this method will only provide you the details for the current focused listitem.

I have 2 solutions for your 2 problems Big Grin

1) Look in the documentation for the webservice which you can use inside panels/containers. For example:
<texture background="true">http://localhost:52307/getmusicart&amp;dbid=$INFO[Listitem.DBID]&amp;type=banner,clearlogo,discart&amp;contenttype=artists</texture>

2) You can set onfocus on the panel/container itself, so on your 8001 panel <onfocus>SetProperty(SkinHelper.WidgetContainer,8001,home)</panel>


RE: skin helper service - User 224999 - 2015-11-14

(2015-11-14, 04:30)SeedyEvil Wrote: Just starting to use this great script on a small mod of a MusicVisualisation.xml. I'm using the following to display artist logo.
Code:
<texture>$INFO[Window(Home).Property(SkinHelper.Player.Music.ClearLogo)]</texture>
From what I've seen it uses the Album Artist to find the logo. Would it be possible to use the Track Artist instead as this would work better for the likes of compilation CDs

Hmm, it should use the track artist... At least, that's what it's supposed to do ;-)
I will look into it right away.


RE: skin helper service - User 224999 - 2015-11-14

(2015-11-14, 04:30)SeedyEvil Wrote: From what I've seen it uses the Album Artist to find the logo. Would it be possible to use the Track Artist instead as this would work better for the likes of compilation CDs
Can you test with the latest Git ? I changed it a bit to prefer the real artist instead of the artist belonging to the album.
Remember to flush the cache before testing in the addon settings..


RE: skin helper service - SeedyEvil - 2015-11-15

(2015-11-14, 22:54)marcelveldt Wrote:
(2015-11-14, 04:30)SeedyEvil Wrote: From what I've seen it uses the Album Artist to find the logo. Would it be possible to use the Track Artist instead as this would work better for the likes of compilation CDs
Can you test with the latest Git ? I changed it a bit to prefer the real artist instead of the artist belonging to the album.
Remember to flush the cache before testing in the addon settings..
Tested. Works Brilliantly!!!
Great work Marcel and thanks


RE: skin helper service - Solo0815 - 2015-11-15

(2015-11-15, 03:07)SeedyEvil Wrote:
(2015-11-14, 22:54)marcelveldt Wrote:
(2015-11-14, 04:30)SeedyEvil Wrote: From what I've seen it uses the Album Artist to find the logo. Would it be possible to use the Track Artist instead as this would work better for the likes of compilation CDs
Can you test with the latest Git ? I changed it a bit to prefer the real artist instead of the artist belonging to the album.
Remember to flush the cache before testing in the addon settings..
Tested. Works Brilliantly!!!
Great work Marcel and thanks
I can't confirm that. skin.helper isn't loading any logo for some compilations or is loading the "Various Artists" logo for an album which logo was displayed correctly before.
http://pastebin.com/yEQDpLsY
Album: Creedence Clearwater Revival - The Greatest Hits
IIRC:
first track: no logo at all
second track: logo for "Various Artists"
third and fourth track: correct logo for "Creedence Clearwater Revival"
latest skin.helper with cleared cache
Maybe you can have a look
Thx


RE: skin helper service - tomer953 - 2015-11-15

Marcel, Does this box can't run your helper?
http://www.gearbest.com/tv-box-mini-pc/pp_202596.html
Code:
[script.module.pil]: requires xbmc.python version 2.0.0 which is not available
Debug Log:
http://xbmclogs.com/pllq7pmfx#line-11165


RE: skin helper service - tomer953 - 2015-11-15

Marcel, Since your color picker is become very advanced, I am now Integrating my own color picker with your script.
I moved all my colors, to extras\colors folder and created colors.xml file.
I also made script-skin_helper_service-ColorPicker.xml file,
and I get this error when trying to pick a color:
http://pastebin.com/74v67A7g
this my xml: (but I get the errors with yours xml too)
http://pastebin.com/FCYcQPeN
this is the onclick:
Code:
<onclick>RunScript(script.skin.helper.service,action=colorpicker,shortcutproperty=TextColor)</onclick>
screenshot: http://i.imgur.com/qdcUZoH.jpg


RE: skin helper service - im85288 - 2015-11-15

Marcel did you get a chance to check the track list order? If your busy I can dig in myself and perhaps do a PR if needed. Cheers


RE: skin helper service - User 224999 - 2015-11-16

(2015-11-15, 21:12)im85288 Wrote: Marcel did you get a chance to check the track list order? If your busy I can dig in myself and perhaps do a PR if needed. Cheers

I'll take a look tomorrow. Been busy today with family stuff Big Grin


RE: skin helper service - User 224999 - 2015-11-16

(2015-11-15, 21:12)im85288 Wrote: Marcel did you get a chance to check the track list order? If your busy I can dig in myself and perhaps do a PR if needed. Cheers

Track listing should be fixed with latest Git, can you check please ?
Note to flush the cache first


RE: skin helper service - User 224999 - 2015-11-16

(2015-11-15, 20:13)tomer953 Wrote: Marcel, Since your color picker is become very advanced, I am now Integrating my own color picker with your script.
I moved all my colors, to extras\colors folder and created colors.xml file.
I also made script-skin_helper_service-ColorPicker.xml file,
and I get this error when trying to pick a color:

I have looked at the code and the only error I could spot is when the dialog was closed (back/exit button) when no color was selected it would throw this error. I have just fixed that on Git.


RE: skin helper service - Jayz2K - 2015-11-16

Hi Marcel,

I'm fine tuning my autoconfig and just noticed using the backup restore in silent mode doesn't show the progress and "completed" notification as it was previously. Is this a normal behavior or did I miss something ?

I first thought it wasn't working but I see my views changing realtime, so it writes the settings correctly.
But since it works in background without notifications, I'm also able to browse my designer and change the settings that are writing by your script the same time (and my restore takes about 2/3 mins to write everything).

Thanks


RE: skin helper service - User 224999 - 2015-11-16

(2015-11-15, 13:34)Solo0815 Wrote: I can't confirm that. skin.helper isn't loading any logo for some compilations or is loading the "Various Artists" logo for an album which logo was displayed correctly before.
Maybe you can have a look

I changed the code a bit more in the quest to get the music artwork right.
Can you please test with the latest Git version ?


RE: skin helper service - User 224999 - 2015-11-16

(2015-11-16, 14:55)Jayz2K Wrote: I'm fine tuning my autoconfig and just noticed using the backup restore in silent mode doesn't show the progress and "completed" notification as it was previously. Is this a normal behavior or did I miss something ?

There has never been any notification, it is silent, right...
What was there was a dialogbusy while the action is running but I accidentaly removed that.
Now the busdy dialog is back for silent operations, can you confirm with latest Git ?


RE: skin helper service - Dumyat - 2015-11-16

Hi Marcel,
I've just added some additional pvr poster artwork in the MadNox skin to the includes_PVR.xml file for the ChannelOSDExtended section. However, what I'm finding is that whilst the poster artwork is being displayed, it's only showing for the current item being played, ie when I scroll up/down on each channel the artwork is not changing accordingly like it does with the poster artwork I added to the MyPVRChannels.xml.
This is the code I've used currently, but was hoping you might be able to give me some feedback on what might need to be changed in order for this work correctly:-
PHP Code:
<control type="image">
            <
left>1000</left>
            <
top>520</top>
            <
width>210</width>
            <
height>300</height>
            <
texture fallback="new_pvr/blue/fallback/fallback_tvposter.png">$INFO[Window(Home).Property(SkinHelper.PVR.Poster)]</texture>
        </
control

Any help/advise is as always very much appreciated
Cheers


This forum uses Lukasz Tkacz MyBB addons.