Kodi Community Forum
Release skin helper service - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Development (https://forum.kodi.tv/forumdisplay.php?fid=32)
+--- Forum: Skinning (https://forum.kodi.tv/forumdisplay.php?fid=12)
+---- Forum: Skin helper addons (https://forum.kodi.tv/forumdisplay.php?fid=300)
---- Thread: Release skin helper service (/showthread.php?tid=235676)



RE: skin helper service - User 224999 - 2015-11-23

(2015-11-21, 16:37)Mike_Doc Wrote: Hi Marcel.

Notice a possible issue with clearlogo for music player. It doesn't seem to clear itself should the following atirst not have a clearlogo?

Could you take a look please when you have the time? Thanks Mike.

I just looked in the code and tested it for myself. The artist logo is actually being cleared.
Sure you're using latest version of the script ?


RE: skin helper service - wencaS - 2015-11-23

(2015-11-22, 17:52)marcelveldt Wrote:
(2015-11-22, 00:15)wencaS Wrote: Thanks for this awesome script.

I used a script to choose colors for MOD Stars color according ratings. But not showing opacity slider.

You need to make sure that you have a definition for the slider control in your Defaults.xml otherwise include the codelines inside the colorpicker xml.
Thanks. Inside colorpicker working great.
Image


RE: skin helper service - User 224999 - 2015-11-23

(2015-09-09, 20:49)Jayz2K Wrote: Hi Marcel, yes, the first one. In fact I wanted to add at least the Title on the fanart, because it's confusing when not matching the widget Title. Just an aesthetical / logical display request ... Not that much important. Wink

Latest Git has some additional properties to the backgrounds, such as title, poster and landscape.

Usage:

$INFO[Window(Home).Property(SkinHelper.AllMoviesBackground.Title)]


RE: skin helper service - im85288 - 2015-11-23

Hi Marcel,

I have been trying without success (in Jarvis) to get Color Themes to work. Creating them appears to work correctly, but restoring does not and from what I can see there are no errors in the log. Have you successfully used this feature with Titan under Jarvis? Is there anything I can do to help trouble shoot this. Thanks


RE: skin helper service - tromy - 2015-11-25

(2015-11-23, 22:07)marcelveldt Wrote:
(2015-09-09, 20:49)Jayz2K Wrote: Hi Marcel, yes, the first one. In fact I wanted to add at least the Title on the fanart, because it's confusing when not matching the widget Title. Just an aesthetical / logical display request ... Not that much important. Wink

Latest Git has some additional properties to the backgrounds, such as title, poster and landscape.

Usage:

$INFO[Window(Home).Property(SkinHelper.AllMoviesBackground.Title)]
Just tried the new backgrounds.
Clearlogo and poster work fine but landscape seems not to work in my set up

Thanks


RE: skin helper service - Jayz2K - 2015-11-25

(2015-11-23, 22:07)marcelveldt Wrote:
(2015-09-09, 20:49)Jayz2K Wrote: Hi Marcel, yes, the first one. In fact I wanted to add at least the Title on the fanart, because it's confusing when not matching the widget Title. Just an aesthetical / logical display request ... Not that much important. Wink

Latest Git has some additional properties to the backgrounds, such as title, poster and landscape.

Usage:

$INFO[Window(Home).Property(SkinHelper.AllMoviesBackground.Title)]

Thanks Marcel, will try this ASAP Wink


RE: skin helper service - User 224999 - 2015-11-25

(2015-11-25, 08:39)tromy Wrote: Just tried the new backgrounds.
Clearlogo and poster work fine but landscape seems not to work in my set up

Do you have landscape art in your library ?


RE: skin helper service - User 224999 - 2015-11-25

(2015-11-23, 22:15)im85288 Wrote: Hi Marcel,

I have been trying without success (in Jarvis) to get Color Themes to work. Creating them appears to work correctly, but restoring does not and from what I can see there are no errors in the log. Have you successfully used this feature with Titan under Jarvis? Is there anything I can do to help trouble shoot this. Thanks

It is working fine in my setup. Does the restored/imported theme show up in the list of themes ?


RE: skin helper service - tromy - 2015-11-25

(2015-11-25, 10:47)marcelveldt Wrote:
(2015-11-25, 08:39)tromy Wrote: Just tried the new backgrounds.
Clearlogo and poster work fine but landscape seems not to work in my set up

Do you have landscape art in your library ?
Nod

To be honest,it was a quick test.I'll check again in the evening and tell you for sure.


RE: skin helper service - im85288 - 2015-11-25

(2015-11-25, 11:44)marcelveldt Wrote:
(2015-11-23, 22:15)im85288 Wrote: Hi Marcel,

I have been trying without success (in Jarvis) to get Color Themes to work. Creating them appears to work correctly, but restoring does not and from what I can see there are no errors in the log. Have you successfully used this feature with Titan under Jarvis? Is there anything I can do to help trouble shoot this. Thanks

It is working fine in my setup. Does the restored/imported theme show up in the list of themes ?

Yes it does show up when placed in the skinthemes folder. Selecting it is possible but the changes are not applied.


RE: skin helper service - tromy - 2015-11-25

(2015-11-25, 12:05)tromy Wrote:
(2015-11-25, 10:47)marcelveldt Wrote:
(2015-11-25, 08:39)tromy Wrote: Just tried the new backgrounds.
Clearlogo and poster work fine but landscape seems not to work in my set up

Do you have landscape art in your library ?
Nod

To be honest,it was a quick test.I'll check again in the evening and tell you for sure.
Tested again poster,clearlogo and title work fine but landscape not.Huh


RE: skin helper service - Dumyat - 2015-11-25

Hi Marcel,
I was curious if it might be possible to add the classification rating for movies shown on live Tv, based on the movie classification given on the IMDB site? Also, since IMDB shows this data in text format, would be possible to show the classification as an image like in the local movie library?
Cheers


RE: skin helper service - im85288 - 2015-11-26

double post


RE: skin helper service - badaas - 2015-11-26

Can you support 'colour' for theme color names too pretty please Smile


RE: skin helper service - im85288 - 2015-11-26

Marcel, I have been delving further into the theme issues I have been having and discovered what I think may be part of the problem.

Skin colour settings named like this:
Code:
bordercolor.name
are saved correctly in the theme file

But if you add more dots to the name eg.
Code:
emby.menu.colour.name
then it does not end up in the saved theme file.

Is this something you can fix or do you recommend that skin colors only have a maximum of one "dot" in the name?

By the way both of the above work fine with the
Code:
RunScript(script.skin.helper.service,action=COLORPICKER,skinstring=emby.menu.colour.name)

EDIT - having re-read the readme it seems that it will only pick things up when the word color is in there, could you add colour to this list? Also is it fine with multiple dots?


This forum uses Lukasz Tkacz MyBB addons.