Kodi Community Forum
Beta Youtube Library - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Beta Youtube Library (/showthread.php?tid=246110)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23


RE: Youtube Library - agiefrh46 - 2018-07-01

(2018-07-01, 01:47)Sleuteltje Wrote: So there you go, 7 reasons!

What's up with the drama? It's not like I'm forcing you or anything Wink, just asking IF that would be possible.

Here's an idea. Not sure if it's doable, just asking:
These strm files are supposed to be playlists and may contain multiple entries. So why calling the plugin FROM instead of calling them one after another. For example you put 3 links within the strm file:
1. to the "start" shim, that just saves the current time somewhere
2. to the official YouTube plugin
3. to the "end" shim, that compares the current time minus start time with the file length and makes decision about marking the file.

Would that approach work within the Kodi API/infrastructure?


RE: Youtube Library - RKCRLR - 2018-07-02

(2018-06-30, 22:32)Sleuteltje Wrote:
(2018-06-28, 22:34)agiefrh46 Wrote:  
RKCRLR Wrote:Can I choose another location for my files?
Yes you can. Just create your own folders in a place where you have sufficient write/read permissions. You also need to add this location as a normal source in Kodi (i've read Kodi can otherwise block certain write/read access to this directory if my addon tries to write there without it being a valid source in Kodi). After this you can alter the directory locations for tv, movies and music videos in the addon settings of Youtube Library.
RKCRLR Wrote:Will I be able to specify my NAS or an attached USB hard drive as the location for the downloads?

Any help will be greatly appreciated.
Thanks
Yes, but this is not tested by me but reported to work by others. And yes. 
 I added a folder for the TV shows on my hard drive and told Kodi it is a TV shows folder per the How To tutorial but I'm still having problems.  I've tried uninstalling and reinstalling several times.  Sometimes I get as far as searaching for Youtube videos but I can't seem to get all the way.  And it isn't consistent.  Right now I'm back to the original problem where it just takes me to the top of the menu when I try to add a new channel as a TV show.  
Any suggestions?
Thanks


RE: Youtube Library - RKCRLR - 2018-07-09

I think I have it working, I just kept trying until it would accept my settings.  I now have a TV show playlist I can manage.  
One question - Do I leave the timezone set to default or do I need to set my timezone in GMT?  
Thanks


RE: Youtube Library - RKCRLR - 2018-07-09

One more question - I notice I get an updating Youtube library message when I restart Kodi.  Does that mean that it will start downloading shows if I restart?  (I don't want that).  
Thanks


RE: Youtube Library - RKCRLR - 2018-07-09

OK, TV shows are being downloaded now (approx 5pm PDT).  I set the interval to daily, the time to 3:00, and the timezone to default. 
Is that because I need to change the default time or is it because I restarted Kodi?  
Also, I don't get any sound when I play the files.  Is there a setting I need to change?  
Thanks


RE: Youtube Library - Sleuteltje - 2018-07-09

(2018-07-01, 03:27)agiefrh46 Wrote: Would that approach work within the Kodi API/infrastructure?
No, it would not.
(2018-07-09, 01:06)RKCRLR Wrote: I think I have it working, I just kept trying until it would accept my settings.  I now have a TV show playlist I can manage.  
Good to hear Smile. What was the cause of the issue? In case someone with your problems comes along.
(2018-07-09, 01:06)RKCRLR Wrote: One question - Do I leave the timezone set to default or do I need to set my timezone in GMT?  
Thanks
The timezone setting is meant for offsetting the update time if its in another timezone. Example; lets say you yourself are in GMT+1 and you are following a youtube show that states "new episode every wednesday at 15:00 GMT+2", you can then set the timezone setting of the playlist to "GMT+2" so you don't have to calculate what 15:00 GMT+2 is in your timezone (GMT+1). Hope that clears that up.
RKCRLR Wrote:One more question - I notice I get an updating Youtube library message when I restart Kodi. Does that mean that it will start downloading shows if I restart? (I don't want that).
Thanks
No, it shouldn't. Unless you have stated that it should. There are 2 sort of intervals, one for checking if playlists should be updated (this will run every X amount according to how you set this in the addon settings, default is 30 minutes). This the "updating youtube library message" you are reffering to. Every playlist has a setting of its own on when it should be checked for new videos. If you have left the notification addon settings at default, you should also see a updating message for each of the playlist individually every time the addon will check for new videos for that specific playlist.
RKCRLR Wrote:OK, TV shows are being downloaded now (approx 5pm PDT). I set the interval to daily, the time to 3:00, and the timezone to default.
Is that because I need to change the default time or is it because I restarted Kodi?
Could be a number of factors. Could be the time on your computer is wrong, you have a wrong timezone set in the addon, wrong playlist settings etc.
If you have set the interval for checking the playlists to slow it could be it was just doing its first run of checking playlists at 5:00 pm. Thats why you should let the checking interval run like every 30 minutes max. and set in every playlist when they should be updated. To not have that be a tedious task, you can set default settings for newly created playlist in the addon settings (in the tv, movies, musicvideo tab accordingly).
RKCRLR Wrote:Also, I don't get any sound when I play the files. Is there a setting I need to change?
Thanks
You said you set YTlibrary to download the videos? There should always be sound. Which playlist / video is this about?


RE: Youtube Library - RKCRLR - 2018-07-10

I don't know what I did to fix it, I just kept trying.  I've had similar problems with other apps on the Shield.  I think it has to do with permissions.  Very frustrating.  I made Youtubelibrary/Streams/TV folders in the NVIDIA_SHIELD folder on my USB hard drive.  

Say I want to download any new shows daily at 2am PDT (when my bonus data time period starts).  I set Update every: every day; Update at: 2:00; and Timezone: Default - Correct? 
Or do I set Timezone: GMT:-7?  If it is GMT-7:00 I would actually need to set it to GMT-8 to make sure I don't start at 1 am when the time changes in the fall. 
Also, I assume there isn't a way to to have a cutoff time (my bonus period ends at 8 am) to make sure I don't run over, correct?  

The playlist I made is for LastWeekTonight.  It downloads .mp4, .m4a, and .webm files.  The .m4a files don't show in Kodi.  The .mp4 files have video but no audio.  The .webm have audio but no video.  One thing is Kodi can't use the Add videos... function when the target is a USB hard drive.  I had to navigate to the directory and use the context menu to set the folder as TV shows.  Kodi doesn't appear to make Media Source for the folder using this method (at least for me) so I have to navigate there to play the files.  

Thanks for all of your help.


RE: Youtube Library - RKCRLR - 2018-07-14

Giving this a bump.  

Should a leave the timezone at default or set it to GMT-7:00 if I want to download at 2am PDT?  

Any ideas of what I should try for the video/sound issue?  I get the same results for .mp4 and .webm files using Windows 10 Media Player.  The .m4a files play sound but no video in what appears to be a quick time player.  

Thanks


RE: Youtube Library - RKCRLR - 2018-08-20

I still haven't figured out what is happening with the videos I download.  It appears that the .mp4 files are the video and the .webm files are the audio.  
I don't even know hos this supposed to work.  Should I be getting a single file with both audio and video?  If so, do I have a setting incorrectly set somewhere?  
If I'm supposed to get separate video and audio, is there an add-on I need to install to play them?  
Any help would be appreciated even if it is just to point me where to look.  
Thanks


RE: Youtube Library - Sleuteltje - 2018-08-22

RKCRLR Wrote:Should a leave the timezone at default or set it to GMT-7:00 if I want to download at 2am PDT?
Not sure to be honest. Its been a while since i coded that. If i'm not mistaken, the timezone is just purely to offset times for shows in different timezones then you. I need to try this in my addon again to refresh my memory.
(2018-08-20, 19:16)RKCRLR Wrote: I still haven't figured out what is happening with the videos I download.  It appears that the .mp4 files are the video and the .webm files are the audio.  
I don't even know hos this supposed to work.  Should I be getting a single file with both audio and video?  If so, do I have a setting incorrectly set somewhere?  
If I'm supposed to get separate video and audio, is there an add-on I need to install to play them?  
Any help would be appreciated even if it is just to point me where to look.  
Thanks
It seems you are getting 2 files, one for audio and one for video. ffmpeg is supposed to combine them at the end. Is this on all your videos or just some? Which settings do you use (quality etc.) when downloading? If its just some videos, can you share the videos in question, i can have a look how it behaves with me.

You can also enable debug mode in the addon settings and post your log on paste.ubuntu.com so i can see what's going on.

You can also try to install ffmpeg to see if that resolves the problem.

There are videoplayers available in which you can select a different video and audio file (like vlc). Alltho this is not really a solution imho.

Please let me know what fixed it if something fixed it Smile.


RE: Youtube Library - RKCRLR - 2018-08-23

This is happening to all videos.  I set Download Videos to Best.  Should I set this option to Off?  I tried setting this option to of to see if I would get .strm files downloaded but nothing downloaded.  I'm running Kodi Leia Alpha 3 on a Shield TV if that matters.  I'll post a sample video and audio file but probably not until Thursday or Friday.  

I've enabled debug mode and will post the results Thursday or Friday after it is supposed to run.  

How do I install ffmpeg?  It appears to be part of the Kodi core player?  

I'll for sure let you know if I find the solution.  

Thanks


RE: Youtube Library - RKCRLR - 2018-08-24

I'm trying to download videos from the LastWeekTonight channel at 3 am. 

Here is a link to a folder with a sample video and audio file that downloaded separately:
https://drive.google.com/drive/folders/1WVrhfpWhkscCjolTBHC3SsghSiZVjPx2?usp=sharing

Youtube Library stopped adding new episodes on schedule (this may have happened when I updated to Leia - can't remember) so I uninstalled and reinstalled it.  

I manually updated the Playlist with Download Videos set to off.  It created a bunch of .strm and .nfo files in the Lastweektonight folder.  I can stream these videos from Kodi TV Shows.  

When I switch Download Videos to best and manually update, the playlist appears to update but no videos are downloaded.  

The playlist doesn't update on schedule anymore (or I don't understand the settings).  

The debug log either isn't being created or I don't know where to find it (I looked in the .kodi\userdata\addon_data\plugin.video.youtubelibrary, .kodi\addons\plugin.video.youtubelibrary, and .kodi\temp folders).  

I did notice the following in the Kodi log file (don't know if it is related):
T:159745410288  NOTICE: script.module.youtube.dl: youtube_dl core version: 2018.04.25
T:159745410288 WARNING: Attempt to use invalid handle -1

Sorry for the all of the problems and thanks for any help.


RE: Youtube Library - RKCRLR - 2018-09-09

I've done some playing around and come to the conclusion that there is something wrong with downloading videos.  I installed Youtube Library on a LibreELEC box and got similar results.  
I can download .strm files fine.  I just can't download whole videos to watch offline.  I discovered the videos I did download (the ones with separate video and audio) are old files.  No newer files download.  That is why I thought videos weren't being scheduled to download. 
I tried downloading videos from the website in the tutorial (Linus Tech Tips).  Same results.  I can download .strm files fine but the few webm files that do download have separate video and audio.  
Still hoping this can be resolved, let me know if there is anything I can do to help.  
Thanks


RE: Youtube Library - agiefrh46 - 2019-01-31

Hi Sleuteltje. Any plans to make the plugin compatible with the v18 UWP version? It's no longer working due to lack of Python _subprocess module.
See bullet #3 in "Can't be implemented" here.


RE: Youtube Library - Albinator - 2019-03-07

Are you still working on the addon? Looks really cool.