Kodi Community Forum
HowTo compile the latest version of Ember from SourceCode - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (https://forum.kodi.tv/forumdisplay.php?fid=116)
+---- Forum: Ember Media Manager (https://forum.kodi.tv/forumdisplay.php?fid=195)
---- Thread: HowTo compile the latest version of Ember from SourceCode (/showthread.php?tid=254955)

Pages: 1 2 3 4


RE: HowTo compile the latest version of Ember from SourceCode - Monk - 2016-01-24

Like you described the latest stable NSIS fails. I think this is due to the bat, which calls NSIS kind mangles the paths. The following works for me, but is kind an ugly hack:

Code:
SET mypath=%~dp0
SET EMM_FILENAME=Ember Media Manager.exe
SET EMM_APPNAME=Ember Media Manager BETA
cd ..
SET EMM_ROOT=%CD%
cd %mypath%

Just for reference, %~dp0 returns the directory the script is located (not the path from which the script is called) and %CD% is the current working directory.


RE: HowTo compile the latest version of Ember from SourceCode - luc290670 - 2016-02-03

In Step 6, I get the following message:

Error in script "Beta_1.4_InstallerScript.nsi" on line 213 - - aborting creation process.

With an older version some 2 weeks ago it worked well.


RE: HowTo compile the latest version of Ember from SourceCode - DanCooper - 2016-02-03

(2016-02-03, 20:52)luc290670 Wrote: In Step 6, I get the following message:

Error in script "Beta_1.4_InstallerScript.nsi" on line 213 - - aborting creation process.

With an older version some 2 weeks ago it worked well.

That error means translation from Transifex not found. Try to manually run the "txAccount.bat" and setup your Transifex account.


RE: HowTo compile the latest version of Ember from SourceCode - luc290670 - 2016-02-04

Thanks ! Did it.


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-08

Quote:*******************************************
* Creating setup file... *
* PLEASE WAIT *
*******************************************
File: ".\translations\*.*" -> no files found.
Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] |
/oname=outfile one_file_only)
Error in script "Beta_1.4_InstallerScript.nsi" on line 213 -- aborting creation process
************************************************
DONE!

Setup is located at
D:\GitHub\Ember-MM-Newscraper\BuildSetup\Builds\Ember Media Manager BETA 1.4.7.2 x86.exe
************************************************
Press any key to continue . . .

Ok complete failure. the 2 .dlls are missing from the project. Looking for solution. Any ideas?


RE: HowTo compile the latest version of Ember from SourceCode - DanCooper - 2016-02-08

See two posts above.


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-08

I tried to follow those posts but no go. I created a transifex account using my github login, but no avail

AxInterop.AXVLC.dll and Interop.AXVLC.dll are missing as well

How do I setup the account @ transifex?

Does it know what project I want to get automatically?

Error from VB: Could Not Find D:\GitHub\Ember-MM-Newscraper\EmberMM - Release - x86\Bin\SQLite.Interop.dll


RE: HowTo compile the latest version of Ember from SourceCode - DanCooper - 2016-02-08

(2016-02-08, 10:39)arcelas Wrote: I tried to follow those posts but no go. I created a transifex account using my github login, but no avail

AxInterop.AXVLC.dll and Interop.AXVLC.dll are missing as well

How do I setup the account @ transifex?

Does it know what project I want to get automatically?

Error from VB: Could Not Find D:\GitHub\Ember-MM-Newscraper\EmberMM - Release - x86\Bin\SQLite.Interop.dll

VLC and AxInterop.AXVLC.dll / Interop.AXVLC.dll are no longer need (I've updated the tutorial).

You have to setup the Transifex account with "txAccount.bat" and test it with "txDownload.bat".


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-08

I must be a special kind of moron. I cannot get it to compile to save my life. Going to try once more from scratch, then I guess I'm waiting for the release like all other jackoffs.


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-08

Quote:*******************************************
* Creating setup file... *
* PLEASE WAIT *
*******************************************
File: ".\translations\*.*" -> no files found.
Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] |
/oname=outfile one_file_only)
Error in script "Beta_1.4_InstallerScript.nsi" on line 213 -- aborting creation process
************************************************
DONE!

Setup is located at
D:\GitHub\Ember-MM-Newscraper\BuildSetup\Builds\Ember Media Manager BETA 1.4.7.2 x86.exe
************************************************
Press any key to continue . . .

Same errors. Damn. Any idea what I'm doing wrong?


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-08

Quote:*******************************************
* Creating setup file... *
* PLEASE WAIT *
*******************************************
File: ".\translations\*.*" -> no files found.
Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] |
/oname=outfile one_file_only)
Error in script "Beta_1.4_InstallerScript.nsi" on line 213 -- aborting creation process
************************************************
DONE!

Setup is located at
D:\GitHub\Ember-MM-Newscraper\BuildSetup\Builds\Ember Media Manager BETA 1.4.7.2 x86.exe
************************************************
Press any key to continue . . .

Ok. I want to start over from creating my Transifex account. I logged into transifex using my github account info.
I cloned the source from github, opened and built project with VB, ran "txAccount.bat" and tested it with "txDownload.bat". Nothing happened. I then tried to use the 0_BuildSetup_x86.bat file to compile and create an installer. That's when I get the same error message every time.


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-09

Oh please help. I'd love to be able to compile source code on my own for a variety of things. I thought this would be the easy one...


RE: HowTo compile the latest version of Ember from SourceCode - Cocotus - 2016-02-10

(2016-02-09, 06:14)arcelas Wrote: Oh please help. I'd love to be able to compile source code on my own for a variety of things. I thought this would be the easy one...

For an quick and dirty solution you could skip and Setp 4 and 5.

In Step 3 you created a release with Visual Studio ("Build..." Strg+Shift+B) -> This will generate the files right in "..\Ember-MM-Newscraper\EmberMM - Release - x86". You can directly start the EmberManager.exe there and it will start. I did that in the past whenever I wanted to use a nightly Ember for my movie library. Downside is you won't have other languages than English (which is default) because you didn't do the Transiflex par - also your missing the automatic updates I think. But maybe thats enough for you?


RE: HowTo compile the latest version of Ember from SourceCode - hslansky - 2016-02-10

Hi,
Which is the appropriate thread to post issues found when testing the compiled code (not compiling the code)? I don't want to clog this thread if this is not the proper location

Thanks


RE: HowTo compile the latest version of Ember from SourceCode - arcelas - 2016-02-10

(2016-02-10, 00:56)Cocotus Wrote:
(2016-02-09, 06:14)arcelas Wrote: Oh please help. I'd love to be able to compile source code on my own for a variety of things. I thought this would be the easy one...

For an quick and dirty solution you could skip and Setp 4 and 5.

In Step 3 you created a release with Visual Studio ("Build..." Strg+Shift+B) -> This will generate the files right in "..\Ember-MM-Newscraper\EmberMM - Release - x86". You can directly start the EmberManager.exe there and it will start. I did that in the past whenever I wanted to use a nightly Ember for my movie library. Downside is you won't have other languages than English (which is default) because you didn't do the Transiflex par - also your missing the automatic updates I think. But maybe thats enough for you?

Well I only speak and write english so should be fine for me. Annoying that I cannot make an installer though...


This forum uses Lukasz Tkacz MyBB addons.