Kodi Community Forum
Release Retrospect v5.3.2 Video Add-On - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Retrospect v5.3.2 Video Add-On (/showthread.php?tid=25522)



- cloud79 - 2008-11-22

Basje Wrote:There are two problems:

First one is that your XBMC does not know how to play RealMedia video files. That is why the first playback does not start.

Second problem is the script, which tries to determine the url to a second time and fails because it already did that.

The first problem I cannot fix, the second I can and I just did. You can find a new channel with the Auto update function of XOT (contextmenu on the Channel overview).

There are two different formats avaliable. One is realmedia, and the other one that i think should be working is windows media wmv.


- vedix - 2008-11-24

Basje Wrote:It seems like XBMC is having trouble reading the Realmedia stream. I could check it for you tonight. I will let you know.

EDIT: Seems to be a XBMC win32 problem. Got the same here. So I cannot help you out at the moment.


Ok thanks alot anyway. I formated and reinstalled everything with a newer bootdisc than I had before. Now I get some videos 20% to work in the SVT.


- sniffertje - 2008-11-24

Kanalenkiezer and other channels are not working in XBMC for windows?


- Basje - 2008-11-24

sniffertje Wrote:Kanalenkiezer and other channels are not working in XBMC for windows?

Yep, Win32 sucks at streaming. That is why. Check the linux or xbox version and see if they work there.


- sniffertje - 2008-11-24

I have no linux or xbox, Is there a solution comming for this problem?


- Basje - 2008-11-24

sniffertje Wrote:I have no linux or xbox, Is there a solution comming for this problem?

Not from me. This is a XBMC problem, so I cannot solve it. Sorry.


- Razor_109 - 2008-11-25

for me this script still doesn't work on Linux, at least not the WMV streams (SBS6, RTL, etc) MSS stream's work (NED1, NED2), or does it work on linux-XBMC with other people?

Else i'm gonna make a ticket and hope one of the developers will take a look at it, guess it's a problem with .WMV streaming due to lack of codecs maybe?


- cloud79 - 2008-11-28

Basje:

I saw that you updated the svt channel.

Tough it seems to be a problem for xbmc live to playback even the wmv stream. Seems to be a dead end. Xbcm doesn't seem to handle wmv nor ram streams. Thanks anyway for making an effort and listening to the users. That's great! Thanks!

//Linus

Code:
...
20081128 19:17:29 - DEBUG    - guicontroller.py - 146 - Showing rating: None
20081128 19:17:29 - INFO     - uriopener.py     - 417 - Determining which Progessbar to use....
20081128 19:17:29 - INFO     - uriopener.py     - 425 - FileSize is unknown
20081128 19:17:29 - INFO     - uriopener.py     - 194 - Url http://svt.se/svt/road/Classic/shared/mediacenter/navigation.jsp?d=72574 was opened successfully
20081128 19:17:30 - INFO     - chn_svt.py       - 90  - Performing Pre-Processing
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:30 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:31 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:32 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:32 - DEBUG    - chn_svt.py       - 142 - starting FormatVideoItem for Sveriges Television
20081128 19:17:32 - DEBUG    - chn_class.py     - 713 - Starting ProcessPageNavigation
20081128 19:17:32 - DEBUG    - chn_class.py     - 728 - No pages found.
20081128 19:17:32 - DEBUG    - guicontroller.py - 46  - DisplayPageNavigation starting
20081128 19:17:32 - DEBUG    - guicontroller.py - 69  - DisplayFolderList needs to display 30 items.
20081128 19:17:32 - DEBUG    - guicontroller.py - 69  - + Focussed is on item 0
20081128 19:17:32 - DEBUG    - chn_svt.py       - 168 - starting UpdateVideoItem for Avsnitt 133 (Sveriges Television)
20081128 19:17:32 - DEBUG    - chn_class.py     - 966 - Going to cache
20081128 19:17:32 - INFO     - uriopener.py     - 148 - Opening requested uri Async: http://svt.se/svt/road/Classic/shared/mediacenter/player.jsp?a=1318650&d=72574 (already 1 threads)
20081128 19:17:32 - INFO     - uriopener.py     - 417 - Determining which Progessbar to use....
20081128 19:17:32 - INFO     - uriopener.py     - 425 - FileSize is unknown
20081128 19:17:32 - INFO     - uriopener.py     - 194 - Url http://svt.se/svt/road/Classic/shared/mediacenter/player.jsp?a=1318650&d=72574 was opened successfully
20081128 19:17:32 - DEBUG    - chn_svt.py       - 196 - Found mediaurl: http://www.svt.se/content/1/c8/01/31/86/50/AA2008-EP133-JSHEH6_1.asx
20081128 19:17:32 - INFO     - guicontroller.py - 112 - Updating item (GUIDs match)
20081128 19:17:32 - INFO     - guicontroller.py - 119 - All items where shown. Now fetching focussed item info for item number 0
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - Fetching info for 'Avsnitt 133'. Setting:
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - | Description: Start
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - | Film & Drama
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - | Andra Avenyn
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - | Andra Avenyn: avsnitten
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - | Avsnitt 133
20081128 19:17:32 - DEBUG    - guicontroller.py - 127 - + Image: /home/xbmc/.xbmc/scripts/My Scripts/XOT-Uzg.v3/channels/svt/svtimage.png
20081128 19:17:32 - DEBUG    - guicontroller.py - 146 - Showing rating: None
20081128 19:17:32 - DEBUG    - chn_class.py     - 242 - onAction (with buttonid=61453 and id=7) detected (ThrdID=-1660961904)
20081128 19:17:33 - DEBUG    - chn_class.py     - 317 - OnClick detected on controlID = 50
20081128 19:17:33 - DEBUG    - chn_class.py     - 321 - Trying to determine what to do with the onClick
20081128 19:17:33 - DEBUG    - chn_class.py     - 345 - OnClick detected on EPList
20081128 19:17:33 - DEBUG    - chn_class.py     - 351 - Detected Video file
20081128 19:17:33 - INFO     - chn_class.py     - 365 - Starting playback of Avsnitt 133 (mediaurl=http://www.svt.se/content/1/c8/01/31/86/50/AA2008-EP133-JSHEH6_1.asx)
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - Fetching info for 'Avsnitt 133'. Setting:
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - | Description: Start
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - | Film & Drama
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - | Andra Avenyn
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - | Andra Avenyn: avsnitten
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - | Avsnitt 133
20081128 19:17:33 - DEBUG    - guicontroller.py - 127 - + Image: /home/xbmc/.xbmc/scripts/My Scripts/XOT-Uzg.v3/channels/svt/svtimage.png
20081128 19:17:33 - DEBUG    - guicontroller.py - 146 - Showing rating: None
20081128 19:17:33 - DEBUG    - chn_svt.py       - 220 - Parsing ASX
20081128 19:17:33 - INFO     - uriopener.py     - 148 - Opening requested uri Async: http://www.svt.se/content/1/c8/01/31/86/50/AA2008-EP133-JSHEH6_1.asx (already 1 threads)
20081128 19:17:33 - INFO     - uriopener.py     - 417 - Determining which Progessbar to use....
20081128 19:17:34 - INFO     - uriopener.py     - 422 - FileSize is known (fileSize=230)
20081128 19:17:35 - INFO     - uriopener.py     - 194 - Url http://www.svt.se/content/1/c8/01/31/86/50/AA2008-EP133-JSHEH6_1.asx was opened successfully
20081128 19:17:35 - INFO     - chn_svt.py       - 207 - Starting Video Playback of mms://wm0.c90805.cdn.qbrick.com/90805/kluster/20081119/AA2008-EP133-JSHEH6_1.wmv using the defaultplayer
20081128 19:17:35 - INFO     - chn_class.py     - 924 - Starting Video Playback using the defaultplayer
20081128 19:17:35 - INFO     - chn_class.py     - 932 - Going to playback a single item mms://wm0.c90805.cdn.qbrick.com/90805/kluster/20081119/AA2008-EP133-JSHEH6_1.wmv
20081128 19:17:35 - INFO     - chn_class.py     - 942 - Playing using default player



- M-Jay - 2008-12-08

I got my Apple TV today and installed UZG in XBMC, it works but buffering is very slow. The non commercial channels seem to be working, the other channels gave an error. I'll be doing some more testing tomorrow.


- Fitho - 2008-12-09

I can't get XOT-UZG to load.

The next lines are from the XBMC.LOG
22:47:28 T:3080 M:1971728384 NOTICE:
22:47:28 T:3080 M:1971728384 NOTICE: Traceback (most recent call last):
22:47:28 T:3080 M:1971728384 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\default.py", line 119, in ?
22:47:28 T:3080 M:1971724288 NOTICE: globalLogFile = logger.Customlogger(os.path.join(config.rootDir, config.logFileName), config.logLevel, config.logDual)
22:47:28 T:3080 M:1971724288 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\resources\libs\logger.py", line 55, in __init__
22:47:28 T:3080 M:1971724288 NOTICE: self.OpenLog()
22:47:28 T:3080 M:1971724288 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\resources\libs\logger.py", line 62, in OpenLog
22:47:28 T:3080 M:1971724288 NOTICE: self.fileDescriptor = os.open(self.logFileName, self.fileFlags)
22:47:28 T:3080 M:1971724288 NOTICE: OSError: [Errno 13] Permission denied: 'C:\\Program Files\\XBMC\\scripts\\XOT-Uzg.v3\\uzg.log'

It can't create the uzg.log file. Seems like Vista has some weird restrictions on C:. I tried creating it myself, but that's not possible. Also tried unchecking read-only for that folder, but that does not change a thing.
What can I do to make this work?

Anyway, thanks for this great script.


- Basje - 2008-12-09

Fitho Wrote:I can't get XOT-UZG to load.

The next lines are from the XBMC.LOG
22:47:28 T:3080 M:1971728384 NOTICE:
22:47:28 T:3080 M:1971728384 NOTICE: Traceback (most recent call last):
22:47:28 T:3080 M:1971728384 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\default.py", line 119, in ?
22:47:28 T:3080 M:1971724288 NOTICE: globalLogFile = logger.Customlogger(os.path.join(config.rootDir, config.logFileName), config.logLevel, config.logDual)
22:47:28 T:3080 M:1971724288 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\resources\libs\logger.py", line 55, in __init__
22:47:28 T:3080 M:1971724288 NOTICE: self.OpenLog()
22:47:28 T:3080 M:1971724288 NOTICE: File "C:\Program Files\XBMC\scripts\XOT-Uzg.v3\resources\libs\logger.py", line 62, in OpenLog
22:47:28 T:3080 M:1971724288 NOTICE: self.fileDescriptor = os.open(self.logFileName, self.fileFlags)
22:47:28 T:3080 M:1971724288 NOTICE: OSError: [Errno 13] Permission denied: 'C:\\Program Files\\XBMC\\scripts\\XOT-Uzg.v3\\uzg.log'

It can't create the uzg.log file. Seems like Vista has some weird restrictions on C:. I tried creating it myself, but that's not possible. Also tried unchecking read-only for that folder, but that does not change a thing.
What can I do to make this work?

Anyway, thanks for this great script.

Run with elevated rights (as admin)? Or move your scripts folder to your profile. I would do the latter


- Fitho - 2008-12-09

Basje Wrote:Run with elevated rights (as admin)? Or move your scripts folder to your profile. I would do the latter

I am running as admin. I can terminate Vista's UAC/UAP, but that causes other issues.
I tried moving the scripts folder, but I couldn't find where to change the path in XBMC. That didn't work.
As Vista seems te be protecting only certain folders like Program Files, I tried moving the entire XBMC-folder (from program files) to the C: root. It fixed the problem.
XBMC and the standard included script, Apple Movie Trailers, do their caching and logging in the profile folder, maybe XOT-UZG should also. But I seem to be the only one having this issue, so don't waste your time on it. It's probably something I missed.

Seems to work great now.

Thanks.


- Basje - 2008-12-09

Fitho Wrote:I am running as admin. I can terminate Vista's UAC/UAP, but that causes other issues.
I tried moving the scripts folder, but I couldn't find where to change the path in XBMC. That didn't work.
As Vista seems te be protecting only certain folders like Program Files, I tried moving the entire XBMC-folder (from program files) to the C: root. It fixed the problem.
XBMC and the standard included script, Apple Movie Trailers, do their caching and logging in the profile folder, maybe XOT-UZG should also. But I seem to be the only one having this issue, so don't waste your time on it. It's probably something I missed.

Seems to work great now.

Thanks.
It is because XOT tries to write in the XBMC\Scripts\XOT folder and that is not allow in c:\program files\ (that is why you can try running XBMC by right clicking, and select Run as Administrator).

Or try it as a plugin, by moving it to your plugin folder in your profile folder. Or, move your complete XBMC into your own profile folder or my documents.


- tomten - 2008-12-10

Basje Wrote:It seems like XBMC is having trouble reading the Realmedia stream. I could check it for you tonight. I will let you know.

EDIT: Seems to be a XBMC win32 problem. Got the same here. So I cannot help you out at the moment.
I have the same problems as vedix with the SVT channel, but I'm using XBMC 8.10 on XBOX. The directory loads fine, some videos work, but most videos just hang when trying to start... what can I do to help debug? Or is it the RM thing?


- bitflusher - 2009-01-11

did you know:
xot works with windows xp, i can select and play but only when i use a keyboard, with a mouse however it just simply ignores user input.


This forum uses Lukasz Tkacz MyBB addons.