Kodi Community Forum
Release Retrospect v5.3.2 Video Add-On - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Retrospect v5.3.2 Video Add-On (/showthread.php?tid=25522)



- Basje - 2011-11-07

richmoijn Wrote:Hi,

First of all, thanks for a great addon!
Secondly, I've an error trying to play "TV4", show "Så mycket bättre" episode "Så mycket bättre del 2". The error also occures for other shows.
I've an ATV2 which is at 4.4.2, running latest nightly build (from 29th of October).

I've tried to exctract the log file, hope this is what you look for...

http://dl.dropbox.com/u/29640008/xbmc.log

Thanks for all support!
Could you please post a complete uzg.log or uzgplugin.log and xbmc.log? The combination of the two gives a bit more information.


- Basje - 2011-11-07

Novin Wrote:Why is a seperate repository needed for this plugin/script?

Because of the XOT-Uzg.v3 license I cannot add my addon to the main Repository. But you install the XOT-Uzg.v3 repo once and enable auto updates, you will never have to look at it again.


- Thiele - 2011-11-08

Hi,

today I updated XBMC to the lastest nightly build. Ever since, XOT-UZG isn't working anymore. Both the video and program add-on. I'm running v3.2.11 on ATV2. When starting the add-on, it says loading (retrieved items: 0) and then quits. Any idea how to fix this?


- Basje - 2011-11-08

Thiele Wrote:Hi,

today I updated XBMC to the lastest nightly build. Ever since, XOT-UZG isn't working anymore. Both the video and program add-on. I'm running v3.2.11 on ATV2. When starting the add-on, it says loading (retrieved items: 0) and then quits. Any idea how to fix this?

It's a know issue. See here for a solution http://code.google.com/p/xot-uzg/issues/detail?id=293

A permanent fix will be in the next version.


- Thiele - 2011-11-08

Basje Wrote:It's a know issue. See here for a solution http://code.google.com/p/xot-uzg/issues/detail?id=293

A permanent fix will be in the next version.

Thanks! When will the next version be available? That one also includes a NOS channel, right?


- Basje - 2011-11-08

Thiele Wrote:Thanks! When will the next version be available? That one also includes a NOS channel, right?

Probably this week, no official ETA. The NOS.nl channel will be included in that version.


- thespecialist - 2011-12-01

Hi,

Just found out about this awesome plugin ! One problem though: when I try to seek in a stream, it just hangs or exits the stream. Is seeking supported at all ?

Thanks !


- Basje - 2011-12-01

thespecialist Wrote:Hi,

Just found out about this awesome plugin ! One problem though: when I try to seek in a stream, it just hangs or exits the stream. Is seeking supported at all ?

Thanks !

Seeking is not supported by XBMC for all stream types. I can't really help that.


- thespecialist - 2011-12-02

Basje Wrote:Seeking is not supported by XBMC for all stream types. I can't really help that.

Ok, thanks for the info, saves me a lot of pointless debugging Wink


- Thiele - 2011-12-02

When are you planning to release 3.2.12? Looking forward to the NOS channel! :-)


- Basje - 2011-12-03

Thiele Wrote:When are you planning to release 3.2.12? Looking forward to the NOS channel! :-)

Well, it kinda got delayed by something called Modern Warfare 3 Big Grin. But I will take some time next week to release it. It has been running stable on my systems here for a while now.


- thespecialist - 2011-12-03

Basje Wrote:Seeking is not supported by XBMC for all stream types. I can't really help that.

I was just looking at how uitzendinggemist does the seeking and it's just a parameter in the URL, for example: /%3Ftype%3Dhttp%26start%3D1954&start=1954

Where 1954 means 1954 seconds. Wouldn't it be possible to just pull such different URL when the user seeks ?

*EDIT* I was just looking at your sourcecode, there's some nice stuff in there like that hashing of the episodeId, using the security key's, nice find !


- Basje - 2011-12-05

thespecialist Wrote:I was just looking at how uitzendinggemist does the seeking and it's just a parameter in the URL, for example: /%3Ftype%3Dhttp%26start%3D1954&start=1954

Where 1954 means 1954 seconds. Wouldn't it be possible to just pull such different URL when the user seeks ?

*EDIT* I was just looking at your sourcecode, there's some nice stuff in there like that hashing of the episodeId, using the security key's, nice find !

Well, I don't think I can capture commands in XBMC from an addon. So changing the URL is a bit complicated. However: I could add an option to the context menu that let's you start an episode at a specific time (if the streams support it). Could you add a feature request on the GoogleCode page for this?

The hashing of the episodeId a hard one to crack, but using some reflection tools for Silverlight I managed it.


- lowfi - 2011-12-05

I use Nox aeon skin (eden svn). XOT-UZG does however appears to use its own layout. Is there a way to switch to a layout offered by the skin?

Normally you use the arrows keys to get to the "side menu" where you can switch between layouts (list, big list, banner, icons etc). This however is not working atm.


- Basje - 2011-12-05

lowfi Wrote:I use Nox aeon skin (eden svn). XOT-UZG does however appears to use its own layout. Is there a way to switch to a layout offered by the skin?

Normally you use the arrows keys to get to the "side menu" where you can switch between layouts (list, big list, banner, icons etc). This however is not working atm.

Well, if you run XOT-Uzg.v3 as a program on XBMC, it will have it's own skin and no XBMC default menu's. If somebody creates a skin for it, XOT-Uzg.v3 could use it.

If you run XOT-Uzg.v3 as a plugin on it will act as a default XBMC folder and it should take on the main XBMC script.


This forum uses Lukasz Tkacz MyBB addons.