Kodi Community Forum
Release Retrospect v5.3.2 Video Add-On - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=154)
---- Thread: Release Retrospect v5.3.2 Video Add-On (/showthread.php?tid=25522)



- bartmans - 2012-01-10

Basje Wrote:About the favorites: XOT-Uzg.v3 already has favorites, you can add them via the context menu. The favorites can be access via the contextmenu of the channel (they unique for each channel).
Okay a typical case of RTFM about the favourites then :-)!

I know this is nothing to do with XOT-UZG but I don't find the new uitzendinggemist.nl very practical. Okay, the quality is better but the way to find shows isn't a huge improvement.


- Basje - 2012-01-10

bartmans Wrote:Okay a typical case of RTFM about the favourites then :-)!

I know this is nothing to do with XOT-UZG but I don't find the new uitzendinggemist.nl very practical. Okay, the quality is better but the way to find shows isn't a huge improvement.

I agree, I liked the old way better. If I find a possibility to improve it, I will do so, but for now we are stuck with this one.


- canadave - 2012-01-10

Basje Wrote:I have no idea why it would crash while exiting. Never noticed it myself. Did you try to use it as an Video Add-on instead of Program? If it happens again, I would be interested in a uzg.log (or uzgplugin.log) and another xbmc.log
No, I was using as a Program. I will for sure do that if a crash occurs again, and will post in this thread (unless there's a more appropriate place to post a crash report?). It actually seems fairly unstable from the few times I've tested it last night, so it might not take too long to wait before I get the chance to post something. For instance, I went to the uitzendinggemist.nl channel, selected a "letter", and started paging down looking for shows...and on the right side, where it has the black square boxes with the page numbers, instead of showing pages 1,2,3,4, etc., they were sort of random numbers--like 3,3,3,8,4,1,2. Then, while moving down through the list of shows trying to see one I'd like to watch, it would occasionally just freeze, and I'd have to reboot the ATV2. This occurred several times.

Anyway, I'll do some more testing today, and post logs when something happens. Thanks for responding!

Basje Wrote:Tros is part of the NOS and all it's video's should be available via the uitzendinggemist.nl channel.
Ah, thanks, I didn't realize. Cheers again for that Smile


- canadave - 2012-01-10

lol....well, that didn't take long!

Started XBMC, went right into XOT-UZG. Went to the uitzendinggemist.nl channel and selected letter "C". Right off the bat, the page numbers in the black boxes on the right were out of order. Same for when I went to the letter "N". Then, while in that section, while scrolling down, it froze on "opening request URL" (it got to 85% and stopped), and I had to restart the Apple TV2.

The uzg.log is here:
http://pastebin.com/pa81Sf3E

The xbmc.log is here:
http://pastebin.com/QyiVmwPw

Just scanned the logs quickly and there does appear to be some good info there on what might be going wrong...not a programmer here, unfortunately, so I'll leave it in your more capable hands. Hope this helps! Smile


- Basje - 2012-01-10

canadave Wrote:No, I was using as a Program. I will for sure do that if a crash occurs again, and will post in this thread (unless there's a more appropriate place to post a crash report?). It actually seems fairly unstable from the few times I've tested it last night, so it might not take too long to wait before I get the chance to post something. For instance, I went to the uitzendinggemist.nl channel, selected a "letter", and started paging down looking for shows...and on the right side, where it has the black square boxes with the page numbers, instead of showing pages 1,2,3,4, etc., they were sort of random numbers--like 3,3,3,8,4,1,2. Then, while moving down through the list of shows trying to see one I'd like to watch, it would occasionally just freeze, and I'd have to reboot the ATV2. This occurred several times.

Anyway, I'll do some more testing today, and post logs when something happens. Thanks for responding!

Ah, thanks, I didn't realize. Cheers again for that Smile
There is indeed an issue with pages in the new UZG channel, it will be fixed soon. I myself use IOS and never had any issues about crashes and so.


- canadave - 2012-01-10

Basje Wrote:There is indeed an issue with pages in the new UZG channel, it will be fixed soon. I myself use IOS and never had any issues about crashes and so.
Oh, good! (I mean, not good, but good that it's a known issue) Smile Hopefully the crash report I posted above will be of some use.

Yes, it looks like we're running the exact same platform (I assume you're on Eden Beta). If you ever want me to test anything, I'd be happy to be the guinea pig :p


- Basje - 2012-01-10

canadave Wrote:Oh, good! (I mean, not good, but good that it's a known issue) Smile Hopefully the crash report I posted above will be of some use.

Yes, it looks like we're running the exact same platform (I assume you're on Eden Beta). If you ever want me to test anything, I'd be happy to be the guinea pig :p

The freezing is not crashing, there is an issue with the regular expressions that take too much CPU (My bad). I will fix it tonight.


- canadave - 2012-01-10

Basje Wrote:The freezing is not crashing, there is an issue with the regular expressions that take too much CPU (My bad). I will fix it tonight.

ahhh...I'm glad it was immediately obvious! Smile I'll try to be more precise with my freezing/crashing verbiage in future Wink

cheers, thanks! Will the fix be put in the repo and thus auto-update on my system, or is there some kind of git version that will be updated?


- Basje - 2012-01-10

canadave Wrote:ahhh...I'm glad it was immediately obvious! Smile I'll try to be more precise with my freezing/crashing verbiage in future Wink

cheers, thanks! Will the fix be put in the repo and thus auto-update on my system, or is there some kind of git version that will be updated?

All updates will be applied via the repository (Except from those who run XBMC4Xbox). So no need to do manual work.


- canadave - 2012-01-10

Basje Wrote:All updates will be applied via the repository (Except from those who run XBMC4Xbox). So no need to do manual work.

excellent, thanks very much Smile


- canadave - 2012-01-12

Not trying to be a pain here, just was curious--did this change get posted? I just checked the addon again, and it seems to be the same...I don't see any change in repo after refreshing it, either.

Sorry if my post sounds impatient...normally my approach is "it happens when it happens". It's just that this Dutch couple is coming over tomorrow night to check out the addon, so I was hoping to verify whether or not it's something on my end that I need to do to get the paging issue squared away Smile


- Basje - 2012-01-12

canadave Wrote:Not trying to be a pain here, just was curious--did this change get posted? I just checked the addon again, and it seems to be the same...I don't see any change in repo after refreshing it, either.

Sorry if my post sounds impatient...normally my approach is "it happens when it happens". It's just that this Dutch couple is coming over tomorrow night to check out the addon, so I was hoping to verify whether or not it's something on my end that I need to do to get the paging issue squared away Smile

Updates where posted the day before yesterday. So you should have gotten them. Check the repository to see what updates you have installed? It should be:
  • net.rieter.xot.channel.nos-3.2.12.6
  • net.rieter.xot.channel.mtv-3.2.12.1
  • net.rieter.xot.channel.se-3.2.12.1

I got them myself (other places in the house) via the repository update, and it all works OK (no more hangs) now.


- canadave - 2012-01-12

Basje Wrote:Updates where posted the day before yesterday. So you should have gotten them. Check the repository to see what updates you have installed? It should be:
  • net.rieter.xot.channel.nos-3.2.12.6
  • net.rieter.xot.channel.mtv-3.2.12.1
  • net.rieter.xot.channel.se-3.2.12.1

I got them myself (other places in the house) via the repository update, and it all works OK (no more hangs) now.

My apologies--it seems to be working fine now, after rebooting my ATV2. Not sure what happened there, but all is well Smile Thanks so much, these friends of mine will be thrilled with your work!


- bartmans - 2012-01-13

Basje Wrote:I agree, I liked the old way better. If I find a possibility to improve it, I will do so, but for now we are stuck with this one.
I forgot my good intentions for 2012. Stay positive.

Having a not so practical UZG site is always better than having no UZG sites like Belgium or even worse a 'my country first' site like the UK. Anyone have a proxy for me Laugh ?

Anyways: we appreciate your good work!


- Basje - 2012-01-13

bartmans Wrote:I forgot my good intentions for 2012. Stay positive.

Having a not so practical UZG site is always better than having no UZG sites like Belgium or even worse a 'my country first' site like the UK. Anyone have a proxy for me Laugh ?

Anyways: we appreciate your good work!

Try one of these:
http://www.xroxy.com/proxy-country-GB.htm

One usually works.


This forum uses Lukasz Tkacz MyBB addons.