Kodi Community Forum
Linux Testing - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Game support (https://forum.kodi.tv/forumdisplay.php?fid=292)
--- Thread: Linux Testing (/showthread.php?tid=257904)

Pages: 1 2 3 4 5 6


RE: Linux Testing - lefty420 - 2017-05-17

Thanks guys Smile


RE: Linux Testing - MrTarantula - 2017-05-30

New builds to correspond with garbear's new builds. I mistakenly built on latest, but am now building again on the same commit as garbear's. It'll be up in about an hour or so. I'll leave both builds up for now.

Edit: Due to a scripting problem, the last build's zip file title has the old build's commit id. The build is up-to-date but I'm going to remove it so there's no confusion. New build coming soon.


RE: Linux Testing - garbear - 2017-06-02

Thanks for keeping up with the builds! Do you have a link that I can stick in the test builds thread?


RE: Linux Testing - MrTarantula - 2017-06-02

The same link as the first post: https://goo.gl/jfkG3v. The direct link to the latest build is https://www.dropbox.com/sh/ya0khylaqwe692k/AAD250qfo1RdmG3XBZyd6TGKa/retroplayer-18alpha1-Ubuntu16.04-x86_64-f79c8d7-20170403.tar.gz?dl=1.


RE: Linux Testing - lefty420 - 2017-06-03

Awesome stuff guys thanks working with the latest Leia git


RE: Linux Testing - ninjafuchs - 2018-03-06

since kodi leia alpha1 is out now in the repos.
i really like to try the retroplayer.
but i really have no clue what to do with that retroplayer folder.
is there a manual that explain the steps for noob like me?


RE: Linux Testing - MrTarantula - 2018-03-06

My builds are extremely outdated. My build machine died and I haven't had time to get them up and running again. But if you want to run it you only need to execute the kodi file in /<yourPath>/retroplayer/bin/.


RE: Linux Testing - tutu - 2018-09-29

I have updated my NUC with Kodi Nightly (running Ubuntu 18.04). How do I go about enabling launching of game ROMS using the built in retroplayer? Is there a guide to where to get started? Are there additional packages to install (e.g. cores)

I can see the games section on the left.

I have added a source to Games, which contains various ROMs over the years, but nothing happens when I try to open them.


RE: Linux Testing - Klojum - 2018-09-29

(2018-09-29, 17:03)tutu Wrote: I have updated my NUC with XBMC Nightly
The application has been named 'Kodi' for some time now. Smile


RE: Linux Testing - tutu - 2018-09-29

(2018-09-29, 17:19)Klojum Wrote:
(2018-09-29, 17:03)tutu Wrote: I have updated my NUC with XBMC Nightly
The application has been named 'Kodi' for some time now. Smile 
 Oops yes, as you can see from my profile I've been using Kodi for a long time (but my NUC has been sitting in a box for a while). I used XBMC on the original Xbox.


RE: Linux Testing - MrTarantula - 2018-09-29

The cores currently have to be compiled for your platform. You can try pulling them out of my old builds but they're very outdated and probably wouldn't work. I've been meaning to set up new builds. Stay tuned.


RE: Linux Testing - tutu - 2018-09-29

(2018-09-29, 17:24)MrTarantula Wrote: The cores currently have to be compiled for your platform. You can try pulling them out of my old builds but they're very outdated and probably wouldn't work. I've been meaning to set up new builds. Stay tuned.
 Is there not a ppa for the relevant cores etc.? I was hoping it was going to be as simple as apt install xyz (or a script to build them) with leia and a bit of config Smile Looking forward to new builds.


RE: Linux Testing - MrTarantula - 2018-09-29

No PPA for the cores, AFAIK. I think they're waiting for the binary addon repo, so that updates to the cores are managed within Kodi.


RE: Linux Testing - tutu - 2018-09-29

(2018-09-29, 18:17)MrTarantula Wrote: No PPA for the cores, AFAIK. I think they're waiting for the binary addon repo, so that updates to the cores are managed within Kodi.
OK Thank you. Getting the process now! Any chance you will be upgrading your build machine to 18.04? If not I might look to build my own.

Would compiling the game.* add-ons work with the current nightly?

I'd thought I would give it a go anyway, here is my modified script:
Quote:#!/bin/bash

#ADDONS=game.libretro*
ADDONS=game.*
BRANCH=retroplayer-18beta2-20180914
WORKSPACE=/home/kodi/repos/kodibuild

#sudo rm -rfv $WORKSPACE
# uncomment if you want to remove automatically
#rm -rfv $WORKSPACE
git clone -b $BRANCH https://github.com/garbear/xbmc $WORKSPACE

mkdir $WORKSPACE/build-addons
cd $WORKSPACE/build-addons
cmake -DADDONS_TO_BUILD=$ADDONS \
      -DCMAKE_BUILD_TYPE=Debug \
      -DCMAKE_INSTALL_PREFIX=$WORKSPACE/addons \
      -DPACKAGE_ZIP=1 \
      $WORKSPACE/cmake/addons
make -j2

Unfortunately, make fails when compiling uae4arm (not sure why.. as I'm using amd64)
Quote:src/audio.cpp: In function ‘void audio_reset()’:
src/audio.cpp:944:28: warning: overflow in implicit constant conversion [-Woverflow]
      cdp->per = PERIOD_MAX - 1;
./src/md-retro/maccess.h: Assembler messages:
./src/md-retro/maccess.h:23: Error: no such instruction: `ldrh %ax,[%rax]'
./src/md-retro/maccess.h:24: Error: no such instruction: `rev16 %ax,%ax'
Makefile:194: recipe for target 'src/audio.o' failed
make[6]: *** [src/audio.o] Error 1
CMakeFiles/uae4arm.dir/build.make:110: recipe for target 'uae4arm/src/uae4arm-stamp/uae4arm-build' failed
make[5]: *** [uae4arm/src/uae4arm-stamp/uae4arm-build] Error 2
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/uae4arm.dir/all' failed
make[4]: *** [CMakeFiles/uae4arm.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make[3]: *** [all] Error 2
CMakeFiles/uae4arm.dir/build.make:110: recipe for target 'build/uae4arm/src/uae4arm-stamp/uae4arm-build' failed
make[2]: *** [build/uae4arm/src/uae4arm-stamp/uae4arm-build] Error 2
CMakeFiles/Makefile2:687: recipe for target 'CMakeFiles/uae4arm.dir/all' failed
make[1]: *** [CMakeFiles/uae4arm.dir/all] Error 2
Makefile:83: recipe for target 'all' failed
make: *** [all] Error 2



RE: Linux Testing - MrTarantula - 2018-09-29

Not sure why you're getting that error. I've got my build going right now (on 18.04 x64). Just a warning if you want to build it yourself, MAME cores take forever.


This forum uses Lukasz Tkacz MyBB addons.