Kodi Community Forum
Missing sound after pause/resume - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: OS independent / Other (https://forum.kodi.tv/forumdisplay.php?fid=228)
---- Thread: Missing sound after pause/resume (/showthread.php?tid=264489)



Missing sound after pause/resume - Infidelus - 2016-03-15

Hi,

I've been a MediaPortal user for a number of years, but a few months ago decided I wanted to go for a more cross-platform approach (buying a Raspberry Pi helped), so I opted for Kodi.

I do have one seemingly Kodi specific issue though which seems prevalent no matter what OS I've tried (OpenElec, Ubuntu, Windows).

If I'm watching a recorded program and pause the program (to make a cuppa, go to loo ... etc), when I resume play, there's a very small but noticeable silence. So if I've managed to pause during a conversation, when I resume play I miss a word or two which I find highly irritating and have to skip back to catch the missing word(s). As mentioned, it's not platform specific. It happens on all the Operating Systems mentioned above and on all hardware I've tried (Raspberry Pi 2, Intel Nuc and my main gaming PC). I've also tried various versions of Kodi (Isengard, Jarvis and the latest Krypton early access version) to see if it's been fixed, which unfortunately it hasn't. It's also not specific to audio output. Most of my connections are HDMI, but the gaming PC uses a normal 3.5 mm jack to the speakers and a DVI connection.

I've messed around with Audio settings as well to see if that has any effect, but no matter what I try, there's this extremely consistent audio dropout. It also doesn't just affect me. A friend also uses Kodi and says the exact same happens to him, which is why I'm surprised I can't find anything searching the forum (or my search terms just aren't right).

If anyone has any ideas, or can point me to a solution I've missed, I'd appreciate it.


RE: Missing sound after pause/resume - Atreyu - 2016-03-15

Maybe this addon can do something for you?

http://kodi.wiki/view/Add-on:XBMC_Unpause_Jumpback


RE: Missing sound after pause/resume - Infidelus - 2016-03-15

Thanks. I guess from your reply that this is a known 'feature'?


RE: Missing sound after pause/resume - wsnipex - 2016-03-15

you can try enabling "keep audio device alive" in audio settings.


RE: Missing sound after pause/resume - candyman2000 - 2016-03-15

(2016-03-15, 21:05)Infidelus Wrote: Thanks. I guess from your reply that this is a known 'feature'?

Not quite a feature but a known issue I think was introduced in 15.x Last version I used which worked fine was 14.2.

Check out this thread for more info: http://forum.kodi.tv/showthread.php?tid=236437&pid=2282598#pid2282598


RE: Missing sound after pause/resume - Atreyu - 2016-03-15

(2016-03-15, 21:05)Infidelus Wrote: Thanks. I guess from your reply that this is a known 'feature'?
Well, imo not so much a feature or an issue.
In fact, wsnipex's suggestion might fix it for you.
Just remembered that i upped the keepalive value to delay sound cut-outs.
Still the unpausejumpback addon is recommendable :-)

/edit i just read the thread @Candyman posted. Turns out to be a known issue indeed..


RE: Missing sound after pause/resume - Infidelus - 2016-03-18

(2016-03-15, 22:38)wsnipex Wrote: you can try enabling "keep audio device alive" in audio settings.

Thanks, I'd aready tried that though with no change.

(2016-03-15, 23:21)candyman2000 Wrote:
(2016-03-15, 21:05)Infidelus Wrote: Thanks. I guess from your reply that this is a known 'feature'?

Not quite a feature but a known issue I think was introduced in 15.x Last version I used which worked fine was 14.2.

Check out this thread for more info: http://forum.kodi.tv/showthread.php?tid=236437&pid=2282598#pid2282598

Thanks for the link. Guess I'll work around it with Unpause Jumpback until the issue's properly fixed then. Smile


This forum uses Lukasz Tkacz MyBB addons.