Kodi Community Forum
Beta Spotify for Kodi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Beta Spotify for Kodi (/showthread.php?tid=265356)



RE: Spotify for Kodi - marcelveldt - 2016-05-20

(2016-05-20, 08:41)newsbeast Wrote: The skin is nice on the eye as I have said prior but it does run slow on android -- takes about 15 or 20 seconds to load a page or section such as settings or addons no matter what is added on, or not.

I like the interface well enough to tolerate its short comings, but that my setup got totally borked by one of your own beta addons ain't really fun.

To solve the slow loading of sections on lower powered platforms please disable views you don't use in the skin settings, forced views, enable/disable views. By default all views are enabled which takes time to load.

Very strange that your skinsetup got messed up by installing the beta repo. That shouldn't happen at all.
Would it be possible for you to grab your kodi logfile for me ?


RE: Spotify for Kodi - newsbeast - 2016-05-20

(2016-05-20, 14:09)marcelveldt Wrote: To solve the slow loading of sections on lower powered platforms please disable views you don't use in the skin settings, forced views, enable/disable views. By default all views are enabled which takes time to load.

Very strange that your skinsetup got messed up by installing the beta repo. That shouldn't happen at all.
Would it be possible for you to grab your kodi logfile for me ?

My kodi setup was stock -- no forced views and not more that 10 video addons. Some local music a few local films, a weather script and artwork downloader that runs at startup. Always let these run first before using kodi as well.

Unfortunately I restarted kodi before looking for the log, and because of the state of kodi could not access any features at all.

Lesson learned

There appears to be an update to the skin helper in the beta repo or a cause to update to a newer shin helper script. I just might try the beta spotify repo again for fun to see if it trashes the setup another time....

As for logging: is that usually in the events tab, or can I fetch it from the file manager as well?

Thanks

The Beast


RE: Spotify for Kodi - marcelveldt - 2016-05-20

(2016-05-20, 15:06)newsbeast Wrote: My kodi setup was stock -- no forced views and not more that 10 video addons. Some local music a few local films, a weather script and artwork downloader that runs at startup. Always let these run first before using kodi as well.
I mean with that, in order to speed up the skin loading time you can disable some views you don't use. There is an option for that at the top of the "forced views" skin settings page.
Just disable the views you never use and you'll notice a big speed improvement on lower powered setups.

(2016-05-20, 15:06)newsbeast Wrote: There appears to be an update to the skin helper in the beta repo or a cause to update to a newer shin helper script. I just might try the beta spotify repo again for fun to see if it trashes the setup another time....
Yes, but beta skinhelper is always backwards compatible with the stable skin version so I'm not sure what happened to your setup.

(2016-05-20, 15:06)newsbeast Wrote: As for logging: is that usually in the events tab, or can I fetch it from the file manager as well?
Best is to just grab the kodi.log file from the file system and put it on some logsharing website like xbmclogs or pastebin.
If the issue returns when you try it again, please let me know, I'm very curious what happened.


RE: Spotify for Kodi - newsbeast - 2016-05-20

Well I reinstalled the repo and the app. Took forever this time to update the skin helper service but it completed without any errors, on screen or in the log. //peculiar all the same// Then I went through the sign-in ritual via the web to link the plugin to my account. Then a new wrinkle appeared:

Login error: Platform not supported for playback Support. Continuing without playback support.

So the tunes play but start somewhere in the middle and jump around like a squirrel from tune to tune on any given album.

So I don't think I'm ready for that. Think you'll get playback controls/support working on Android anytime soon, or have I missed something in the install?

Spotify is a nice thing to have -- especially a premium account. Tons of great music -- but not being able to control the entry point to a given song -- i.e. the songs beginning -- is kinda like turning on the radio and taking what you get.

Still love the skins good looks


RE: Spotify for Kodi - RoloK - 2016-05-20

(2016-05-18, 22:53)RoloK Wrote:
(2016-05-17, 23:49)marcelveldt Wrote:
(2016-05-12, 13:25)RoloK Wrote: I see wich artist it is if ilook into the "media info", but there is no Artist names in the "list"

Got it, I've now appended the artistname to the Multi-artist results.
New version is coming up

Thank you for a great job.
The "artist - song" in lists works great in the new version.

Hi again

The "artist - song" in lists works almost great in the new version.
It's still missing in Explore --> New releases


RE: Spotify for Kodi - FrankP - 2016-05-21

The nrw spotify addon does not work on openelec and osmc on pi2.
Does anybody know if openelec or osmc will support a webbrowser in the future.
Or are there other ways to make it work?


RE: Spotify for Kodi - Jönke - 2016-05-21

Read page one for workaround


RE: Spotify for Kodi - FrankP - 2016-05-21

Thanks. That worksSmile


RE: Spotify for Kodi - kb0n - 2016-05-22

(2016-05-17, 23:53)marcelveldt Wrote:
(2016-05-14, 10:58)Capone2381 Wrote: I am running OSMC on a Raspberry Pi 2 and have used the workaround. Everything appears to be working fine other than the fact that the tracks only play for 30 seconds. Does anybody have a fix for this? Thanks for your work on the add-on.

Strange, the raspberry pi should work fine. Was tested by multiple people now, except for the OSMC. I believe others are using openelec or libreelec. Possible to save your kodi log after you have started the addon ?
Had the same problem and spent quite some time debugging. Turns out OSMC uses hard float support, evident by the existence of '/usr/lib/arm-linux-gnueabihf'.
Since libspotify doesn't provide downloads for armv7hf (https://developer.spotify.com/technologies/libspotify/#libspotify-downloads), you should be fine copying the .so files:
Code:
from: your_kodi_folder/addons/plugin.audio.spotify/resources/dlls/linux/armv6hf
to  : your_kodi_folder/addons/plugin.audio.spotify/resources/dlls/linux/armv7
I used the files from the libspotify download page and it works fine, but I assume the ones from the plugin are the same and should work as well.

Of course it would be desirable if this was automatically detected and handled by the plugin in the upcoming versions Smile


RE: Spotify for Kodi - Jönke - 2016-05-23

(2016-04-04, 22:35)marcelveldt Wrote:
(2016-04-02, 13:53)Jönke Wrote: This is what i get in log when try to open playlist
http://pastebin.com/DWBR6LuY

Still some problems with ÅÄÖ letters ? When acess playlist i get a new folder named "j%c3%b6nke-user" and not jönke-user

Version 1.0.9 is now uploading to the repo. That should fix the unicode issue

Playlist is broken again for me. 1.0.14

http://pastebin.com/G69x4rmK
Album, songs, artist works!


RE: Spotify for Kodi - marcelveldt - 2016-05-24

(2016-05-22, 22:04)kb0n Wrote: I used the files from the libspotify download page and it works fine, but I assume the ones from the plugin are the same and should work as well.
Of course it would be desirable if this was automatically detected and handled by the plugin in the upcoming versions Smile

Thanks for figuring this out. I will include the fix in next version!


RE: Spotify for Kodi - Raejans - 2016-05-25

Hi Marcel, great addon...best Spotify addon yet! But, like some other members are experiencing, the addon crashes randomly.
I have an Android Minix Neo 8H ARM Cortex A9 based mediahub icw Kodi 16.1, Skin is Aeon Nox Silvo mod and I use the latest version 1.0.14 of your addon.
It seems to me, it crashes since the last update. 1.0.13 was working perfectly (for me that is...)

Since more members are experiencing the same as me on different devices, skins or other things, my guess is the changes which were made to version 1.0.14 were not suitable for some platforms.

I hope you can look into it. I'm just a noob, don't even know how to upload a log Confused but I can only backup the comments previously mentioned.

Thanks,

Raejans


RE: Spotify for Kodi - Raejans - 2016-05-25

hmz...now it crashes constantly, I can't even get to my playlists anymore ....upgraded to 1.0.15 just yet, no improvement there Sad

** degraded to 1.0.13 - still crashing but less often, can get to play a song or two **


RE: Spotify for Kodi - marcelveldt - 2016-05-25

(2016-05-25, 10:57)Raejans Wrote: Hi Marcel, great addon...best Spotify addon yet! But, like some other members are experiencing, the addon crashes randomly.
I have an Android Minix Neo 8H ARM Cortex A9 based mediahub icw Kodi 16.1, Skin is Aeon Nox Silvo mod and I use the latest version 1.0.14 of your addon.
It seems to me, it crashes since the last update. 1.0.13 was working perfectly (for me that is...)

Since more members are experiencing the same as me on different devices, skins or other things, my guess is the changes which were made to version 1.0.14 were not suitable for some platforms.

I do not know of other users experiencing crashing ?
Anyway, if it's crashing we need to track down the cause. Please provide me your Kodi logfile after a crash occured.
Please share it with a log sharing site like pastebin, xbmclogs or dropbox instead of pasting it in the forum post.
Thanks !


RE: Spotify for Kodi - Raejans - 2016-05-25

(2016-05-25, 12:45)marcelveldt Wrote:
(2016-05-25, 10:57)Raejans Wrote: Hi Marcel, great addon...best Spotify addon yet! But, like some other members are experiencing, the addon crashes randomly.
I have an Android Minix Neo 8H ARM Cortex A9 based mediahub icw Kodi 16.1, Skin is Aeon Nox Silvo mod and I use the latest version 1.0.14 of your addon.
It seems to me, it crashes since the last update. 1.0.13 was working perfectly (for me that is...)

Since more members are experiencing the same as me on different devices, skins or other things, my guess is the changes which were made to version 1.0.14 were not suitable for some platforms.

I do not know of other users experiencing crashing ?
Anyway, if it's crashing we need to track down the cause. Please provide me your Kodi logfile after a crash occured.
Please share it with a log sharing site like pastebin, xbmclogs or dropbox instead of pasting it in the forum post.
Thanks !

http://goo.gl/wX44RQ

Hope it helps! Thx in advance.