Kodi Community Forum
Beta Spotify for Kodi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Beta Spotify for Kodi (/showthread.php?tid=265356)



Spotify for Kodi - Blarre72 - 2017-06-02

(null)
Ok, sorry. It's a pre-installed package and I haven't really bothered about them. I will do a clean up since I'm really only interested in using my Netflix, Spotify and Swedish play channels. Sorry about that. The Spotify errors still apply though.


RE: Spotify for Kodi - marcelveldt - 2017-06-02

(2017-06-02, 20:00)Raitsa Wrote: 1.1.5 installed on 2 Intel NUCĀ“s now, both working very very nicely.

The other is using Krypton (LibreELEC-Generic.x86_64-8.0-Milhouse-20161129210859-#1129-ga26112d)
and the other the very latest Leia one from today (LibreELEC-Generic.x86_64-9.0-Milhouse-20170601210326-%230601-gc6a4377).

marcelveldt, amazing work, thank you again.

OK, great to hear it's working !
Just added another update on the repo which allows for muliple user accounts btw


RE: Spotify for Kodi - Karellen - 2017-06-02

No problems.

As you have installed a "Build" you no longer have the original Kodi installed as downloaded from this site. It is a modified version which we do not support, so no action/interest will be taken as we are not responsible for the mess created by others.

If you can replicate the problem on a clean and original Kodi install, more interest will be shown.

Thanks Smile


Spotify for Kodi - Blarre72 - 2017-06-02

Ok, sorry for that. I will remove it and try a clean install with this plugin tomorrow then. I'll post my results and log later.


RE: Spotify for Kodi - jurialmunkey - 2017-06-03

@marcelveldt
Still getting access token errors after a certain amount of time passed with 1.1.7 version from your beta repo.
Running Kodi 17.3 on LE8 (the "Extended" version by escalade that has RetroArch and Chrome included)

Hadn't even been playing anything, just left the machine idling for a few hours (runs as a samba server) and came back to it and had the access token errors
Log:
https://pastebin.com/igLh5UE7

Also, is there some way to restart the spotify plugin or reauthorise the access token without needing to restart kodi?


RE: Spotify for Kodi - marcelveldt - 2017-06-03

(2017-06-03, 08:51)jurialmunkey Wrote: @marcelveldt
Still getting access token errors after a certain amount of time passed with 1.1.7 version from your beta repo.
Running Kodi 17.3 on LE8 (the "Extended" version by escalade that has RetroArch and Chrome included)

Hadn't even been playing anything, just left the machine idling for a few hours (runs as a samba server) and came back to it and had the access token errors
Log:
https://pastebin.com/igLh5UE7

Also, is there some way to restart the spotify plugin or reauthorise the access token without needing to restart kodi?

The backgroundservice takes care of auto refreshing the token when needed.
This isn't done in the plugin entry as that will slow down the plugin and it will cause unneeded calls to the api.
Looking at your log I see a strange thing happening: Look around line 151
The service is stopped there and never started again so no token refreshes.

Maybe this was some leftover from the previous version.
Can you restart your machine and leave it running for a while ? It should print "Authentication token updated" around every hour.


RE: Spotify for Kodi - jocus - 2017-06-03

Spotify doesn't work anymore on my Rapsberry Pi 3 with Libreelec 8.0.2. I get a window with my login credentials. After clicking the OK button nothing happens. I can see this in my logfile:

09:00:49.687 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:34.739 T:1343054752 NOTICE: Previous line repeats 89 times.
09:01:34.739 T:1343054752 NOTICE: plugin.audio.spotify --> Audio proxy - stop called
09:01:34.741 T:1313084320 ERROR: Traceback (most recent call last):
09:01:34.741 T:1313084320 ERROR: File "/usr/lib/python2.7/SocketServer.py", line 290, in _handle_request_noblock
09:01:34.741 T:1313084320 ERROR: File "/usr/lib/python2.7/SocketServer.py", line 605, in process_request
09:01:34.741 T:1313084320 ERROR: File "/usr/lib/python2.7/threading.py", line 678, in __init__
09:01:34.741 T:1313084320 ERROR: File "/usr/lib/python2.7/threading.py", line 702, in _set_daemon
09:01:34.741 T:1313084320 ERROR: File "/usr/lib/python2.7/threading.py", line 1150, in currentThread
09:01:34.741 T:1313084320 ERROR: SystemExit
09:01:34.743 T:1343054752 WARNING: plugin.audio.spotify --> Exception in webservice ! --> ''
09:01:34.743 T:1343054752 NOTICE: plugin.audio.spotify --> Audio proxy - stopped
09:01:35.691 T:1478001568 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:36.744 T:1343054752 NOTICE: Previous line repeats 1 times.
09:01:36.744 T:1343054752 NOTICE: plugin.audio.spotify --> waiting for credentials...
09:01:37.694 T:1478001568 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:41.746 T:1351443360 NOTICE: Previous line repeats 4 times.
09:01:41.747 T:1351443360 NOTICE: plugin.audio.spotify --> start audio proxy on port 52308
09:01:41.748 T:1351443360 WARNING: plugin.audio.spotify --> Exception in webservice.run ! --> [Errno 98] Address already in use
09:01:42.700 T:1478001568 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:44.748 T:1343054752 NOTICE: Previous line repeats 2 times.
09:01:44.748 T:1343054752 NOTICE: plugin.audio.spotify --> Launching system-default browser
09:01:44.749 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:53.711 T:1478001568 NOTICE: Previous line repeats 16 times.
09:01:53.711 T:1478001568 NOTICE: plugin.audio.spotify --> Audio proxy - stop called
09:01:53.758 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:53.787 T:1478001568 NOTICE: plugin.audio.spotify --> Audio proxy - stopped
09:01:54.761 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:01:55.787 T:1478001568 NOTICE: Previous line repeats 1 times.
09:01:55.788 T:1478001568 NOTICE: plugin.audio.spotify --> waiting for credentials...
09:01:56.765 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:02:00.792 T:1351443360 NOTICE: Previous line repeats 4 times.
09:02:00.792 T:1351443360 NOTICE: plugin.audio.spotify --> start audio proxy on port 52308
09:02:00.794 T:1351443360 WARNING: plugin.audio.spotify --> Exception in webservice.run ! --> [Errno 98] Address already in use
09:02:01.772 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:02:03.794 T:1478001568 NOTICE: Previous line repeats 2 times.
09:02:03.794 T:1478001568 NOTICE: plugin.audio.spotify --> Launching system-default browser
09:02:03.794 T:1478001568 NOTICE: plugin.audio.spotify --> Waiting for authentication token...
09:02:09.092 T:1961693648 NOTICE: Previous line repeats 10 times.
09:02:09.093 T:1961693648 NOTICE: NFS is idle. Closing the remaining connections.
09:02:09.781 T:1343054752 NOTICE: plugin.audio.spotify --> Waiting for authentication token...


RE: Spotify for Kodi - agasi48 - 2017-06-03

(2017-06-03, 09:09)jocus Wrote: Spotify doesn't work anymore on my Rapsberry Pi 3 with Libreelec 8.0.2. I get a window with my login credentials. After clicking the OK button nothing happens. I can see this in my logfile:

Same for me with rpi3 and libreelec 8.0.2 ...


RE: Spotify for Kodi - marcelveldt - 2017-06-03

(2017-06-03, 09:09)jocus Wrote: Spotify doesn't work anymore on my Rapsberry Pi 3 with Libreelec 8.0.2. I get a window with my login credentials. After clicking the OK button nothing happens. I can see this in my logfile:

Please restart your pi and try again. Please let me know if that works.


RE: Spotify for Kodi - jurialmunkey - 2017-06-03

(2017-06-03, 09:07)marcelveldt Wrote: Looking at your log I see a strange thing happening: Look around line 151
The service is stopped there and never started again so no token refreshes.
Maybe this was some leftover from the previous version.
Can you restart your machine and leave it running for a while ? It should print "Authentication token updated" around every hour.
I noticed this also. Will restart and leave it running for a while and report back.

Also, I've noticed another unrelated issue: When browsing, if I enter into one album but press back whilst DialogBusy is showing and then go into another album I can no longer play anything and get a "one or more items failed to play" error.
Relevant log:
https://pastebin.com/BNJzdhLm


RE: Spotify for Kodi - jocus - 2017-06-03

(2017-06-03, 09:48)marcelveldt Wrote:
(2017-06-03, 09:09)jocus Wrote: Spotify doesn't work anymore on my Rapsberry Pi 3 with Libreelec 8.0.2. I get a window with my login credentials. After clicking the OK button nothing happens. I can see this in my logfile:

Please restart your pi and try again. Please let me know if that works.

I did this, but still not working. I also noticed this line in the logfile:
10:04:27.886 T:1829761952 NOTICE: plugin.audio.spotify --> Failed to detect architecture or platform not supported !


RE: Spotify for Kodi - marcelveldt - 2017-06-03

(2017-06-03, 09:52)jurialmunkey Wrote: Also, I've noticed another unrelated issue: When browsing, if I enter into one album but press back whilst DialogBusy is showing and then go into another album I can no longer play anything and get a "one or more items failed to play" error.
Relevant log:
https://pastebin.com/BNJzdhLm

I just found out that whenever an error occurs in the pluginentry, Kodi will tell the service to stop.
Once the service is stopped, playback and token refreshes will no longer work.
I will fix that and provide a new version withn a few minutes.


RE: Spotify for Kodi - marcelveldt - 2017-06-03

(2017-06-03, 10:09)jocus Wrote: I did this, but still not working. I also noticed this line in the logfile:
10:04:27.886 T:1829761952 NOTICE: plugin.audio.spotify --> Failed to detect architecture or platform not supported !

OK, thanks. That was the missing piece in the puzzle. I will review my architecture detection code...

EDIT: Found a typo in the code. Version 1.1.9 should be available on the repo within a few minutes, please have a test with that.


RE: Spotify for Kodi - jocus - 2017-06-03

(2017-06-03, 10:10)marcelveldt Wrote: OK, thanks. That was the missing piece in the puzzle. I will review my architecture detection code...

EDIT: Found a typo in the code. Version 1.1.9 should be available on the repo within a few minutes, please have a test with that.

Update 1.1.9 is still not available. I'm currently running 1.1.8.


RE: Spotify for Kodi - Blarre72 - 2017-06-03

Ok, I'm back with a clean install on my Android box with Kodi Jarvis and most current version pf the Spotify plugin. I still get errors in th log when starting and browsing my Spotify library.

First of all there seems to be some issues with the lists. I have to enter everything twice (back and forth) to get any content and when I finally get down to my songs I can see them but not play them.

This is from my log:

12:08:55 T:1884591112 NOTICE: plugin.audio.spotify --> Shutdown requested !
12:08:55 T:1884591112 NOTICE: plugin.audio.spotify --> Audio proxy - stop called
12:08:56 T:1884591112 NOTICE: plugin.audio.spotify --> Audio proxy - stopped
12:08:56 T:1884591112 NOTICE: plugin.audio.spotify --> stopped

Error Type: <type 'exceptions.TypeError'>
Error Contents: an integer is required
Traceback (most recent call last):
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.audio.spotify/service.py", line 13, in <module>
MainService()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.audio.spotify/resources/lib/main_service.py", line 42, in __init__
self.spotty = Spotty()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.audio.spotify/resources/lib/utils.py", line 348, in __init__
self.__spotty_binary = self.get_spotty_binary()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.audio.spotify/resources/lib/utils.py", line 409, in get_spotty_binary
log_msg(__name__, exc)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.audio.spotify/resources/lib/utils.py", line 77, in log_msg
xbmc.log("%s --> %s" % (ADDON_ID, msg), level=loglevel)
TypeError: an integer is required

12:10:36 T:1987383736 WARNING: plugin.audio.spotify --> Exception in plugin_content ! --> 'NoneType' object is unsubscriptable
12:11:51 T:1989436608 WARNING: Previous line repeats 1 times.
12:11:51 T:1989436608 WARNING: Attempt to use invalid handle -1
12:17:32 T:1975756336 WARNING: Previous line repeats 2 times.
12:17:32 T:1975756336 WARNING: plugin.audio.spotify --> Exception in plugin_content ! --> 'NoneType' object is unsubscriptable
12:17:47 T:1789806680 ERROR: Control 61 in window 10147 has been asked to focus, but it can't
12:17:48 T:1975501280 WARNING: Attempt to use invalid handle -1
12:19:10 T:1974168648 WARNING: Previous line repeats 2 times.