Kodi Community Forum
Beta Spotify for Kodi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Beta Spotify for Kodi (/showthread.php?tid=265356)



RE: Spotify for Kodi - marcelveldt - 2017-06-06

(2017-06-06, 09:44)xbmosx Wrote: Did some more testing today (Ubuntu 16.0.4, Kodi NUC). With local playback everything seems to be working. I cannot get connect client mode to work though. After a Kodi fresh start I can see the Spotify client advertising on the network. But the spotty-x84_64-musl process crashes or stops very soon afterwards (vanishes from the system monitor processes list without an error notification). I also tried to restart spotty manually from outside of Kodi, but that didn't work either.

Please test with 1.1.16... This was already discussed here in the posts.


RE: Spotify for Kodi - borgybz - 2017-06-06

Hi marcel! I can't find any .16 version on your repo. Did you find a solution about the impossibility to play any song? Did you watch the log you asked me to post?
For me is still not working/not playing anything


RE: Spotify for Kodi - mazeeff - 2017-06-06

I can confirm that 1.1.16 fixes the issue that I reported in post#885, regarding songs freezing 3 seconds from end of song. Thanks for the great work!


RE: Spotify for Kodi - borgybz - 2017-06-06

(2017-06-06, 11:12)mazeeff Wrote: I can confirm that 1.1.16 fixes the issue that I reported in post#885, regarding songs freezing 3 seconds from end of song. Thanks for the great work!

Where did you download it? I can't see any .16 version on official repo...

EDIT: my kodi was completely gone crazy! Resetted kodi deleting manually all the kodi folder and now with .16 version seems to work and regular play songs
EDIT2: now not working anymore again, with same error. Mystery


RE: Spotify for Kodi - mazeeff - 2017-06-06

(2017-06-06, 11:24)borgybz Wrote:
(2017-06-06, 11:12)mazeeff Wrote: I can confirm that 1.1.16 fixes the issue that I reported in post#885, regarding songs freezing 3 seconds from end of song. Thanks for the great work!

Where did you download it? I can't see any .16 version on official repo...

https://github.com/marcelveldt/repository.marcelveldt/tree/master/plugin.audio.spotify


RE: Spotify for Kodi - DarkHelmet - 2017-06-06

(2017-06-06, 09:21)marcelveldt Wrote:
(2017-06-05, 16:54)DarkHelmet Wrote: Using 1.1.15 with Kodi 17.3 on windows 10. I cannot play any tracks anymore. When I try Kodi freezes and after a while i get a message that "one or more items could not be played".

Can you confirm it's fixed with 1.1.16 ?

Yes, it's fixed. Thank you very much.


RE: Spotify for Kodi - marcelveldt - 2017-06-06

(2017-06-06, 11:43)mazeeff Wrote:
(2017-06-06, 11:24)borgybz Wrote:
(2017-06-06, 11:12)mazeeff Wrote: I can confirm that 1.1.16 fixes the issue that I reported in post#885, regarding songs freezing 3 seconds from end of song. Thanks for the great work!

Where did you download it? I can't see any .16 version on official repo...

https://github.com/marcelveldt/repository.marcelveldt/tree/master/plugin.audio.spotify

Please install the repository and not link to the file directly, otherwise you will end up with dependency mismatches!


RE: Spotify for Kodi - borgybz - 2017-06-06

(2017-06-06, 12:17)marcelveldt Wrote:
(2017-06-06, 11:43)mazeeff Wrote:
(2017-06-06, 11:24)borgybz Wrote: Where did you download it? I can't see any .16 version on official repo...

https://github.com/marcelveldt/repository.marcelveldt/tree/master/plugin.audio.spotify

Please install the repository and not link to the file directly, otherwise you will end up with dependency mismatches!

I was able to install it. Now when trying to play a song whole kodi freezes


RE: Spotify for Kodi - marcelveldt - 2017-06-06

(2017-06-06, 12:36)borgybz Wrote: I was able to install it. Now when trying to play a song whole kodi freezes

I have no clue what's going on with your machine. It's working fine at multiple of my machines.
Make sure that you have installed version 1.1.16 through my repo and just to be safe restart your computer afterwards.
If the playback is still failing after that, I need a Kodi debug log captured after you tried the playback.

Can you browse the menus of the addon successfully ?


RE: Spotify for Kodi - borgybz - 2017-06-06

(2017-06-06, 12:58)marcelveldt Wrote:
(2017-06-06, 12:36)borgybz Wrote: I was able to install it. Now when trying to play a song whole kodi freezes

I have no clue what's going on with your machine. It's working fine at multiple of my machines.
Make sure that you have installed version 1.1.16 through my repo and just to be safe restart your computer afterwards.
If the playback is still failing after that, I need a Kodi debug log captured after you tried the playback.

Can you browse the menus of the addon successfully ?

As you asked me I already posted the log in previous page. Now trying several times I realized that sometimes the playback starts, but the streaming is very bad and slow and playback keeps stopping and I hear cracking sounds! I believe to think that the problem is about the port used by this type of connection. Can you explain me what type of connection does the addon use to connect to Spotify servers? Maybe could be blocked by my isp? I connect through a Vodafone Wi-Fi hotspot with captive portal login... ( I made a script to auto connect that runs every five minutes..)


RE: Spotify for Kodi - marcelveldt - 2017-06-06

(2017-06-06, 13:09)borgybz Wrote: As you asked me I already posted the log in previous page. Now trying several times I realized that sometimes the playback starts, but the streaming is very bad and slow and playback keeps stopping and I hear cracking sounds! I believe to think that the problem is about the port used by this type of connection. Can you explain me what type of connection does the addon use to connect to Spotify servers? Maybe could be blocked by my isp? I connect through a Vodafone Wi-Fi hotspot with captive portal login... ( I made a script to auto connect that runs every five minutes..)

Well, there's the answer... At this time I did not implement any cache or buffer of any kind. The audio is just streamed directly in PCM format from libreelec, which receives the stream in realtime as ogg vorbis from Spotify's servers. So, on slow or bad internet connections this will not perform well.

The previous version had caching to disk enabled by default This will solve the issue you describe but this is a drama for users running the addon on a pi because it will wear out the SD card. For that reason, and because I made the assumption that nowadays everyone has a very fast connection, I disabled the whole caching part.

What I will do is implement a toggle option in the addon settings to enable caching to disk.
Once that's done, I will give you a headsup to test again. Hopefully later today already as it shouldn't be too much work.


RE: Spotify for Kodi - borgybz - 2017-06-06

(2017-06-06, 14:23)marcelveldt Wrote:
(2017-06-06, 13:09)borgybz Wrote: As you asked me I already posted the log in previous page. Now trying several times I realized that sometimes the playback starts, but the streaming is very bad and slow and playback keeps stopping and I hear cracking sounds! I believe to think that the problem is about the port used by this type of connection. Can you explain me what type of connection does the addon use to connect to Spotify servers? Maybe could be blocked by my isp? I connect through a Vodafone Wi-Fi hotspot with captive portal login... ( I made a script to auto connect that runs every five minutes..)

Well, there's the answer... At this time I did not implement any cache or buffer of any kind. The audio is just streamed directly in PCM format from libreelec, which receives the stream in realtime as ogg vorbis from Spotify's servers. So, on slow or bad internet connections this will not perform well.

The previous version had caching to disk enabled by default This will solve the issue you describe but this is a drama for users running the addon on a pi because it will wear out the SD card. For that reason, and because I made the assumption that nowadays everyone has a very fast connection, I disabled the whole caching part.

What I will do is implement a toggle option in the addon settings to enable caching to disk.
Once that's done, I will give you a headsup to test again. Hopefully later today already as it shouldn't be too much work.

Thank you very much. This could be a good test to do, I'm only concerned because when I do a speed test my connection isn't slow at all. With ookla speedtest I have a 20 Mbit download speed. Playing through the same wifi from phone I have no lag/ problem at all and I use the max quality from phone too.


RE: Spotify for Kodi - sswilson - 2017-06-06

(2017-06-06, 04:18)marcelveldt Wrote:
(2017-06-06, 00:46)sswilson Wrote: Ok, went through a fairly thorough shutdown/restart.......

Start kodi/uninstall 1.0.25/shut down kodi/restart PC/delete app data (more on this later)/restart PC/open kodi/install 1.1.15/cleared userinfo to default/shut down kodi/reboot PC/open kodi/verify login info still nil/enter login info/shut down kodi/reboot PC/Start Kodi (got the "default browser" message along with an open browser for authentification/ open plugin/playback freezes/close kodi/reboot PC/open kodi/open plugin/playback still freezes kodi/reverted back to 1.0.25/playback works

The only thing that's puzzling me is that the default login info populated after I'd deleted the app data folder I could find which suggests I'm not getting all of it. Where would I look for the app data or is there a folder name I can search for?

edit: Now I'm not even seeing the return of the app data folder I deleted previously. Sorry... think I"m going to tap out for now and see if the lightbulb comes on for somebody else that explains what I'm doing incorrectly. I'll stick with the older version until it breaks completely and then maybe try a full kodi re-install.

1) The new version doesn't have any data stored in the addon_data folder anymore.

2) I forgot to mention. If you're on Windows, you must install the MS VC 2015 runtime, just google it and install.

Please let me know if the vc2015 runtime did the trick.

EDIT: nvm, I might have found a way to prevent that dependency. Please test the next version 1.1.16 and let me know.

Now it's actually crashing to desktop....

https://paste.ubuntu.com/24793499/

As per previous tests... my personal spotify library tree still loads and is navigable, but attempts to play a track freezes kodi. This time however it's crashing rather than just returning a "one or more files couldn't be played" error. The crash is repeatable on every restart of kodi and attempt to play a spotify file. Local playback is fine. (WRT the previous post and internet speeds I'm a strong 190/50+ so that wouldn't be an issue).

I was still wondering if this is something strange going on with a file format mismatch so I changed my output to the speakers and disabled passthrough, but still no joy.

The only other option I can think of is a full re-install of kodi in an attempt to clear out residual app data. As I stated earlier... it's obviously being stored somewhere since my login information repopulated on a new install.


RE: Spotify for Kodi - borgybz - 2017-06-06

(2017-06-06, 14:47)sswilson Wrote:
(2017-06-06, 04:18)marcelveldt Wrote:
(2017-06-06, 00:46)sswilson Wrote: Ok, went through a fairly thorough shutdown/restart.......

Start kodi/uninstall 1.0.25/shut down kodi/restart PC/delete app data (more on this later)/restart PC/open kodi/install 1.1.15/cleared userinfo to default/shut down kodi/reboot PC/open kodi/verify login info still nil/enter login info/shut down kodi/reboot PC/Start Kodi (got the "default browser" message along with an open browser for authentification/ open plugin/playback freezes/close kodi/reboot PC/open kodi/open plugin/playback still freezes kodi/reverted back to 1.0.25/playback works

The only thing that's puzzling me is that the default login info populated after I'd deleted the app data folder I could find which suggests I'm not getting all of it. Where would I look for the app data or is there a folder name I can search for?

edit: Now I'm not even seeing the return of the app data folder I deleted previously. Sorry... think I"m going to tap out for now and see if the lightbulb comes on for somebody else that explains what I'm doing incorrectly. I'll stick with the older version until it breaks completely and then maybe try a full kodi re-install.

1) The new version doesn't have any data stored in the addon_data folder anymore.

2) I forgot to mention. If you're on Windows, you must install the MS VC 2015 runtime, just google it and install.

Please let me know if the vc2015 runtime did the trick.

EDIT: nvm, I might have found a way to prevent that dependency. Please test the next version 1.1.16 and let me know.

Now it's actually crashing to desktop....

https://paste.ubuntu.com/24793499/

As per previous tests... my personal spotify library tree still loads and is navigable, but attempts to play a track freezes kodi. This time however it's crashing rather than just returning a "one or more files couldn't be played" error. The crash is repeatable on every restart of kodi and attempt to play a spotify file. Local playback is fine. (WRT the previous post and internet speeds I'm a strong 190/50+ so that wouldn't be an issue).

I was still wondering if this is something strange going on with a file format mismatch so I changed my output to the speakers and disabled passthrough, but still no joy.

The only other option I can think of is a full re-install of kodi in an attempt to clear out residual app data. As I stated earlier... it's obviously being stored somewhere since my login information repopulated on a new install.

Same behavior here! Mine doesn't crash but simply freezes kodi. But now it's clear that it's not a connection problem cause you have exactly the same problem of me. Library is full accessible and navigable, but when trying to play a song in very rare cases it works, but most of times kodi freezes.
I can say to you that I tried to fully reinstall kodi and problem is the same


RE: Spotify for Kodi - sswilson - 2017-06-06

I've got a relatively fresh windows 10 install that's never had kodi on it so I'll give that a try sometime later this week.