Kodi Community Forum
Beta Spotify for Kodi - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: Add-on Support (https://forum.kodi.tv/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (https://forum.kodi.tv/forumdisplay.php?fid=148)
---- Thread: Beta Spotify for Kodi (/showthread.php?tid=265356)



RE: Spotify for Kodi - moppi1988 - 2017-09-25

(2017-09-25, 19:20)smallclone Wrote: Hi, Great addon, thanks for hard work. The problem I have on 2 "LibreELEC devices" (A Pi2 and an Intel NUC Celeron) is that every song stops at around the 3 minute mark. It then skips to the next song and does the same. I downloaded the repo and installed that way. I have the most up to date LibreELEC and the most up to date version of the spotify addon but can't seem to fix this issue.

It even does it when I try and use spotify Connect from my phone. Most odd.

You need a debug log?

With the most recent version I run in same issue as well (Win 10).
I've never had this issue before !


RE: Spotify for Kodi - Scavendoa2 - 2017-09-26

(2017-07-28, 14:23)marcelveldt Wrote:
(2017-07-28, 14:20)Scavendoa2 Wrote: Just reporting the fact that the addon seems to not working on Kodi Krypton.

- Hardware : Raspberry pi 3 b
- OS : libreelec
- Kodi version : Krypton 17.3
- Addon version : latest available

The addon keep asking me my credentials, again and again and again. I've checked them, they works fine.

Lot's of users running the add-on on Krypton with pi3 so seems to be specific to your system.
Would it be possible for you to send me your Kodi logfile after you got this login issue ?

Hello marcelveldt,

I've came back from holidays about a month ago, but didn't have enough spare time to give it a try.
Yet, last night, when I booted my Pi, the device appeared in my connected devices on my spotify app on my android, but i didn't change anything since my last try on august.
So I guess you must have provided a new version which fixed my issue with auto-update on, thank you.

Now it's working, I have some minor bug to submit :
1 - All the song cut before the end of it (about 10 secondes before, give or take)
2 - Sometime, the same song play two or three time (without repeat on)
3 - When I go the the next song with my android, it take a long time to be taken in account on the extension, most of the time it doesn't even work
4 - When i forward a little bit the song on my android, it's not taken in account on the extension, but the reverse operation work (forward on the extension in synchronized on the android app)

By the way, I'm a PHP Dev, so I don't know if I have the knowledge to help you, from time to time, but I would be glad to contribute.
I did some Java and C# years ago, as well.

Anyway, thank you for your great work !


RE: Spotify for Kodi - Didko - 2017-09-26

(2017-09-13, 20:54)marcelveldt Wrote:
(2017-09-12, 22:07)Didko Wrote: Same here!
So, I wasn't active for awhile, but now I upgraded my Pi and I've hit the same problem - a song longer than 8:30 min got muted. Was there any workaround for this?

Please test with next version 1.1.43 which will be available later today. I might have fixed it just now.

Unfortunately the problem isn't fixed. It still stops after 8-9 minutes. The new version even seems to be a bit more buggy, as I've had few songs which stopped playing after 2-3 minutes or the system completely crashed (the Kodi restarted without any obvious reason).


RE: Spotify for Kodi - zloe - 2017-09-27

I also experience the issue that long tracks stop playing after some time (4..8 minutes).
Actualy it is not really "stopping", just no sound is sent.
I had a visualization running once and noticed that also this did not get any sound info (all bars of the spectrum stayed at gound level).
The time info stil progressed, but no sound to hear.

plugin version 1.1.44
libreelec version 8.1.2 (but also noticed it with kodi 18 builds).
Raspberry PI 3

- zloe


RE: Spotify for Kodi - ray2301 - 2017-09-27

(2017-09-25, 22:07)moppi1988 Wrote:
(2017-09-25, 19:20)smallclone Wrote: Hi, Great addon, thanks for hard work. The problem I have on 2 "LibreELEC devices" (A Pi2 and an Intel NUC Celeron) is that every song stops at around the 3 minute mark. It then skips to the next song and does the same. I downloaded the repo and installed that way. I have the most up to date LibreELEC and the most up to date version of the spotify addon but can't seem to fix this issue.

It even does it when I try and use spotify Connect from my phone. Most odd.

You need a debug log?

With the most recent version I run in same issue as well (Win 10).
I've never had this issue before !

similar issue here also on windows 10. any song i play, plays till about 90% and then hangs. then it starts to stutter a bit and stops hanging kodi. reverted to 1.1.42 for now.


RE: Spotify for Kodi - foxstefano - 2017-09-27

The addon stopped working on my pc (Win10 64 bit, Kodi 17.4) since last summer: everytime I try to play a song, it appears a popup message "Spotty.exe no longer works"


RE: Spotify for Kodi - saustark - 2017-09-28

(2017-09-27, 23:32)foxstefano Wrote: The addon stopped working on my pc (Win10 64 bit, Kodi 17.4) since last summer: everytime I try to play a song, it appears a popup message "Spotty.exe no longer works"

On my similar setup I get the same popup, even the addon isn't in use, which is very frustrating.
For the moment i decided to delete the spotify addon, as this popup makes my whole KODI setup unusable.


RE: Spotify for Kodi - smallclone - 2017-09-28

(2017-09-27, 23:19)ray2301 Wrote:
(2017-09-25, 22:07)moppi1988 Wrote:
(2017-09-25, 19:20)smallclone Wrote: Hi, Great addon, thanks for hard work. The problem I have on 2 "LibreELEC devices" (A Pi2 and an Intel NUC Celeron) is that every song stops at around the 3 minute mark. It then skips to the next song and does the same. I downloaded the repo and installed that way. I have the most up to date LibreELEC and the most up to date version of the spotify addon but can't seem to fix this issue.

It even does it when I try and use spotify Connect from my phone. Most odd.

You need a debug log?

With the most recent version I run in same issue as well (Win 10).
I've never had this issue before !

similar issue here also on windows 10. any song i play, plays till about 90% and then hangs. then it starts to stutter a bit and stops hanging kodi. reverted to 1.1.42 for now.

Thanks for this. I rolled back to 1.1.42 and this advice seems to fix the issue on my Intel NUC but not on my raspberry pi.


RE: Spotify for Kodi - a1rwulf - 2017-09-28

(2017-09-21, 20:15)marcelveldt Wrote:
(2017-09-14, 23:03)a1rwulf Wrote:
(2017-09-03, 21:27)marcelveldt Wrote: Yes I have but as far as I know it's not okay to include binaries in an add-on for the official repo.
Unless you're willing to accept that ;-)

That's indeed right and still the case afaik.
But does the addon still depend on a closed source binary?

Quote:The add-on had a major refactor and is now no longer relying on libspotify.
Instead it will now utilize a slightly modified version of librespot (open source spotify sdk) with a big thanks to @plietar for creating this custom spotify SDK.
Also, it's no longer needed to have a webbrowser installed on the pi.

Made me think that it's not depending on closed sources anymore.

Indeed, it's completely independent of closed source but I precompile the (opensource) librespot/spotty for each platform as a binary.
Don't know if thats acceptable ?

Will discuss this internally, afaik there's more addons with the same requirement.
So let's see how a possible solution could look like.


RE: Spotify for Kodi - Saul in Oz - 2017-10-07

Fixed!
Mostly.
Version 1.45 on Kodi17.4 plays all of almost everything. One episode of 2:20 freeze but rapidly skipped to the next track. One freeze with error message spotify64.exe stopping working but otherwise works very well.

Interface is also a great deal faster.


RE: Spotify for Kodi - Mowa - 2017-10-08

Hi Marcel,
Unfortunately Spotify showing only blank screen again for the past week on both my HTPC and laptop.

- Hardware: HTPC; AMD A10-6800K, AMD A10-6800K, Crucial Ballistix Tactical 8GB
- Os: Windows 7 SP1 X64, Kodi 17.4
- Spotify V1.1.45 installed with the repo

Debug Log:
https://pastebin.com/yxnvcMaL

Log:
https://pastebin.com/tCS65DXu


RE: Spotify for Kodi - foxstefano - 2017-10-08

Same problem as usual with 1.1.45: "Spotty.exe stopped working"
Win10 64 bit, Kodi 17.4


RE: Spotify for Kodi - DarkHelmet - 2017-10-10

(2017-10-08, 02:00)foxstefano Wrote: Same problem as usual with 1.1.45: "Spotty.exe stopped working"
Win10 64 bit, Kodi 17.4

I have the same. Hard to pin down. Sometimes it takes hours of playback until I get that, sometimes it never comes and sometimes it comes pretty fast. Also looking through the kodi logs (which are huge mostly due to the time until that message shows up), there was nothing to be found there. And the message is a Windows message, not a Kodi message.


RE: Spotify for Kodi - MrGenius1 - 2017-10-10

I also have the Spotty.exe error and I have to uninstall the addon to get my Kodi back to being stable. I'm running Win 10 x64 with Kodi 17.4. I love this addon! Is there a workaround or anything to get is thing going?


RE: Spotify for Kodi - foxstefano - 2017-10-11

(2017-10-10, 17:12)MrGenius1 Wrote: I also have the Spotty.exe error and I have to uninstall the addon to get my Kodi back to being stable. I'm running Win 10 x64 with Kodi 17.4. I love this addon! Is there a workaround or anything to get is thing going?

It seems to be an unknown problem, it appeared in june and still no solution...