Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-04

(2016-09-04, 17:38)MichaelAnders Wrote: I cannot select VAAPI bob for example. Debug log shows:
...
It's a Beebox N3150. I tested some versions:
#903: broken (as stated)
#902: broken - found another post with the same error: 2407188 (post)
#901: works (no issues before ever either)

RIght, OK.

In #0901 I had PR:404 (from @fritsch) and PR10339 (from @fernetmenta), where VAAPI-Bob was working.

Then on 2 September, @FernetMenta cherry picked changes from PR:404 into PR10339 (closing the former), a decision which obviously broke VAAPI-Bob in the #0902 build.

That explains the VAAPI-Bob issue. Hopefully it can be fixed without opening a trac ticket.

Edit: You added the link to @nuc-LE's post - this is unrelated to your issue as the Chris Wilson patch is back as of #0903.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MichaelAnders - 2016-09-04

(2016-09-04, 17:59)Milhouse Wrote:
(2016-09-04, 17:38)MichaelAnders Wrote: I cannot select VAAPI bob for example. Debug log shows:
...
It's a Beebox N3150. I tested some versions:
#903: broken (as stated)
#902: broken - found another post with the same error: 2407188 (post)
#901: works (no issues before ever either)

RIght, OK.

In #0901 I had PR:404 (from @fritsch) and PR10339 (from @fernetmenta), where VAAPI-Bob was working.

Then on 2 September, @FernetMenta cherry picked changes from PR:404 into PR10339 (closing the former), a decision which obviously broke VAAPI-Bob in the #0902 build.

That explains the VAAPI-Bob issue. Hopefully it can be fixed without opening a trac ticket.

Edit: You added the link to @nuc-LE's post - this is unrelated to your issue as the Chris Wilson patch is back as of #0903.
Ok, I'll wait for an update on the issue and will then retest


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-04

@fritsch/@fernetmenta since #0902 it looks like VAAPI hardware acceleration is either not functioning at all, or being reported incorrectly - 720p/1080p videos that previously reported "ff-h264 (HW)" in PlayerProcessInfo now show as "ff-h264 (SW)". All VAAPI options are enabled.

Debug log playing 720p video (all VAAPI options enabled): http://sprunge.us/CQNY

This probably has something to do with it:
Code:
17:41:31  24.553089 T:140558567728896   ERROR: VAAPI::ConfigVAAPI - failed to init output

In addition, as reported by @MichaelAnders, several of the VAAPI deinterlace options are now missing - in #0901 we had "VAAPI - Motion compensated", "VAAPI - Motion adaptive", "VAAPI - Bob", "Deinterlace", "Bob" and "Off", but in #0902+ we only have Deinterlace/Deinterlace (half)/Bob/Blend/Off, and if you select any of these deinterlace methods in Video Settings, it always shows in PlayerProcessInfo as "yadif:1:-1:1".

Perhaps the failure to init VAAPI explains the missing VAAPI deinterlace modes.

Edit: Reverting PR10339 restore HW acceleration, though obviously there's no deinterlace option at all in Video Settings.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Repo1st - 2016-09-04

Thank you netradio is fxed now...
(Fix for netradio crashes (PR:10387))


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - cowboype - 2016-09-04

(2016-09-04, 15:25)Milhouse Wrote: In Kodi? No idea, ask in the Feature Requests section. If BD-J support is ever added in Kodi it's unlikely (IMHO) that support will be added to LibreELEC, unless someone packages BD-J support as an add-on.

Thanks. In libreelec i can watch BD-ISO, but without bd-j menus. I hope this feature soon as possible.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-09-04

@cowbope: If you implement it, it will even be faster :-)


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MichaelAnders - 2016-09-04

And while we're at it...

I cannot report on any Kodi 17 release that worked for this, I used an Nvidia Shield TV before the switch...

On my system (Beebox N3150, Onkyo TX-SR805 amplifiert, small Samsung LCD TV), I hardly ever get a working TV output and/or sound output.

Examples:
- I start the beebox, everything is turned on. I get no output at all. Initially I thought the system is hanging and rebooted, sometimes it worked. But mostly, I get no screen output at all, no sound either (feels like 80% of the cases)
- In other cases, I get the kodi UI but no sound. No UI sounds, no sound from movies etc. (15%
- Everything works right away (hardly ever)

Solution that always fixes it via ssh:
xrandr -s 1280x720

Kodi notices the change and after a few scones the kodi UI comes up and sound works if it did not before.

Maybe some race-condition, no idea - but it's pretty annoying. I'll get a new 65" SUHD Samsung tomorrow, maybe things change then - but that would just help me, not others Wink


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - fritsch - 2016-09-04

Remove the onkyo from the chain and retry. What you experience is for sure not normal.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MichaelAnders - 2016-09-04

(2016-09-04, 21:14)fritsch Wrote: Remove the onkyo from the chain and retry. What you experience is for sure not normal.
Yup, then it works fritsch - I even see a BIOS screen now immediately :o

Hmpf - sounds more like a BIOS issue or something then I guess... also that I get a weird resolution of something like 1368x768 instead of 1920x1080 or 1280x720...

Ok, I guess I'll contact Asrock then. Hopefully the brand new 65" will work though, I dont want to go back to Nvidia or an older NUC..

If that still fails - any way to add some manual cron job or something in libreelec to "force" mode set?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Roby77 - 2016-09-04

(2016-09-04, 21:14)fritsch Wrote: Remove the onkyo from the chain and retry. What you experience is for sure not normal.

Can't he resolve forcing edid and resolution as you suggested for me with Black screen at boot with denon avr ?


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Roby77 - 2016-09-04

(2016-09-04, 22:44)MichaelAnders Wrote:
(2016-09-04, 21:14)fritsch Wrote: Remove the onkyo from the chain and retry. What you experience is for sure not normal.
Yup, then it works fritsch - I even see a BIOS screen now immediately :o

Also with Denon i see asrock rarely even if i disabled ultra fast boot


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - MichaelAnders - 2016-09-04

(2016-09-04, 23:12)Roby77 Wrote:
(2016-09-04, 22:44)MichaelAnders Wrote:
(2016-09-04, 21:14)fritsch Wrote: Remove the onkyo from the chain and retry. What you experience is for sure not normal.
Yup, then it works fritsch - I even see a BIOS screen now immediately :o

Also with Denon i see asrock rarely even if i disabled ultra fast boot
Ultra fast boot is disabled on my system. Good in a way to hear I'm not alone with this issue...


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - john.cord - 2016-09-05

Chromebox and #903 --> no hardware decoding :-(


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Magoo32 - 2016-09-05

(2016-09-05, 01:55)john.cord Wrote: Chromebox and #903 --> no hardware decoding :-(

Same here.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

New LibreELEC.tv Krypton build #0904: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.2 #1 SMP Sun Sep 4 21:11:30 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160904211015-#0904-g3be9cfe [Build #0904]

Based on tip of LibreELEC.tv master (3be9cfe3, changelog) and tip of XBMC master (5bcf9ba7, changelog) with the following modifications:
  • Includes FernetMenta "VideoPlayer" patches
  • Includes latest kodi-platform master (c8188d82)
  • Includes latest libcec master (62b8520c, ahead +15)
  • Includes latest libnfs master (fac3a954, ahead +34)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: inputstream.mpd (4d50f576, +3), inputstream.rtmp (9c05b8dd), inputstream.smoothstream (b63ecbb4), peripheral.joystick (9e88033b, +33), pvr.argustv (299088b5), pvr.demo (01c68c88), pvr.dvblink (ea3d98cc), pvr.dvbviewer (f72c62ff), pvr.filmon (675c2b4e), pvr.hdhomerun (eef1bd15), pvr.hts (48b2e261), pvr.iptvsimple (a4c52558), pvr.mediaportal.tvserver (3c39bd0c, +7), pvr.mythtv (b1b426f3), pvr.nextpvr (4dabcf41), pvr.njoy (b5d65655), pvr.pctv (d6d969fe), pvr.stalker (bb9c0b10, +10), pvr.vbox (2750c92a), pvr.vdr.vnsi (40c45dc9), pvr.vuplus (7ab30d34), pvr.wmc (d9eac84f)
  • Includes commits from xbmc/master, ahead +5 (FernetMenta)
  • Exclude [env] kodi-999.99-PR10309.patch: Merged upstream
  • Exclude [env] kodi-999.99-Revert-PR10247.patch: Not required
  • Exclude [env] libcec-PR208.patch: Merged upstream
  • Include [env] patch: Add kodi binary addons (pvr, adsp, other)
  • Include [env] patch: Don't build ADSP addons
  • Include [env] patch: ffmpeg: Bump to 3.1.3-Krypton-Beta3 (e9002c3)
  • Include [env] patch: Fix memory leak in mesa 12.0.1 (fixed in 12.0.2)
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] PR:689: llvm: update to 3.9.0
  • Include [env] PR:690: Package updates
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: drm/i915: Fixes and diagnostics for Braswell (linux)
  • Include [pkg] patch: peripheral.joystick: Disable udev and see if stability improves (peripheral.joystick)
  • Include [pkg] patch: drm/i915: Fix backwards test in Chris Wilson patch (link) (linux)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Limit the depth of the display pipeline to the framebuffer (linux)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:10370: Add settings to control notification rumble duration and strength
  • Include [pkg] PR:10393: peripheral: Add backward compatability for older settings files
  • Include [pkg] PR:10400: VideoPlayer: fix lateframes if fps does not equal refresh rate
Build Highlights:
  1. ffmpeg: fix for pixellated thumbnails
  2. Restore old CEC settings filename
  3. llvm and various package updates (clean build)
  4. Fix broken VAAPI hardware acceleration (and deinterlace modes)
  5. Include mesa patch to fix memory leak
Build Details:
  1. LibreELEC.tv:
    • tvheadend42: update to 4.1.2236 (PR:688, 1 commit, 2 files changed)
    • docker: update to 1.12.1 (PR:691, 1 commit, 2 files changed)
    • rsyslog: initial addon (PR:684, 6 commits, 17 files changed)
  2. XBMC:
    • skin: remove all use of hyphen as none value (PR:10388, 1 commit, 69 files changed)
    • [Estuary] fix / unify PVR window breadcrumbs (PR:10381, 3 commits, 8 files changed)
    • [cmake/linux] Add target to execute tests with valgrind (PR:10350, 1 commit, 1 file changed)
    • VideoPlayer: ffmpeg, ignore pics before first key frame (PR:10391, 1 commit, 2 files changed)
    • VideoPlayer: catch silly CRedirectException, fixes crash (PR:10387, 1 commit, 1 file changed)
    • VideoPlayer: fix and cleanup deinterlacing methods (PR:10339, 12 commits, 49 files changed)
    • [cmake] fix sse detection (PR:10372, 4 commits, 12 files changed)
    • VideoPlayer: fix vaapi after 6cad53545815eb1cca65e9997a9382550d204ed7 (5bcf9ba7)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Fix memory leak in mesa 12.0.1 (fixed in 12.0.2)
    • Added: [env] PR:689: llvm: update to 3.9.0
    • Added: [env] PR:690: Package updates
    • Added: [pkg] PR:10393: peripheral: Add backward compatability for older settings files
    • Added: [pkg] PR:10400: VideoPlayer: fix lateframes if fps does not equal refresh rate