Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - dirtydesaster - 2016-09-05

VAAPI works now, but i have a lot of Drops @ vaapi-mcdi.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

(2016-09-05, 11:00)dirtydesaster Wrote: VAAPI works now, but i have a lot of Drops @ vaapi-mcdi.

There's a problem with PR10400. Try this build, #0904x which has a fix for PR10400 - it's much better now.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - porkchop999 - 2016-09-05

Yes 0904x works a lot better


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Roby77 - 2016-09-05

Yes.. works...thank you


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - mglae - 2016-09-05

(2016-09-05, 06:46)Milhouse Wrote:
  • Added: [env] patch: Fix memory leak in mesa 12.0.1 (fixed in 12.0.2)

As assumed the memory leak disappeared in #0904.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

Great, should bump to 12.0.2 tonight.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-09-05

Is there anyway I can get around the 8-bit patch in the builds? I want to keep testing Smile


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - schumi2004 - 2016-09-05

(2016-09-05, 19:03)mglae Wrote:
(2016-09-05, 06:46)Milhouse Wrote:
  • Added: [env] patch: Fix memory leak in mesa 12.0.1 (fixed in 12.0.2)

As assumed the memory leak disappeared in #0904.
This is great news. Going to upgrade asap.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Boulder - 2016-09-05

I got a Kodi crash with #0904x. I only put the file in the update folder, SSH'd in and rebooted from there. Then I left the box running by itself so I don't know what happened. I just noticed crashlogs when retrieving normal Kodi logs.

http://pastebin.com/G9ufP92Z


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-09-05

@Milhouse any chance of getting this patch in there?

https://patchwork.freedesktop.org/series/8024/


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

(2016-09-05, 20:26)Boulder Wrote: I got a Kodi crash with #0904x. I only put the file in the update folder, SSH'd in and rebooted from there. Then I left the box running by itself so I don't know what happened. I just noticed crashlogs when retrieving normal Kodi logs.

http://pastebin.com/G9ufP92Z

Presumably this was a one-off crash? Has it happened again?

It looks to be Python related - there's a Python deadlock fix in tonight's build (PR10399) though I can't really tell you much about it as trac.kodi.tv is offline.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

(2016-09-05, 21:13)_Spook_ Wrote: @Milhouse any chance of getting this patch in there?

https://patchwork.freedesktop.org/series/8024/

OK, thanks.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - ferdyvw - 2016-09-05

Hi, noob question maybe, but i have been using OpenElec and libreelec for the last 5 years and today upgraded to a cherrytrail box, and ran into the hdmi-audio cherrytrail issues.

Now i just found this thread and learned that the millhouse versions of libreelec included a fix for this problem at some point. Is that still the case, for the latest version?

Or should i look in to a more generic version?

Thanks a lot.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-05

Yes. And the Cherrytrail patch is also in the latest LibreELEC 8 alpha release, 7.90.005.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - wizziwig - 2016-09-06

(2016-09-05, 19:47)_Spook_ Wrote: Is there anyway I can get around the 8-bit patch in the builds? I want to keep testing Smile

I figured out an alternative to that patch but still working out a clean way to add it to Intel's driver code. It fixes both the missing 44.1 kHz audio on some TV/AVR and the frame skips at 59.940 refresh. Original patch is not required so pipeline can stay at 12-bit like the stock 4.7 kernel. Dithering is disabled so I don't think it looks any different than 8-bit (at least on my TV). Extra bits are just padded. I only test on HDMI so your DisplayPort->HDMI setup might still have those two bugs I mentioned but should work as well as older OpenElec builds for you.

That 8-bit patch is still a good idea to keep in the long run since Kodi is unlikely to take advantage of 12-bit for a long time. Since I don't have access to any Intel DisplayPort hardware, you will need someone else to look at why it doesn't work for you. The DP code is very complicated to debug. Hopefully Intel can fix it.