Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mule1 - 2016-04-29

(2016-04-26, 20:29)mule1 Wrote:
(2016-04-24, 15:29)mule1 Wrote:
(2016-04-21, 20:12)mule1 Wrote: With the latest build #0420 .ts-files are unwatchable because the hiccups begin right after the start of the playback. With builds #0419 and before the hiccups first start after some skipping as described above.
Please tell me how i can help to find the reason for this issue.

I did some more testing and have to correct my above findings (next time i will do some deeper tests before posting, sorry for that!):
The issue is not specific to the milhouse builds (neither openelec, nor libreelec version) and is existing in fritsch builds too. It was wrong to say that it is general issue with .ts-files. Until now i found the issue only on recordings from german fta channels which are being recorded in 720p with dolby 5.1.The playback hiccups after some skipping only appear when vaapi is set as preferred renderer.
Hopefully this helps to track down the reason for the issue.
Am I doing something wrong or why seems this issue to be ignored?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-29

(2016-04-29, 00:27)mule1 Wrote: Am I doing something wrong or why seems this issue to be ignored?

People usually comment when they have something to add, either a question to elicit more information, or ideally a solution. Silence doesn't mean you're being ignored, it most likely means nobody has a clue why your setup is behaving the way it is. Maybe uploading a sample .ts file that can be used to reproduce the problem will help? Although I'm not giving you any guarantees that it will.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Milhouse - 2016-04-29

New LibreELEC.tv Krypton build #0428: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc5 #1 SMP Thu Apr 28 21:04:42 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160428210317-#0428-g8b0c952 [Build #0428]

Based on tip of LibreELEC.tv master (8b0c9525, changelog) and tip of XBMC master (4015436f, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. New 4.6.0-rc5 kernel
  3. Updated Skylake 1.26 firmware
  4. New LibreELEC branding
  5. [skin] save skin settings early on exit - fix for shortcuts etc. not being saved?
Build Details:
  1. LibreELEC.tv:
    • procps-ng: Default to old top colour scheme (PR:238, 1 commit, 1 file changed)
    • noobs: update slides to new branding (PR:246, 1 commit, 14 files changed)
    • settings: bump to v0.7.3 (PR:249, 1 commit, 1 file changed)
    • LibreELEC: update logo (PR:243, 1 commit, 4 files changed)
    • libcec: update imx6 patch to work with p8-platform (PR:220, 1 commit, 1 file changed)
    • kodi-theme-Estuary: update to new LibreELEC icon (PR:250, 1 commit, 1 file changed)
    • amlogic CEC adapter moved to project dirs (PR:254, 1 commit, 2 files changed)
    • changed LibreELEC URLs in (mainly) descriptions to https://libreelec.tv (PR:253, 1 commit, 36 files changed)
    • pulseaudio: enable neon support only if neon is avaible (PR:225, 1 commit, 1 file changed)
    • linux: update i915 firmware for skylake (PR:228, 1 commit, 4 files changed)
    • kodi: configure volume steps to 20 by default (PR:174, 1 commit, 1 file changed)
    • kodi: add os.openelec.tv to manifest while we still ship it (PR:258, 1 commit, 1 file changed)
    • mtools: removes installing of floppyd, manual and info (PR:257, 1 commit, 1 file changed)
  2. XBMC:
    • Various minor build fixes (PR:9414, 5 commits, 4 files changed)
    • [Win32] a set of fixes for windows. (PR:9678, 6 commits, 10 files changed)
    • [dxvahd] fixup! dxva processor after 39542765368b2f913f49d0a6e4fe91e1… (PR:9680, 1 commit, 1 file changed)
    • [cmake] Some more fixes (PR:9676, 5 commits, 6 files changed)
    • [doxygen] Fix and improve doxygen parts (PR:9685, 2 commits, 5 files changed)
    • Configure cleanup, this removes some leftovers in configure.ac (PR:9401, 2 commits, 1 file changed)
    • [depends] - build fixes for libxslt and openssl (PR:9289, 4 commits, 2 files changed)
    • Chop out anything before Android 5 and don't build with amlogic (PR:9688, 2 commits, 2 files changed)
    • configure.ac: Add target_platform=target_linux for powerpc (PR:9682, 1 commit, 1 file changed)
    • xbmc_pvr_types.h: Fix compilation with gcc6 (PR:9677, 1 commit, 1 file changed)
    • [droid] [refclock] do not stop callback when focus is lost. (PR:9690, 1 commit, 1 file changed)
    • [VideoPlayer] fixup! stalls after seek. (PR:9694, 1 commit, 1 file changed)
    • [pvr] needs_configuration is deadcode now (PR:9673, 1 commit, 2 files changed)
    • [cleanup] remove unused depends (PR:9686, 3 commits, 17 files changed)
  3. libnfs:
    • zdr string decode: don't memcpy when src and dst pointers are the same (a5408bfa)
    • Add win32 magics to example programs (b3c41060)
  4. inputstream.smoothstream:
    • add expat dependency (PR:1, 1 commit, 2 files changed)
    • Correct PTS after seek (7a8734f9)
    • Version bump 1.0.5 because of seek issue (a21e82c6)
    • fix track renewal on stream change seek (5d784e54)
  5. pvr.argustv:
    • More CURL Post (PR:51, 1 commit, 1 file changed)
    • adapt to PVR API 5.2.0 (PR:53, 1 commit, 2 files changed)
  6. pvr.dvbviewer:
    • fix timers (PR:36, 2 commits, 3 files changed)
  7. pvr.hdhomerun:
    • adapt to PVR API 5.2.0 (PR:23, 1 commit, 3 files changed)
  8. pvr.pctv:
    • adapt to PVR API 5.2.0 (PR:36, 1 commit, 3 files changed)
  9. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
    • Added: [pkg] PR:9696: [xbmc/xbmc] [skin] save skin settings early on exit



RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - FreakinSyco - 2016-04-29

Can anyone elaborate what "VSyncOff" in the Codec Info overlay is showing? A google for the term doesn't result in much.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - SmallwoodDR82 - 2016-04-29

moved to #0428 and random black flashing screen is now much worse, happens every few seconds now.

This is a Shuttle XH61V (w/ Intel i3-3225 CPU) to a Denon AVR-1612 out to a LG Plasma.

Here is dmesg - http://sprunge.us/NVEX

Here is debug - http://pastebin.com/UVSN8zRM

DRM guys seem to be stumped also as my past bug report has went quiet. They asked me to use the kernel from kodi 15.0 on this newer build but I'm not 100% sure how to do that or if it's even possible.

However I looked at the Kodi logs this time and saw this "19:58:30 50.212917 T:140021535389760 DEBUG: NotifyXRREvent - notify display reset event"
Edit: Nevermind above comment, just realized that was when I powered off just the receiver to see if changing the power up order would matter.

But when I move back to Kodi 15.0 all is good. No black screens and no issues at all. Just for the hell of it I did swap all HDMI cables involved but no change.

Any ideas?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - fritsch - 2016-04-29

Quote:[ 2.057769] Hardware name: Shuttle Inc. XH61V/FH61V, BIOS 1.05 05/03/2013
[ 2.057771] Workqueue: events output_poll_execute
[ 2.057773] 0000000000000000 ffffffff812b6f16 ffff880119f57b98 0000000000000000
[ 2.057774] ffffffff8103a756 0000000000000000 ffff880119f57bf0 0000000000000000
[ 2.057775] 000000000000003c ffff8800d0c54e08 0000000000000001 ffffffff8103a7b5
[ 2.057775] Call Trace:
[ 2.057778] [<ffffffff812b6f16>] ? dump_stack+0x5a/0x6f
[ 2.057780] [<ffffffff8103a756>] ? __warn+0xc8/0xe1
[ 2.057781] [<ffffffff8103a7b5>] ? warn_slowpath_fmt+0x46/0x4e
[ 2.057783] [<ffffffff81848087>] ? _raw_spin_lock_irqsave+0xe/0x29
[ 2.057784] [<ffffffff81378fed>] ? drm_wait_one_vblank+0x123/0x13c
[ 2.057786] [<ffffffff810636ce>] ? wake_up_atomic_t+0x1f/0x1f
[ 2.057788] [<ffffffff814e01e7>] ? ironlake_crtc_enable+0xac9/0xb90
[ 2.057789] [<ffffffff814c56d7>] ? hsw_write64+0x5/0x5
[ 2.057790] [<ffffffff814dddbb>] ? intel_atomic_commit+0x5c2/0x101c
[ 2.057792] [<ffffffff8138ae6c>] ? drm_atomic_check_only+0x273/0x52a
[ 2.057794] [<ffffffff8137127d>] ? restore_fbdev_mode+0x109/0x223
[ 2.057795] [<ffffffff81372a3d>] ? drm_fb_helper_restore_fbdev_mode_unlocked+0x2b/0x5e
[ 2.057796] [<ffffffff81372aa6>] ? drm_fb_helper_set_par+0x36/0x41
[ 2.057797] [<ffffffff81372a0a>] ? drm_fb_helper_hotplug_event+0xab/0xb3
[ 2.057798] [<ffffffff81368cc1>] ? output_poll_execute+0x12b/0x15a
[ 2.057800] [<ffffffff8104b188>] ? process_one_work+0x139/0x1d4
[ 2.057801] [<ffffffff8104b6d3>] ? worker_thread+0x1d3/0x29e
[ 2.057802] [<ffffffff8104b500>] ? rescuer_thread+0x2b6/0x2b6
[ 2.057803] [<ffffffff8104f1ff>] ? kthread+0x95/0x9d
[ 2.057804] [<ffffffff81848382>] ? ret_from_fork+0x22/0x40
[ 2.057805] [<ffffffff8104f16a>] ? init_completion+0x1d/0x1d
[ 2.057808] ---[ end trace 8421c749f3f31a64 ]---

Kernel bug with your hardware. Post your Xorg.0.log please.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - smiffy1989 - 2016-04-29

Still got the ARGUS TV channel logo missing issue with 428 (noticed there had been a couple of commits, thought one might have been a fix so thought I'd give it a try!). Can get new logs if needed.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - maluc - 2016-04-29

Hi!
I updatet from OE to LE (Think that Milhouse only develope on LE for the future?). Works so far, but I can´t update it through OE Dev Updater. Is there a chance to install a LE Dev updater Add-on?

I use it with RPi3 and Nuc (generic). On my Nuc I can´t disable some menu entries - maybe I can use another skin for it?


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - kanyck - 2016-04-29

Post #10 will help 2312564 (post)


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-04-29

neox387 linked a zip version ready to install for libreelec devupdate

https://github.com/miigotu/script.libreelec.devupdate/blob/master/README.md#instructions


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - gjwAudio - 2016-04-29

(2016-04-28, 04:45)wesk05 Wrote:
(2016-04-27, 21:32)gjwAudio Wrote: c) are you aware of any video test-files that can be used to determine the offset(s) needed for a users particular setup ?
This test pattern is from Spears & Munsil HD Benchmark and is for 23.976 frame rate. You can test Dolby Digital/Dolby Digital TrueHD/DTS-HD Master Audio. First two tracks play from center channel, the other two play front L & R - AV-Sync test pattern. The beep tone is supposed to start in the middle of video frame "0" (after 20ms).

@wesk05

Thank you for the reply, and the test file. I will check it out and see if I get any closer to determining a "standard offset" for my mix of equipment.

There may be too many variables to control for... I know I'm pushing the boundaries of my NUC by asking it to play 8-bit/HEVC. It struggles through with software decoding - and the variability of things that could affect SW decoding may ultimately prevent one set-and-forget offset value.

This evening I watched some HEVC TV episodes with +0.125 msec offset (ie: audio leading video), which got awfully close to looking correct.

Thanks again for helping.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - b0mb - 2016-04-29

here is my log of GUI crash that happens with all builds after 21.04.

http://sprunge.us/WZEU


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - mule1 - 2016-04-29

(2016-04-29, 00:38)Milhouse Wrote:
(2016-04-29, 00:27)mule1 Wrote: Am I doing something wrong or why seems this issue to be ignored?

People usually comment when they have something to add, either a question to elicit more information, or ideally a solution. Silence doesn't mean you're being ignored, it most likely means nobody has a clue why your setup is behaving the way it is. Maybe uploading a sample .ts file that can be used to reproduce the problem will help? Although I'm not giving you any guarantees that it will.
Thanks for your answer Milhouse. Didn't want to sound offending or impatient in any way. I was just wondering if i didn't deliver the needed information so you are able to analyze this issue. I will upload a sample as you suggested asap.


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - Roby77 - 2016-04-29

(2016-04-29, 13:32)b0mb Wrote: here is my log of GUI crash that happens with all builds after 21.04.

http://sprunge.us/WZEU

could you please append to https://bugs.freedesktop.org/show_bug.cgi?id=95196

also if you have error in /sys/class/drm/card0/error


RE: LibreELEC Testbuilds for x86 (Kodi 17.0) - sunnyfunny - 2016-04-29

(2016-04-29, 13:32)b0mb Wrote: here is my log of GUI crash that happens with all builds after 21.04.

http://sprunge.us/WZEU

Same Problem on my NUC3700

@millhouse

can you switch back to Kernel which is used in builds before 21.04?