Kodi Community Forum
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Printable Version

Kodi Community Forum (https://forum.kodi.tv)
+-- Forum: Support (https://forum.kodi.tv/forumdisplay.php?fid=33)
+--- Forum: General Support (https://forum.kodi.tv/forumdisplay.php?fid=111)
+---- Forum: Linux (https://forum.kodi.tv/forumdisplay.php?fid=52)
---- Thread: v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0) (/showthread.php?tid=269815)



RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-15

Ok, we may now need mesa 12.1. I'll see what I can do tomorrow.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - alxtr1bal - 2016-09-15

(2016-09-15, 02:23)Milhouse Wrote: Ok, we may now need mesa 12.1. I'll see what I can do tomorrow.

May be that's it, because i tested mesa 12.1 git on an elementary os with 4.8rc6, the rx460 was working on this.
(https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa)


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-15

(2016-09-15, 01:28)madmarkym Wrote: It certainly looks like we are getting a bit closer now. We are booting into a blacks screen with a mouse cursor, there were no on screen errors though.
Here are my logs including xorg this time, it looks like there were a few modules that failed to load
dmesg: http://sprunge.us/FjMe
xorg: http://pastebin.com/TQsvyXdf

Mesa 12.0.3 released today, with a number of RadeonSI updates.

Two builds to try with the RX460/470/480:

#0915x - kernel 4.7.4, mesa 12.0.3
#0915y - kernel 4.7.4, mesa 12.1.0-devel, latest libdrm with updated amdgpu support

Can you let me know which (if any) work with the RX4x0 cards.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - madmarkym - 2016-09-15

No problem as soon as I get home from work I will test both


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - madmarkym - 2016-09-15

Quick test of 0915x before I left. Same black screen

xorg log: http://pastebin.com/LSQPzw9y
dmesg log: http://sprunge.us/VIRW


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-15

Let's hope #0915y is a winner...


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-09-15

(2016-09-14, 23:31)Milhouse Wrote:
(2016-09-13, 22:25)_Spook_ Wrote: Cool. I will test it tomorrow on the other NUC. Is the LSPCON patch in there also?

How is #0913y (4.8-rc6 kernel with 4K patch, and without Chris Wilson 8bpc patch)?
@Milhouse

No go. But I think I might have figured out whats causing the problem specifically for me.

So, my LG OLED 65E6 TV has a feature called HDMI Ultra Deep Colors which, among other features, enables HDR on that HDMI input. With HDMI Ultra Deep Colors ENABLED and this 4k patch or the Chris Wilson 8pbc patch I am not able to get a proper HDMI signal. This combined with the fact that the NUC6i7KYK does not have a NATIVE HDMI port but uses a chip ( http://www.paradetech.com/products/displayport-format-converters/ps175/ ) to transform the DisplayPort signal to HDMI 2.0 signal (LSPCON).

This combination causes issue. But I would think that the main issue is the chip/LSPCON. That is based on the fact that HDMI Ultra Deep Colors are enabled with the NUC6i5SYK that has a native HDMI 1.4 output.

So, for now I will just use that NUC6i5SYK. But, this could be a problem when the next generation NUCs are released in Q1-17. From the leakes it looks like all of them will have the same chip and no native HDMI port. That conclusion again is based on the fact that Kaby Lake does not have native HDMI 2.0 and all Kaby Lake NUCs will have HDMI 2.0 output.

I could also just disable HDMI Ultra Deep Colors on HDMI2 input on the TV or just use another HDMI input. But I want everything trough the AVR and be able to watch HDR material from my Shield and Panasonic UHD player.

So, no biggie for me. But if you want to play with this with me you could generate a build without the 4k patch, one with the 4k patch and lspcon patch and one with just the lspcon patch. But I know it's alot of work so again no biggie Smile


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - alxtr1bal - 2016-09-15

(2016-09-15, 19:07)Milhouse Wrote: Let's hope #0915y is a winner...

Unfortunately ... nope ... same behavior : i reach a black screen with the mouse cursor.

I'll check the logs as well


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - madmarkym - 2016-09-15

Yes I am afraid it has failed :-(

xorg: http://pastebin.com/vQbajica
dmesg: http://sprunge.us/SdNL


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - amarinho - 2016-09-15

Black screen with mouse cursor on both builds.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-15

Bummer. I'll include the new mesa and libdrm in tonight's build anyway.

@_Spook_ I'll do some 4.8-rc6 builds for you tomorrow. They will include the new mesa/libdrm and powerplay so might be worth testing RX4x0 cards too.


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - _Spook_ - 2016-09-15

Thanks! Appreciate it Smile


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - alxtr1bal - 2016-09-15

Here is kodi crash log for the test with RX460

http://sprunge.us/eBDR


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - alxtr1bal - 2016-09-15

May be we could try also the 4.8rc6 with mesa 12.1 and libdrm
with the CONFIG_DRM_AMD_POWERPLAY=y
and maybe this one :
CONFIG_DRM_AMDGPU_CIK=Y

source
https://linuxconfig.org/getting-the-rx-480-running-with-amdgpu-on-linux


RE: LibreELEC Testbuilds for x86_64 (Kodi 17.0) - Milhouse - 2016-09-15

(2016-09-15, 21:55)alxtr1bal Wrote: and maybe this one :
CONFIG_DRM_AMDGPU_CIK=Y

Pretty sure CIK is for older pre-Polaris GPUs, but what the hell...